Dell Studio 1737 Battery and AC Adaptor problems

Hi I have a dell studio 1737 laptop. It was working fine until I noticed that the battery wasnt charging. I heard the ac adaptor buzzing a bit so I figured the ac adaptor was on its last leg. So I ordered a new one. That didnt charge the battery. So I ordered a new battery. Still nothing charging.
I shut the laptop down, removed the battery(new and old) and tried running the laptop just off the old ac adaptor.
It boots up fine and is usable but I cannot get the battery to charge whether its the new battery/ac adaptor or the old ones.
Is there anything that possibly went on the board itself?????
I have been doing some research but cant find much answers out. I read some other people having the same problem but nothing answered in several forums I have read.
3 answers Last reply
More about dell studio 1737 battery adaptor problems
  1. spiderxx,

    There is some information on the Dell Community Forum that discussing laptop battery charging issues. You can copy and paste the link below to review it and if needed contact the Dell Laptop Forum Liaison Dell-Terry B.

    http://en.community.dell.com/support-forums/laptop/f/3518/t/19369809.aspx

    Thanks,
    Dell-Jesse
  2. thank you for the post.
  3. spiderxx said:
    thank you for the post.

    I know this is an old post but I found it when looking for my own problem of a new battery not being recognised in an old Studio 1737.
    The original battery was only lasting 15 minutes so ordered a new one from ebay (A third party low cost one bought Jan 2014), Plugged it in and got the message, "battery not recognised, laptop will not charge the battery"
    Doh !
    After searching a few sites for an answer, I tried updating the BIOS (new battery was still installed at this point. The update went from A02 to A05 and it worked a treat, no more message. Battery charges fine.
    I am not saying that was Spiderxx's problem but it certainly worked for mine.
Ask a new question

Read More

Dell Battery Laptops Computers