Sign in with
Sign up | Sign in
Your question
Solved

Realtek sound drivers

Last response: in Windows 7
Share
July 13, 2009 6:38:38 PM

so I upgraded to windows 7, but I haven't been able to get my audio to work.

I installed all the drivers and my computer recognizes that I have the most updated drivers. Everything is plugged in correctly and even when I do sound tests it works. But for everything else, like itunes or youtube, nothing comes from my speakers.

my onboard sound is Realtek ALC888 and my motherboard is GIGABYTE GA-EP43-DS3L

Thanks

More about : realtek sound drivers

July 14, 2009 8:43:47 AM

I had issues some days ago with my sound, also using Windows 7, I replaced an upgraded driver version for ALC889A back to the drivers supplied with my motherboard and everything seems to be fixed.

Maybe that could work for you too if you have the original driver disc.

.C.
m
0
l

Best solution

July 14, 2009 3:30:04 PM

I had a problem with the realtek sound on my gigabyte board not to long ago. Found out that for some reason windows set it play for the front audio ports by deafault. Pretty easy to fix and might be something you want to check on.
Share
a b $ Windows 7
December 7, 2012 9:53:59 PM

Yep - I had similar problems - sound OK after boot up, then half an hour later no sound. I've got Realtek ALC898 on ASRock X79 Extreme 3 running Windows 7 Home Premium 64 bit.

If I rebooted the problem was fixed again - for the next half hour anyway. I tried different speakers - same problem. I tried various Realtek drivers - 2009, 20010, 20011 and 2012 - all did the same. I disabled the Realtek and used Microsoft sound - same problem still.

I also started getting other problems - Steam wouldn't load, COD wouldn't load then on shut down it would do a "Logging Off" for over half an hour. I started to suspect that there was a problem that was affecting a variety of functions.

So maybe it was Windows. The problem started a week ago so I did a System Restore to before then and hey presto - so far no problems. But don't forget to turn off your power save mode when doing a restore - the PC didn't like going to sleep during the middle of a Restore. And now I don't let Windows do automatic updates. I vet them first.

I hope my 5 days of stuffing around benefits someone.
m
0
l
!