Sign in with
Sign up | Sign in
Your question

Rise of Nations Black Screen on Startup

Last response: in Video Games
Share
August 3, 2004 6:21:00 PM

Archived from groups: microsoft.public.games.discussion (More info?)

Hello,

I hope all are doing well here today. As the Subject
indicates I am having a bit of time trying to play Rise of
Nations. It will start up and play 3 different cut scenes
then after the 3rd cut scene the screen goes black and I
have to reset my computer to reboot.


I am using win2k with enough memory, cpu speed etc to play
this game. I need help from YOU to resolve this issue as
I stumbled into something interesting.

After I exhausted all avenues, DX6.0c, updated Radeon 9800
drivers, updated Asus MB drivers. I decided to reinstall
win2k as dxdiag would not recognize my vga card nor my
SoundMax drivers correctly (indicating problems). After
the reinstall I simply installed the DX9.0 striaght from
the Rise of Nations CD and WHAM!!!! IT WORKED FOR THE
FIRST TIME in 1 WEEK!!!

However, do to SP4 and Internet Explorere 5.0 conflicts
(as SP5 and IE 6.0 with SP1 was still in the registry) I
had to reinstall SP5 and IE 6.0 with SP1. As you problem
know I was getting all kinds of lock ups, error messages,
etc. and it was a pain to deal with. However, after
installing SP5 and IE 6.0 with SP1 I immediately wanted to
play Rise of Nations. To my surprise I recieved the same
Black Screen as before. This implies that SP5 with IE6.0
with SP1 somehow conflicts with Rise of Nations through
DX9.0 (as I notice some DX files you delete will re-appear
after 20 seconds or so. Therefore if there are new files
for DX 9.0 from 9.0c, 9.0 will simply revert them back
from 9.0c. Thus creating a problem when trying to upgrade
DX 9.0! In essence, you never truly upgrade all of DX
components from 9.0 to 9.0c thus causing instability
issues with you attempt to use Direct 3d Acceleration,
Direct Draw Acceleration and AGP Texture Acceleration.
Thus getting a blank screen when the computer enables
those features.

This is what I know so far. All of it from a technical
stand point may/may not be correct verbage. However, the
content of what I said is accuracte and needs to be
address by the Tech staff here at MS!
Anonymous
August 4, 2004 9:20:17 AM

Archived from groups: microsoft.public.games.discussion (More info?)

Correct,

I had to download SP4 not SP5.
Why does MS affliate and produce games that are not
compatible with SP4?

>-----Original Message-----
>Hello,
>
>I hope all are doing well here today. As the Subject
>indicates I am having a bit of time trying to play Rise
of
>Nations. It will start up and play 3 different cut
scenes
>then after the 3rd cut scene the screen goes black and I
>have to reset my computer to reboot.
>
>
>I am using win2k with enough memory, cpu speed etc to
play
>this game. I need help from YOU to resolve this issue as
>I stumbled into something interesting.
>
>After I exhausted all avenues, DX6.0c, updated Radeon
9800
>drivers, updated Asus MB drivers. I decided to reinstall
>win2k as dxdiag would not recognize my vga card nor my
>SoundMax drivers correctly (indicating problems). After
>the reinstall I simply installed the DX9.0 striaght from
>the Rise of Nations CD and WHAM!!!! IT WORKED FOR THE
>FIRST TIME in 1 WEEK!!!
>
>However, do to SP4 and Internet Explorere 5.0 conflicts
>(as SP5 and IE 6.0 with SP1 was still in the registry) I
>had to reinstall SP5 and IE 6.0 with SP1. As you problem
>know I was getting all kinds of lock ups, error messages,
>etc. and it was a pain to deal with. However, after
>installing SP5 and IE 6.0 with SP1 I immediately wanted
to
>play Rise of Nations. To my surprise I recieved the same
>Black Screen as before. This implies that SP5 with IE6.0
>with SP1 somehow conflicts with Rise of Nations through
>DX9.0 (as I notice some DX files you delete will re-
appear
>after 20 seconds or so. Therefore if there are new files
>for DX 9.0 from 9.0c, 9.0 will simply revert them back
>from 9.0c. Thus creating a problem when trying to
upgrade
>DX 9.0! In essence, you never truly upgrade all of DX
>components from 9.0 to 9.0c thus causing instability
>issues with you attempt to use Direct 3d Acceleration,
>Direct Draw Acceleration and AGP Texture Acceleration.
>Thus getting a blank screen when the computer enables
>those features.
>
>This is what I know so far. All of it from a technical
>stand point may/may not be correct verbage. However, the
>content of what I said is accuracte and needs to be
>address by the Tech staff here at MS!
>
>
>.
>
!