Sign in with
Sign up | Sign in
Your question
Solved

Replacing PSU in Dell Studio XPS 435MT

Last response: in Computer Brands
Share
October 17, 2012 1:38:40 AM

Hello, Tom's Hardware, you lovely folks! You guys totally helped me put together my beautiful build, and now I hug it and think of you. :love: 

ANYhow... we've got a Dell Studio XPS 435MT that won't turn on at all. I did some Googling and found this topic: http://en.community.dell.com/support-forums/desktop/f/3... . There people note the MOBO light being on and the fans very briefly turning on, both of which I've got going on here, and it sounded like most people just ended up buying a new PSU. So, that's my intention. But for the record, I'll describe the problem:

Computer was shut down normally. Next day, tap power button, won't turn on. The green LED in the back is lit, so power is being received. If you tap the power button, there's a brief light on the power button and the fans spin very briefly before stopping. I opened up the case and the MOBO light is on.

So, for a replacement PSU I was thinking of the CORSAIR Builder Series CX500 V2 500W ( http://www.newegg.com/Product/Product.aspx?Item=N82E168... ) . But there's also a PSU billed as a replacement for this specific model, listed here: http://www.ebay.com/itm/NEW-480W-Power-Supply-Replace-D... .

Should I try to match the 480 wattage, or will a 500W be okay? We don't plan on upgrading the computer in any way at this time.

Thoughts and suggestions? Thanks a million in advance! :bounce: 

Best solution

October 17, 2012 2:23:06 AM
Share

Could be psu.
500 watt would be fine.
November 24, 2012 6:51:44 PM

Best answer selected by Velti.
!