Sign in with
Sign up | Sign in
Your question

Possible CPU Problem

Tags:
Last response: in CPUs
Share
June 16, 2003 9:01:02 PM

Let me begin by listing my basic setup. This is my first home-built system:
--AMD Athlon XP 2800+ (Barton Core)
--ASUS A7N8X Deluxe, PCB 2.0 (C1003 BIOS version)
--1 GB Crucial/Micron Technologies DDR2700 RAM
--ATI Radeon 9800 Pro (256 MB)

Now to my problem. When I finished building my PC, I decided to run a 3DMark2001SE benchmark just to burn it in--"christen" it, if you will. To my surprise, it almost immediately crashed to the desktop. After much testing and updating drivers, the problem persisted, and it even got to the point where now I'm having random reboots. Microsoft prompted me to download a RAM test one day after reporting an error. They said it was most likely a hardware issue. I've downloaded multiple (OS-independent) memory tests, and I've found that when the cache is enabled, errors pop up continuously; however, when it is disabled, everything checks out clean.

Just to be safe, I also downloaded a (OS dependent) CPU tester. I set it up for its incredibly long (six-hour) diagnostic testing run. After a mere four minutes, I got an error telling me that the quicksort test had failed.

I’ve asked around to AMD, Crucial, the maker of my RAM stress test program, and miscellaneous forums, and so far, I haven’t gotten a response as to what my problem is. Hopefully some kind soul on the TH forums will help me.

My belief is (as a *practically* A+ certified person, long story) that the problem has something to do with the cache. I don’t know what cache it’s referring to, though. Is it the CPU’s L1 or L2 cache, a hard drive cache (BTW, I have a Western Digital WD800JB hard drive, just for reference), or some other form of cache?

Any help is appreciated. Here’s what I’ve tried so far:
--Updating all drivers (except for the BIOS, which I’ve been told shouldn’t be done unless necessary)
--Updating Windows XP
--Underclocking the RAM (more specifically the CAS latency, from 2.5 to 3.0)

More about : cpu problem

June 16, 2003 9:28:46 PM

Sounds like its got to be the cache on the Barton causing the problems. Test your system with a different CPU if you can.
June 16, 2003 11:30:00 PM

Sounds like it could be a PSU problem. What are you using?
-Brett
Related resources
June 16, 2003 11:39:37 PM

When you say the test passes with the cache disabled then it's pretty much a closed case. Test a different CPU in there mang.

If it was the CPU then it was probably damaged in shipping because AMD never makes mistakes.

<font color=red>Proudly supporting the AMD/Nvidia minority</font color=red>
June 17, 2003 1:55:19 AM

I've found some more results, folks. I'd like to thank you for the support you've given me so far, but it seems the tables may be turning as to what the problem might be.

I decided that I'd give my CPU one last shot. I turned down the bus frequency down to a mere 266 MHz, compared to the stock 333 MHz, and the RAM tests passed, no holds barred. I know you all are thinking, "Hey, that means it HAS to be the processor!" Keep reading, and you'll find that the problem is now incredibly different.

I returned my processor's bus frequency to its stock setting once again, but I realized that I had forgotten to change one of the BIOS settings—the one that determines the RAM’s frequency (e.g. Set by SPD). It had obviously been left on ‘Auto’ when I was underclocking the CAS latency. So, without a thought in my mind, I changed it back. The tests failed again. Big deal, right? Wrong. Keep reading. You may have to read this post over about two times for it to really sink in like it did with me.

Now, I set my CPU’s bus speed back down to 266 MHz (I forgot exactly what motivated me to do so). I ran the tests again. They failed. What? The tests failed even when the CPU’s frequency was down to the likes of a common-class 2200+? That’s right. If you’re like me, this is when things started to sound a little fishy.

I went back to the BIOS once more. I rushed to figure out exactly what I had it on when the tests started passing. Finally, I reached the successful setting. With the processor set to the same bus frequency (266 MHz), I re-set the memory frequency control to ‘Auto.’ The tests passed again. I had found my successful configuration.

However, being my daredevil self (Ha! Well, at least that’s what I like to think…), I returned my processor to stock frequency. The tests failed. I know this sounds like it’s all going around in a circle, but read over this once you get to the end and you’ll see that every paragraph holds a key to the solution.

I finally got the idea to turn off the annoying startup logo from within the BIOS. I thought this would be nothing, but it actually would be the key to my finding what was actually wrong. Going back and performing the past two steps, I found out that when I changed the CPU’s bus frequency, the memory’s bus frequency changed, too. I later discovered that that was what the ‘Auto’ option was for. Now I was getting ideas. Good ones. Very sneaky ideas.

Enough with the ‘Auto’ option! Let’s set this puppy up manually! I first set the memory to ‘100%.’ This would yield the 333 MHz CPU bus without affecting the memory bus, leaving it at 333 MHz, as well. The tests failed. Then, I calculated what percentage of 333 MHz that 266 MHz was (or rather, what percentage of 166 MHz [double-pumped] 133 MHz [double-pumped] was)—80%. I went into the BIOS once again (getting tired of it by now, of course) and set it. And so it was. I ran the RAM test, and behold! It passed. Are you catching on now? I never thought I would, so if you aren’t just yet, hold on. I will clarify the situation.

I said I would clarify, and I will. I’ll do it right now, in a few short sentences. When the RAM frequency was set to 266 MHz, the system became stable. When it was set to the stock 333 MHz frequency, the system became unstable. The processor is no longer in the picture, as we know now that the processor speed doesn’t affect the RAM speed (at least if it’s set right). The two components that are in question now are the motherboard and the RAM.

Now, because I was trained to do so in my A+ courses, I swapped out each RAM stick individually to make sure one stick wasn’t bad. Neither stick is bad. I don’t believe I have a bad motherboard, but it’s still a possibility. The odds of such are severely narrowed nonetheless, due to this fact: My motherboard manufacturer does not approve of my memory.

Okay, any questions? Any input? As always, help is appreciated. The problem is still not solved.
June 17, 2003 7:17:36 AM

Well glad you figured it out for the most part. Now of course you need to get your hands on some RAM that you know for sure will run at 333. That should prove if it's your RAM that's sucking (my guess) or the motherboard.

Also it could be that you are just leaving your timings to aggresive when you move to 333?
June 17, 2003 8:00:04 AM

Check the vdimm voltage, it might be too low to support your ram. or you are running your ram beyond Mhz spec for the timing.

Try increasing the mem voltage to 2.8v ~ 3.0v

<b>"Granted I dont own a P4. But I read enough stuff and waste enough time on forums newsgroups IRC and computer news sites that I proberly know more then if I DID own a P4." -vk2amv</b>
June 17, 2003 9:23:34 AM

Please go buy a single stick of samsung ram, and tell us if it worked. There are a lot of people with the same type of problem, and noone can fix it. Good luck.
June 17, 2003 4:01:10 PM

Does anyone know the default voltage for a DDR2700 DIMM? It could be that, after all, because my BIOS has a history of putting in numbers that are too low (i.e. putting my default CPU bus speed down to 100 MHz).

*Edit: Disregard this post. I've found that the usual setting is 2.5v, courtesy of Scott Mueller's "Upgrading and Repairing PC's," 14th Edition.*
June 18, 2003 7:59:17 PM

Will Corsair RAM do? I ordered a 512 MB stick of it yesterday and it should arrive Friday (via UPS 2nd-Day Air).
June 18, 2003 8:34:44 PM

Quote:
Sounds like it could be a PSU problem. What are you using?

I agree. The PSU is my first suspect. The RAM is my second.

GCCslix, what power supply are you using? What are its specs?

"<i>Yeah, if you treat them like equals, it'll only encourage them to think they <b>ARE</b> your equals.</i>" - Thief from <A HREF="http://www.nuklearpower.com/daily.php?date=030603" target="_new">8-Bit Theater</A>
June 18, 2003 8:39:26 PM

Which type of Corsair RAM and MB?

Mike
June 19, 2003 2:12:49 PM

I'm using an Antec TruePower430 (430W), so I believe I'm fine on power supplies. ;) 
June 19, 2003 3:54:07 PM

Normally I would completely agree. The Antec TruePower line is pretty darn good. :) 

However, in this case you happen to have a mighty fine collection of known power-hungry supply vampires. :o  So I'd monitor the voltages on your rails and make sure that there aren't any fluxuations and that none are going below their ratings just to be sure. I mean it'd be awful to try tracking down a RAM problem if it was just a power supply being drained by such impressive hardware.

"<i>Yeah, if you treat them like equals, it'll only encourage them to think they <b>ARE</b> your equals.</i>" - Thief from <A HREF="http://www.nuklearpower.com/daily.php?date=030603" target="_new">8-Bit Theater</A>
June 19, 2003 10:38:03 PM

If the RAM doesn't solve my problem, I'll check into it. Thanks phoenix! :) 
June 22, 2003 9:15:00 PM

The stick of Corsair did in fact solve my problem. Thanks again for all your help, and I believe that just about wraps up this thread. :) 
!