Sign in with
Sign up | Sign in
Your question

Autoplay in Windows 7 Ultimate x64 doesn't work on fresh install

Last response: in Windows 7
Share
April 2, 2010 12:46:39 PM

Hi -

Smallish yet irritating problem with my Win 7 Ultimate 64-bit install - Autoplay doesn't work, and hasn't since I was forced to reinstall a couple of weeks back. Doesn't work for discs inserted, USB flash drives, memory cards, external HDDs plugged in etc (Firewire & ExpressCard/34 not tested). I have of course gone to the Autoplay settings and restored defaults, also tried setting every category (DVD, CD, etc) at "Ask me every time". No luck. I was working fine on the same OS before before I had to reinstall fresh, also on x86 version of Win 7, and on Vista. Nothing wrong with the USB ports/disc drive, inserted media is still detected.

Any ideas?

Cheers

Sony VAIO VGN-NR280E
Win 7 Ultimate x64 + OS X 10.5.7 dual-boot with BootThink v.1
Mobile Intel 965 Express Chipset
Intel Core 2 Duo 1.7 T5450
4GB DDR2 667
Intel GMA X3100 (358MB)
Fujitsu 200GB Fast SATA
April 3, 2010 5:37:37 PM

OK, got it... here's the answer for anyone else having the same issue -


Check if the Group Policy Setting has been disabled for the Autoplay feature.

Note: Changing Group Policy Setting applies to only Windows 7 Ultimate and Windows Enterprise editions.

1. Click Start and in the Search box, type gpedit.msc and press Enter.
Now browse to Computer Configuration\ Administrative Templates\ Windows Components\ Autoplay Policies\ Turn off Autoplay.

2. To Enable:
Change the value of Turn off Autoplay to Disabled.

Note: This will enable the Autoplay feature.

Refer this link to which provides solutions to some common problems with AutoPlay:

Troubleshoot AutoPlay problems
http://windows.microsoft.com/en-us/windows7/Troubleshoo...

(many thanks to Divya R – Microsoft Support for this help

m
0
l
February 5, 2013 1:27:14 PM

I had the same problem. Was driving me crazy. I found out the problem is Picasa 3.9, when installed disabled autoplay for some reason.

Solution. Install Picasa 3.8 (If you can find it), then upgrade to Picasa 3.9 from within the application.
m
0
l
Related resources
!