Solved

Printer install fails: admin status not recognized?

Others have had this problem in the past, but I haven't found the answer reading other threads. Here's the outline:

Have installed a new wireless router and gotten all four computers into the network. Have an HP4500 All-in-One printer that was working fine before the new router, but now (probably because the network is more secure) it doesn't show up on the network.

Tried to install the HP software from the CD using a Win7 computer. Get error message that it cannot be run under "Run as...." and that I need to log off and log back in as ADMINISTRATOR. I'm the only user, and my UAC is set to Administrator. I have done the following:

Set UAC to "Never notify", rebooted
Set UAC to "Always notify", rebooted
Used the "Run" box to find the program on the E: drive to see if I could right click something and run as administrator, didn't see that option

None of these things worked. Any instructions need to be spelled out, my computer savvy is medium at best. TIA.
7 answers Last reply Best Answer
More about printer install fails admin status recognized
  1. Sorry, don't know how I got this into Win8 instead of Win7.
  2. Best answer
    have you tried downloading the driver from hp web page it may be newer then the cd.
  3. I did that last night, and it worked as far as being able to install the software. There were updates specifically to solve Win7 glitches. Problem now is that it seems the firewall is blocking or hampering stuff going to print. When I printed the test page, there was an HP error statement about making sure a certain port was set to allow "stuff" (my term, sorry) to go through, but in the midst of trying to find out how to configure the firewall I lost the error note so can't even quote it here. A 10-character Notepad document takes 2 or 3 minutes to print. :-(
  4. Turns out that the problem was solved by setting "print directly to computer" For Windows 7 this is done by opening “Devices & Printers” from the Start Menu, right click on the printer icon and select “Printer Properties” (not just plain “Properties”). Click on the Advanced tab and check the bubble “Print directly to the computer” It's been explained to me that this uses the computer's memory to process the printing instead of the printer memory.

    Am still frustrated by the computer not recognizing me as administrator when installing such a program. :(
  5. Try this. Had a similar problem with the same printer a while back.... Install it as a USB Connected printer, take ownership of it, then disconnect it. Re-connect it as WiFi, administer it with a dedicated IP address both on the print server/computer properties and then the routers. Check the router setup and settings to be sure that there isn't any rules negating the ip addey you gave it from connecting to the router. Complicated yes. But for some reason it worked. Been working on about two years now. My home network with 4 desktops and the 2 Laptops all print to it without a glitch. Hope it helps.

    :hello:
  6. Thanks, PB, that might be a little over my head. Fortunately, I solved the problem, as mentioned in my last post. I wish there was a way to select my own post as "best answer" 'cause it certainly did the trick!
  7. Best answer selected by nwislander.
Ask a new question

Read More

Configuration Printers Windows 8