Sign in with
Sign up | Sign in
Your question

Samsung SyncMaster 214t monitor Issue

Last response: in Computer Peripherals
Share
May 2, 2010 3:48:57 PM

Hi guys,
I have an irritating issue with my Samsung SyncMaster 214t monitor..
Windows 7 resolution is set to 1600x1200 @ 60hz - (native for this monitor)
Samsung SyncMaster 214t monitor keeps coming up with message "1920x1600 Not optimum Mode - Recommended Mode 1600x1200 60hz"
Tried adjusting with button controls on monitor - some features are grayed out and an adjustment for the resolution within these controls is nowhere to be found.
Have the correct driver installed but this is a issue (message), generated by the monitor itself
Any information greatly appreciated.
July 1, 2010 12:23:27 PM

I had the same problem. Samsung discontinued this monitor and does not have a Vista/Win 7 driver for it, so I don't understand your claim that you have the right driver installed. If you did, Win 7, in its Device manager, will show it as a 21T monitor type. Most likely, it will show it as a generic PnP.

I get the same message. The monitor is forced to a refresh rate of 59, not 60 Hz. That's why you keep getting the message from the monitor's OSD.

In most cases, you can live with the annoyance, but Adobe Lightroom, Canon ZoomBrowser and other apps needing a corrrect inf file for the monitor will not work properly. For example, LR will only show grey thumbnail images. ZB reports that its module stopped working.

If you google vista 214t, you get some 3rd party stuff that might work. In my case, I gave up and bought a Dell U2410. I'm not sure I want to buy any more monitors from a company that can't be bothered supporting its client base. At least you can rely on Dell to update the drivers across OS changes.
m
0
l
March 4, 2011 8:42:48 PM

I had the same problem with my 214T monitor ( Amd Phenom X4 and ATI HD5670) - finally I resolve my problem with a cleanup of my drivers with " Driver Sweeper 2.9.0"

afterwards with latest Glary Utilities v2.32.0.1126 there was a cleanup of over 100 registry entries
m
0
l
Related resources
March 24, 2011 8:09:15 AM

Twinscroll said:
I had the same problem with my 214T monitor ( Amd Phenom X4 and ATI HD5670) - finally I resolve my problem with a cleanup of my drivers with " Driver Sweeper 2.9.0"

afterwards with latest Glary Utilities v2.32.0.1126 there was a cleanup of over 100 registry entries



Hi I I had also the same problem with my 214T monitor.
Let me advice how resolved your problem with a cleanup of your drivers with " Driver Sweeper 2.9.0"?

Thank you.
m
0
l
November 14, 2011 9:27:05 PM

Problem fixed.
My setup: A Samsung syncmaster 214T and a NVidia GeForce 6600 GT grafix card and windows 7 (32bits)
I also got this annoying message "Not the optimum mode".
If you click on the menu button of the monitor it says your sending 1920x1200, while it should be 1600x1200 @74.6KHz
I solved the problem by installing the nvidia driver for the 6600GT and then create a custom resolution with a differnd timing.
How:
open the NVIDIA Control Panel. (in the control panel...)
Goto "Change resolution"
Select the monitor and click on "Customize...".
Check "Enable resolutions not exposed by the display"
Click "Create Custom Resolution..."
Then fill in the following values:
Horizontal pixels: 1600
Vertical Lines: 1200
Refresh rate (hz): 60
Color depth (bpp): 32
Click on "Timing" to adjust the timing.
Select "GFT" (Now you see that the refresh rate changes to 74.52 Khz)
Activate this custom resolution and the irritating message will not appear anymore
m
0
l
December 12, 2011 3:21:21 AM

Hi xitavr

First of all, I must express my heartfelt thanks to you.
To be sure this were a thorny issue but you had the tact to iron out difficulties.
I must submit your opinion and advice........
After activated this custom resolution and the irritating message would not appear anymore.

I will pay tribute to your experence and efforts.
Thank you......
m
0
l
February 13, 2012 6:45:33 AM

Thanks
this resolved my problem ;-)

Best regards
m
0
l
!