Sign in with
Sign up | Sign in
Your question

Toshiba Qosmio X505 Button utilities

Last response: in Laptops & Notebooks
Share
February 17, 2010 10:42:42 PM

Brand: Toshiba
Model: Qosmio X505-Q875
OS: Windows 7 Home 64-bit

I just bought my laptop about a month ago, everything was great. I was loading my programs I would need for school, then I downloaded Spybot S&D and ran the cleaner....
This is where I ran into problems. It's not a problem with the functionality of windows, just that the extra touch buttons on the side are not mapped anymore. I did some research online and found that the pointers in the ButtonSettings.ini file is stored in a Users\user\AppData\Temp folder when it comes stock from the factory. The registry points to this config file in the Temp folder, not very bright for them to do that. I called Toshiba help, which was not any help, the guy I talked to had no clue about this issue and was determined it is something I did to it. I've tried to uninstall and re-install the Toshiba value added package as many have suggested, both versions (see below) of them, only to have the same outcome, not working properly.

After many hours of troubleshooting this Button Setting Configuration problem, I don't know what else to try.
Here are the steps I have tried so far:
1. Uninstalled Toshiba Value Added Package (original one was I believe 1.2.34_64, I know it wasn't the one one Toshiba has listed because I was hesitant to uninstall it. It was a newer version number.)
2. Reboot
3. Run Ccleaner, remove any unmapped registry entries
4. Reboot
5. Check in registry, delete TBS folder
6. Check Program Files\Toshiba, delete TBS folder
7. Reboot

At this point, without the value package installed, the mute button and the touch pad on/off buttons work but eco utility and media player buttons will not.
The volume buttons increase/decrease and the play/pause button works always regardless of the TVAP program.

8. Re-install Toshiba Value Package (recommended version for my laptop on Toshiba website, 1.2.26_64)
9. Reboot

After the first try I thought Spybot was still blocking it as I still had it running on boot. I disabled it and re-applied all steps, but it was still the same outcome. Something just isn't clicking here.....

I've noticed in the registry after I uninstalled the first time and re-booted, there is a TBSBAK folder created. I have not deleted this as it has an extra folder called HotButtons which has 4 sub folders with a key in each one representing buttons number 1 through 4. When I re-install the TVAP and it re-installs the TBS registry folder, this set of subfolders are not there. Not quite sure what that is about either.

Something else I have tried is to re-name the TBSBAK folder to TBS and try to map it to the ButtonSettings.ini file. Still, no luck.

I've also looked inside the Program Files\Toshiba\TBS folder and saw a custom button config program and see the executables for the buttons. But I seem to not be able to manually map and buttons either.

I'm not in the habit of using these buttons as I didn't get much time to get acquainted to them but I found the mute button extremely useful while in public places or in class.

On a side note, the Media Button(button with the music note within a box) will turn on the computer when touched while computer is off. I was wiping off the computer keyboard and discovered it. Just interesting to me.

Any help would be greatly appreciated as I'm at a brick wall right now.
Thanks,

Josh
a b D Laptop
February 18, 2010 1:55:13 AM

Yes, mine does the same thing, i.e. hitting a media button will turn it on. Seeing that you have tried almost every practical solution, have you considered just restoring it back to factory settings? I'm thinking that if you do that, it will recvert the button mapping back to stock. If you go that route, just back up everything and stay away from spybot, as it appears it wiped the temp folder out.
m
0
l
February 18, 2010 2:37:51 PM

I wouldn't mind restoring it back to factory default, I did not make a backup image of the OS when it first came. I can fix most anything on windows and fix most driver support if it breaks just did not anticipate something like spyware tools wiping out the pointers to keyboard helper buttons. I see there is a hidden partition for the restore, is there a program to run in the toshiba utilities to restore the original drivers and software? Or is there a way to make a disc image from the restore/recovery partition?
m
0
l
!