Sign in with
Sign up | Sign in
Your question

New Video Card, lagging window movement

Last response: in Windows 7
Share
November 1, 2012 5:31:18 AM

I just purchased a new Radeon 7970 video card and installed it. Downloaded the Catalyst Software and drivers for the 7900 series. Also redownloaded DirectX just incase. However when I move a window (i.e. browser window) around the screen there is a white lag trail left behind that I've never had before. I have a custom system and switched from a GTX 560Ti card (I deleted all Nvidia related items too). Never had an issue with the previous card. Please help :( 

Here are some system specs if it helps
i7-2700k
G skill DDR3 1600 RAM - 8GB
180GB intel 520 SSD
1TB WD Caviar Black HDD
Sapphire Radeon 7970
ASUS P8Z68-VPro mobo
November 23, 2012 5:28:33 PM

Did you find a solution to this, I'm having the same problem
m
0
l
November 23, 2012 5:35:28 PM

Have you tried unistalling & re-installing the drivers that came with the CD?
m
0
l
Related resources
November 23, 2012 5:36:32 PM

For me, it's only the browser window that has the problem! (Google Chrome). Games/everything else runs fine :\
m
0
l
November 23, 2012 5:39:14 PM

If it is one program maybe it need re-installing. Also chrome uses alot of RAM when viewing multiple tabs so maybe you need more. Do you have 32 bit or 64 bit windows?
m
0
l
November 23, 2012 5:41:42 PM

64 Bit Windows 8
i5 3750K@3.4Ghz
8GB DDR3 RAM
HD 7870 2GB Ghz OC

I will try reinstall it :) 
m
0
l
November 23, 2012 5:45:52 PM

No luck :( 
m
0
l
November 23, 2012 5:51:27 PM

Did you try another Browser. Firefox Maybe?
m
0
l
November 25, 2012 9:48:53 AM

Resolved it - (Kinda) - It only actually happens when Facebook is open, I guess as the website is so intensive. When it's not open it's fine!

Thanks for your help fantomdark
m
0
l
!