Sign in with
Sign up | Sign in
Your question

Can't open files when I use the Search option

Last response: in Windows 7
Share
April 2, 2010 7:56:16 PM

Can't open files when I use the Search option... looks like this:

! These Files can't be opened
Your Internet security settings prevented one or more files from being opened

Help!
a b $ Windows 7
April 6, 2010 11:55:30 AM

What files are you trying to open?
m
0
l
July 7, 2011 12:37:53 AM

sunjenkwei said:
Can't open files when I use the Search option... looks like this:

! These Files can't be opened
Your Internet security settings prevented one or more files from being opened

Help!

Alternate Solution for same error message.

Background

Microsoft Downloads - in my case those from the Microsoft Update Catalog,

but it has also been reported those from Web Update,

Microsoft Downloads Create file / path names in Windows 7 64 bit greater than the maximum allowed within Windows 7 64bit. Note you cannot create over length path names manually in Windows 7.

The maximum is 260 characters including 3 character drive designation plus 1 character <null> terminating character.

The maximum is 256 not counting the drive designator ( i.e. C:\ ) and also not including the <null> terminating character at the end. So the entire directory path plus the file name should be less than or equal to 256 characters. Excluding the three ( 3) character drive designator "C:\" from the 256.

In my case the path downloaded from Microsoft by Microsoft software was greater than 270 bytes in several cases.

The result was the same error.

These files can't be opened.

Your Internet Security settings prevented one or more files from being opened.

Either of the following solutions worked:

Copy the file to a much shorter directory.

or

Rename the file in place so that the entire path, including the file name, is less than 256 characters.

Obviously in these cases the error message is misleading.

It appears this may be a default error message that pops up when the real error is not identified.
m
0
l
!