Sign in with
Sign up | Sign in
Your question

Problem Installing Windows 7 Help!

Last response: in Windows 7
Share
November 2, 2012 2:01:55 PM

Hello, I recently put together my very first custom built PC with the below specs:

Case: Cooler Master Sniper
PSU: Cooler Master 850w modular
CPU: i5 2500k w/ stock heatsink/fan
MOBO: ASRock Z77 Extreme 4
RAM: GSkill Ripjaws 16 GB (2x 8 GB)
HDD: Western Digital 1tb Black
OPTICAL: LG CD/DVD Burner
OS: Windows 7 Home Premium 64-bit OEM

After about 2-3 hours I had everything installed, powered up just fine, popped in the windows 7 disc and started installation. Everything ran smoothly until first restart. It went to the screen where the colors fly in to form the Windows logo and says starting windows and then just sits at that screen indefinately. I've searched numerous forums trying to find an answer but I haven't found any with the exact problem i'm having.

Everytime I restart the computer it boots up to this screen and no further.

Any suggestions?
a c 354 $ Windows 7
November 2, 2012 2:27:42 PM

Check the RAM first, try with one stick at a time, try different slots.
m
0
l
November 2, 2012 2:30:45 PM

Thanks, I'll try this out!
m
0
l
Related resources
November 2, 2012 2:52:39 PM

The windows logo gets stuck due to a driver issue (IMO). Load in safe mode and go to device manager. Delete the video card driver first or roll it back. Try a reboot and let me know if it boots.
m
0
l
November 2, 2012 2:55:34 PM

I actually tried booting in safe mode already, it shows the files being loaded and then freezes
m
0
l
!