Sign in with
Sign up | Sign in
Your question

Running HDMI audio only from pc to receiver

Last response: in Home Audio
Share
March 13, 2011 11:42:33 AM

Okay, so here's my setup.

Asus Crosshair IV Formula
AMD 6870
Onkyo TX-sr606
Vizio 42" TV

So I have various HDMI inputs on my Onkyo receiver, which I have filled with my PC, my PS3, and my cable. The receiver has and HDMI out to my TV, so I can route all my video. The PS3 and the cable work flawlessly. But PC is a little wonky. I'm currently setup on my pc with a normal monitor besides the tv connection via receiver. This monitor is my main display and what I spend most of my time on. Usually, I just used my receiver for audio with a toslink cable, and ran an HDMI cable to the tv if I wanted to extend my display. However, I got the new onkyo receiver, and I switched the setup to run HDMI for audio and video through the receiver to the tv. Now, I can't get audio only from the HDMI hookup.

In order for me to get audio AT ALL from the hdmi hookup from my pc to receiver, I have to extend the display so that my tv would be included by my computer as a monitor, BUT I don't need my tv to be on. Otherwise, my ati audio device tells me it's not plugged in. This has me wondering... do I need a video signal sent through the HDMI cord for it to be detected by my receiver? Is there any way to get audio only, with the option of having the tv as an extended display, instead of it being mandatory?
March 13, 2011 8:55:07 PM

how about enabling amd HDMI output .... thats all i do and it works.
March 14, 2011 1:19:41 AM

It's enabled. The only problem is that it won't recognize the HDMI cord is even plugged in unless I have my monitor set to extending the display to the TV output on my receiver.
Related resources
January 10, 2013 3:26:29 AM

I'm having a similar issue, and no one can seem to help me either.
February 13, 2014 7:40:14 PM

HDMI audio can only be imbedded in a video signal, even if it's just a black screen. If you want hi bit-rate LPCM audio, it has to be a video signal of at least 720p. It sucks, but that's the way it is.
!