Sign in with
Sign up | Sign in
Your question

Full Screen Mode Apps Are Not Stretching To Fill Window

Last response: in Windows 7
Share
November 3, 2012 2:13:23 AM

Hello All!!

I am having a strange issue that appears to be related to my video driver, settings, etc.

I play several different video games on my PC and each one of them has the option to play in Windowed mode or Full Screen mode. Until recently switching a game to full screen mode made it fill up the entire window. In the last day or so, something has changed where now the game doesn't re-size itself when in full-screen mode. Instead, it stays the same size and a black border is drawn around all four sides. To make things ever weirder... it doesn't do this on all my games, but it does it on most.

Here are some screenshots to demonstrate the issue more clearly.

Regular Windowed Mode


Full Screen Mode


I have tried everything I can to fix it but I am stumped. I have changed various settings for each game but nothing has worked. I have also looked around at the settings in Windows 7 but I couldn't find anything that fixed it.

Do you think this is an issue with the game(s) or could it be something in Windows?

Thanks!
November 3, 2012 2:55:13 PM

This could be an issue with some other software on your computer that doesn't want to allow the game to change the resolution of the screen. I see you have TeamViewer running. I don't know whether or not that would make you keep one specific resolution, but it might.

You should try to change the resolution at which your games run. Some apps may not allow you to do this. If you have a game that runs at a smaller resolution than your screen, if you hit the fullscreen button the game will take over the foreground. Based on what it's allowed to do, it will either decrease your screen resolution to the resolution of the game, it will stretch the game to fill the current resolution, or it will maintain the current resolution and run the game at the biggest size possible, like it's doing for you.

Now, from what I can tell the game you're trying to run is ancient. About nine years old. You should probably change the compatibility settings in Windows to get an optimal experience. This can be done by right clicking on the icon and clicking "Troubleshoot Compatibility." Windows will automatically try to figure out the best way to run the game, but it might not fix the issue. If it doesn't, right click on the icon again, and go to properties. In the properties box, go to the compatibility tab. Set the compatibility mode to Windows XP (Service Pack 3) and try to use the game. If that doesn't work, try checking off the box labeled "Disable display scaling on high DPI setting." That should do the trick, but if it doesn't, try checking off more of the boxes, like "Run in 640x480 screen resolution." It might take a while but you should be able to find the right combination.

If that works, then you should be able to do it for the other games you run.

I hope that's at least a little helpful!
m
0
l
a b $ Windows 7
November 3, 2012 10:35:14 PM

Are you using a monitor or a tv as your monitor?
m
0
l
!