Sign in with
Sign up | Sign in
Your question

Game running in background but won't open???? Help!

Last response: in Windows 7
Share
November 3, 2012 2:39:44 PM

Hello, I'm having trouble with several games opening their pre-game menus properly but then disappearing. They are running in the background but can only be seen in task manager and do not appear on the task bar. I have had this problem with multiple different games from different publishers so I'm assuming it is an error on my end. The games I have tried are Starcraft 2, Half-life, and a multitude of Steam games. I have a self-built computer running Windows 7. I'll list specs below:

Nvidia GTX 570
Intel i5-2500k
8 GB RAM

It's becoming incredibly annoying and I would desperately love some resolution to this. Thanks.

(P.S. and I have tried running everything in compatibility mode and as administrator)
November 3, 2012 3:15:02 PM

Hmmm. This is quite an interesting issue.

I can only think of a few things that could cause this:

- If you use multiple monitors or connect your computer to a TV, the game might come up on a different display by default, therefore showing you absolutely nothing.
- Check the 3D application settings in the Nvidia Control Panel to see if something's amiss. I can't really be more specific than that.
- If you see the game as running in Task Manager, try right clicking on it and selecting "Bring to Front" and "Maximize."

That's all I got. I hope this helps!
m
0
l
a b $ Windows 7
November 3, 2012 3:52:39 PM

I think this is one of those problems that would be better if there was a way to get hands on and see for myself because I've not heard of anything like this and it has to be a setting someplace in Windows because it affects different games.
You can try going into the Windows default programs and making sure that all the default options are normal and there is a reset to default button that you can try to see if it changes anything. It may be that a device needs to be selecteds to run the games.
Control Panel/ Hrdware and sound/auto play
m
0
l
Related resources
November 3, 2012 4:04:31 PM

Try using Alt+Tab then release the tab key.Try finding the game instance.
This happend to me a few times with guild wars 2 but never with starcraft 2.
m
0
l
November 4, 2012 9:01:23 PM

This is happening with any game. Publisher doesn't seem to be an issue. All steam programs including steam itself, Blizzard games, and a couple of stand alone programs. I have tried running as admin, compatability mode, allowing access through firewall, and disabling firewall. After about 100 tries, and several reboots, the program will open up first time. But once it has closed for any reason, it is back to the same loop. It must be something with my system and not the actual programs. Pleeeeassse help.
m
0
l
!