Sign in with
Sign up | Sign in
Your question

Repairing Desktop Icons

Last response: in Windows XP
Share
Anonymous
August 23, 2005 8:17:48 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Several of my desktop icons have been replaced with the "missing
application" icon, i.e. when you uninstall an application and the shortcut
icon remains but changed. The desktop shortcuts still work, e.g. My Computer
opens my computer. Can anyone tell me how to repair Desktop icons? Many
thanks

More about : repairing desktop icons

August 23, 2005 8:17:49 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Icons - Repair View

TweakUI Icon Fix - Repairs the View 16 & 32 (Line 4)
http://www.kellys-korner-xp.com/xp_tweaks.htm

To use the Regedit: Save the REG File to your hard disk. Double click it and
answer yes to the import prompt. REG files can be viewed in Notepad by right
clicking on the file and selecting Edit.

--
XP-WNP
Today is the first day of the
rest of your life.


"Jim McIntyre" wrote:

> Several of my desktop icons have been replaced with the "missing
> application" icon, i.e. when you uninstall an application and the shortcut
> icon remains but changed. The desktop shortcuts still work, e.g. My Computer
> opens my computer. Can anyone tell me how to repair Desktop icons? Many
> thanks
>
>
>
August 23, 2005 11:16:05 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Jim McIntyre wrote on Tue, 23 Aug 2005:

>Several of my desktop icons have been replaced with the "missing
>application" icon, i.e. when you uninstall an application and the shortcut
>icon remains but changed. The desktop shortcuts still work, e.g. My Computer
>opens my computer. Can anyone tell me how to repair Desktop icons? Many
>thanks
>
>
Hi Jim

Try this: Go to C:\Documents and Settings\Username\Application Data and
delete the file IconCache.db. It's a hidden file so you need to have
enabled Show hidden files if you don't normally use that.

Then reboot and Windows will recreate the icon cache.

Hope it helps.
--
Nightowl
Related resources
Anonymous
August 26, 2005 5:27:27 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

"Nightowl" <owl@[127.0.0.1]> wrote in message
news:$5FOjGglf2CDFwin@black.hole...
> Jim McIntyre wrote on Tue, 23 Aug 2005:
>
>>Several of my desktop icons have been replaced with the "missing
>>application" icon, i.e. when you uninstall an application and the shortcut
>>icon remains but changed. The desktop shortcuts still work, e.g. My
>>Computer
>>opens my computer. Can anyone tell me how to repair Desktop icons? Many
>>thanks
>>
>>
> Hi Jim
>
> Try this: Go to C:\Documents and Settings\Username\Application Data and
> delete the file IconCache.db. It's a hidden file so you need to have
> enabled Show hidden files if you don't normally use that.
>
> Then reboot and Windows will recreate the icon cache.
>
> Hope it helps.
> --
> Nightowl

Thanks Nightowl - unfortunately I could not locate IconCache.db anywhere on
my computer - I have hidden files set to see. I should have stated I use Win
XP Pro with SP2
August 26, 2005 8:12:27 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Jim McIntyre wrote on Fri, 26 Aug 2005:

{Nightowl wrote:]
>> Try this: Go to C:\Documents and Settings\Username\Application Data and
>> delete the file IconCache.db. It's a hidden file so you need to have
>> enabled Show hidden files if you don't normally use that.
>>
>> Then reboot and Windows will recreate the icon cache.
>>
>
>Thanks Nightowl - unfortunately I could not locate IconCache.db anywhere on
>my computer - I have hidden files set to see. I should have stated I use Win
>XP Pro with SP2

Hi Jim

Yes, I use XP Pro with SP2 too. How odd. . . did you have Search set to
look in hidden and system folders as well? On my computer IconCache.db
is in C:\Documents and Settings\Username\Application Data, though on
Google I found some people saying theirs was in C:\Documents and
Settings\Username\Local Settings\Application Data.

Never mind, try this instead.

Right-click on the desktop and choose Properties, then Appearance tab,
Effects button. Check the box for Use large icons, and OK your way out.
This should make Windows rebuild the icons -- you can then go back and
uncheck the box to return them to normal size.

Hope this helps. . .

--
Nightowl
!