file/directory permissions

I've got a seperate fat32 partition that I need to give full user permissions to. I mean, where joe schmoe can read/write/execute from it.

I thought the mount options "user,exec,nosuid,rw" would do the trick. But it ain't working. Root can flip through just fine, but my "normal" user can't; I get shot down when I go to move files (write) to it.

I do I mount this entire partition with unrestricted access for all users?

I'm using Mandrake 8.2, if that even matters...


P@ll4dium f0r L1f3!
14 answers Last reply
More about file directory permissions
  1. Are you mounting it as root or as a user?
  2. Um.

    Actually I have it in my fstab.

    If that makes any difference.

    And just what the h3ll does "fstab" stand for anyways?

    file system something something something?

    P@ll4dium f0r L1f3!
  3. try adding umask=0777 to the options in fstab which would make it world r/w.
  4. Isn't it 0007?

    If my baby don't love me, I know, I know, her sister will.
  5. God I hope that was a James Bond joke.

    It is totally uncool, and slightly o-fensive, to make jokes with someone who is so new they will screw the system completely. Do I need to get rid of the "user, exec, nosuid, rw" stuff, or will it matter? And what the heck kind of an option is "--". I can't find that one anywhere in any how-to's or my bible. It's put on default for my cdrom reader.

    Anyways, I go now to make changes...

    Gracias!
  6. It was not a joke. To get your wanted umask, you take the permissions you want and subtract them from 777. Thus a umask of 007 gives you permissions of 770. It was a legit answer. He made no joke and I am offended at your response to somebody trying to help you with your problem. There is no intention from his statement to do harm to your system.

    <font color=blue>Unofficial Forum Cop</font color=blue>
  7. Oops, looks like it is 0777... I'm not chmod expert, so I just took a few things off of a site I found. 0007 is to let others read/write/etc, 0070 is for group, and 0700 is for owner (as I understand it that is). So to make it readable by everyone, it should be 0777.

    Besides, James Bond is 007, not 0007.

    If my baby don't love me, I know, I know, her sister will.
  8. Thanks everyone.

    SilverPig: do you remember what site you were on to find those designations?

    P@ll4dium f0r L1f3!
  9. I can find it again... It was very very brief though. I actually did find it and was about to post the url, but mozilla didn't want to paste the link I copied so I just said fsck it... :smile:

    <A HREF="http://www.mcsr.olemiss.edu/cgi-bin/man-cgi?chmod+1" target="_new">http://www.mcsr.olemiss.edu/cgi-bin/man-cgi?chmod+1</A>

    funny... it worked that time :)

    If my baby don't love me, I know, I know, her sister will.
  10. I have a windows partition mounted. Here is my fstab for your reference. It is mounted to /windows

    LABEL=/ / ext2 defaults 1 1
    LABEL=/boot /boot ext2 defaults 1 2
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    /dev/hda1 /windows vfat defaults 0 0
    none /proc proc defaults 0 0
    none /dev/pts devpts gid=5,mode=620 0 0
    /dev/hda3 swap swap defaults 0 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0
    0

    <font color=blue>Unofficial Forum Cop</font color=blue>
  11. Thank you, but the default is to completely lock that drive down. I want to open it up.

    So, I tried adding umask=0777 to my fstab. Right now it has absolutely no permissions whatsoever.

    *ROOT* can't even change the permissions on the drive. It tells me "you have insufficient access to chage this file...".

    If friggin root doesn't have access, who the hell does?

    God?!?!?!?!!?!?!?1/1/1

    (I'm at a turning point. I don't know if I want to cry, or load the shotgun)


    [edit: OMFG! Just for grins I changed the umask to 0000, and it worked! Total access!!!

    W000000000oo000000000000000o00000000000oooo000000000000000000-
    000000000000o000000000o0o0000000000oooo00000000000000000000-
    0000000000000o00000000o0000000o0000000000000000t!!!!!!!!!!!!!!!!!!

    Thanks everyone!)


    P@ll4dium f0r L1f3!
  12. yep. umask octals are basically the opposite of chmod ones.

    <i>Do I look like I care?</i>
  13. That is what I tried to explain to you earlier....but I got a couple of posts mixed up and it wasn't as clear as it should of been. But anyways, glad you got it to work.

    <font color=blue>Unofficial Forum Cop</font color=blue>
  14. Yeah, I can see now what you were talking about. I might have explained it a little differently, but you gave me the starting place when I didn't even have that.

    Thanks!

    P@ll4dium f0r L1f3!
Ask a new question

Read More

Permissions Partition FAT32