Sign in with
Sign up | Sign in
Your question

All of my USB ports don't work

Last response: in Laptops & Notebooks
Share
March 3, 2010 2:13:32 AM

Hi I have a Compaq F700 notebook running Windows Vista 32 bit SP2. All of my USB ports have stopped working. I have uninstalled the drivers and had windows try to install them upon reboot but I get this error message. It is for my usb root hub (7) ports

One of the usb devices attached to this computer has malfunctioned and windows do not recognize it.

There are only 3 physical ports visible. I have nothing plugged into them and I still get the error. I was also told to delete my INFCACHE.1 file in windows folder/inf.
I did and it got rid of the error message but did not solve the problem. I tried to go into BIOS and make sure that PNP is enabled and I cannot even access anything like that in the bios. The only option is hard drive check and memory. I have updated to current bios too. Could at this point be a Hardware issue? Should I go ahead and format and reinstall and see if that works. Does anyone have any advice? Help because I am ready to give up.
Thanks in advance for the help.

More about : usb ports work

March 3, 2010 5:12:57 AM

Reformat is a nice way to ensure it's not a software problem. It is rather time intensive though, so wait for someone more knowledgeable to respond first. I don't deal with hardware that much, so if I had this problem, I would just reformat and hope all my drivers were working properly. =x
m
0
l
!