Sign in with
Sign up | Sign in
Your question

Logitech z506 won't play surround sound

Last response: in Home Audio
Share
May 28, 2011 5:52:58 AM

I just bought the Logitech Z506 5.1 speaker system, and I can't get it to play through all 5 speakers. I use my laptop, which has 2 audio jacks (there's a microphone jack too, I didn't try to plug it in there), so I can only plug in 2 of the 3 cables.

The speakers are supposed (I think) to have some kind of forced surround sound output so that stereo input is played in surround, but if I only plug in the front speakers, all that plays are the left and right speakers and the sub. If I plug in 2 of the cables, those two things will play, but not the third.

I tried using a splitter, with one cable plugged in directly and the other two sharing the splitter, but that seems to overpower the speakers that aren't using the splitter.

After about a day of this, I ordered the GWC Technology AA1500 USB Audio Adapter (5.1 Channel), which is supposed to convert sound to 5.1, and it does have the 3 jacks for a 5.1 system, but when I plugged it in, installed the drivers, and tried to use it, it only played sound through the Front port. I tried going to (in Windows 7) Control Panel -> Sound -> Speakers -> Configure and setting playback to 5.1 Surround instead of Stereo, but the problem remains. The output is still only through the front jack.

Before these speakers I used a cheaper 5.1 system, the CA 5402, and even with only 2 cables plugged in, those speakers all played. I really don't understand why the Z506 won't just port sound from the front left and right to the rear like my old ones did. I tried plugging the satellites from the Z506 into the sub from the CA 5402 with only the front and center/sub cables plugged in and I got equal sound from every speaker, just like I wanted. Any ideas on why I can't get this from the Z506?
Anonymous
August 13, 2011 10:10:29 PM

unplug the black and orange jacks from the subwoofer
m
0
l
January 26, 2014 5:38:16 AM

make sure your song or movie have 6 channel audio (right click on that properties and then click on details TAB on audio section check channel mostly songs have 2(stereo) best of luck

and sry for english
m
0
l
January 26, 2014 8:27:06 PM

i bought this product 2 years ago from local market, and all i have to say is that quite an awesome product it is and i am its proud owner, but my review is dedicated to those who are having problems with rear speakers/ are not getting surround sound experience.

1. make sure that you have 5.1 setup enabled in your audio driver settings.
2. make sure that the file you are playing consists of 6 channel audio, to check it right click on file and then properties.
3. make sure that the media player which is being used to play the file has 5.1 speakers option enabled. windows media player is by default enabled but vlc media player requires to select the speaker type for 5.1 speakers.
4. to get better output, enhance rear speaker sound level to +10dB in audio driver settings.
m
0
l
!