Sign in with
Sign up | Sign in
Your question

Cannot format the disk

Tags:
Last response: in Windows 7
Share
November 6, 2012 10:33:51 AM

Hello,

first, let me tell you how the problem started.

It is AMD based PC (Athlon 4800+, Biostar MB +iGPU, 2GB DDR2, Samsung 250GB), where everything is going as it should. One day, the PC after booting to Desktop, just freezes and nothing works, the cursor doesn't move, the keyboard too.

Next step, formatting. Well, I thought it will solve the problem, but when the installation comes to the point to choose a partition, it doesn't show any, AND you cannot create a new one. Just to mention the PC has been formatted couple of times with the same procedure.

Tried with new hdd, the same, tried with another hdd, again .. It is tried with 2 Seagate 200gb hdds AND they are tested on another machine, and they do work. The stock hdd Samsung has too many bad sectors (HD Sentinel shows 0% health [dead any moment], for one of the seagate showed 95% health [2 bad sectors] and for the other about 50 bad sectors). Tried with 3 different sata cables and 6 differents ports.

Tried with 3 different win7 installation DVDs, and 2 XP.

The disks sometimes are shown in BIOS, and sometimes they are not.

Do you have any suggestion what could be the problem ?

More about : format disk

a b $ Windows 7
November 6, 2012 10:40:31 AM

Is the HDD set to AHCI or IDE in BIOS?
November 6, 2012 11:12:45 AM

Tried with both. (Actually there were only SATA and AHCI).
Related resources
a b $ Windows 7
November 6, 2012 11:40:37 AM

It might be a SATA controller issue. I wonder if a PCI SATA controller would work.
If more than one RAM modules installed, remove one and test, to rule out a memory issue.
November 6, 2012 12:00:03 PM

Going to test the possibility for ram errors in a couple of hours, because the PC is not mine. Any other suggestions are welcome.
November 6, 2012 6:33:05 PM

It is not the memory, tested with 3 different RAM sticks (the first time it showed the partitions, but every other time it didnt [about 10+ times]). Any other suggestions ?
!