UPDATE FOR Radeon X300/X500/X1050 SERIES

I have Windows 7 Professional I downloaded Angry Birds But get error message OpenGL 2.0 not supported also OpenGL 1.3 not supported what do I do?
3 answers Last reply
More about update radeon x300 x500 x1050 series
  1. You need to update the driver for your video card and see if that will get you to where the game requirements are met.
    All games have minimum system requirements and your video card currently is not meeting those requirements. A driver update may allow you to meet those requirements.
  2. For 32-bit Windows 7 drivers, go here:

    http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_vista32.aspx?type=2.4.1&product=2.4.1.3.13&lang=English

    For 64-bit Windows 7 drivers, go here:

    http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_vista64.aspx?type=2.4.1&product=2.4.1.3.13&lang=English

    As this series of GPUs is not supported any longer, this is as good as it gets in terms of driver support. Might be time for a new video card.
  3. Hi :)

    Its an old Laptop, so upgrade your video drivers from the manufacturers website...

    All the best Brett :)
Ask a new question

Read More

Drivers Windows 7 OpenGL Error Message Radeon