Sign in with
Sign up | Sign in
Your question

Laptop Speakers don\'t work, Headphones Do in win 7

Last response: in Laptops & Notebooks
Share
March 11, 2010 9:39:30 AM

i installed windows 7 on my laptop and the laptop speakers do not worke but the headphone have sound
a b $ Windows 7
March 11, 2010 2:31:29 PM

well if that is the case than using common sense with the info you just gave me tells me the speakers in your laptop are broke
March 11, 2010 2:35:53 PM

or... you might want to install the manufacter sound drivers....
Related resources
a b $ Windows 7
March 11, 2010 2:39:45 PM

if he didn't have the manufacturer sound drivers installed he wouldn't get any sound out of the headphones
March 11, 2010 2:51:04 PM

Quote:
if he didn't have the manufacturer sound drivers installed he wouldn't get any sound out of the headphones


That's not necessarily true. If he has a USB headset, then it has its own built in sound driver independent of the OS. Is this the case hassan? If so, then go to the laptop manufacturer's website and DL the specific audio drivers for your laptop model and your speakers should work.

Also, another thing that can happen is the if you plug in a secondary audio device (such as USB headphones) then Windows automatically makes it the default audio device. Go to Control Panel and then to the Audio section and look at what is the default audio output device. Its possible that the speakers will work, but the OS right now isn't sending the output to it (rather straight to the headphones). If this is the case then you'll have to toggle this, or tell whatever applications which device to use by default if you want to use both speakers & headphones.
June 2, 2012 7:45:23 PM

I have just managed to solve the problem after a long time trying. My Dell has a Sigmatel Audio Card. Right click on speaker con at the bottom of screen to open Volume Control screen. Click on "Advanced" Under "Other Controls" is a tick box "1 Spk Mute" Uncheck box and they work!!!!

God knows how it got checked but it was at at the time I was installing new software (I cannot remember what for) so I suspect that had glitch and did it for me.

Hope it works for others :lol:  :wahoo: 
June 9, 2012 12:05:26 AM

Two weeks later and the speakers did not work again for no obvious reason. This time I went to Control Panel , Sounds and Audio Devices, Properties, Audio and it shows Sigma Tel Audio, Click advanced and it shows Laptop stereo speakers. click Performance and then restore defaults and speakers start working again, Headphones were uaffected and worked throughout
!