Win XP SP2: "Debugger detected"

Archived from groups: microsoft.public.games.discussion (More info?)

Hi there,

after installing SP2 on my Windows XP I got an error message from the game
"Pirates of the Caribbean" telling me "A debugger was detected. Close it
down and restart the program". I simply cannot find out what's causing this
error. Unfortunately Ubi couldn't help me and advised me to re-install my PC
:-(

I didn't change any settings. But I did install SP2 and that seems to be the
reason for the error message. YES, I did disable the script debugging in IE
this is not the resolution! And YES I own a original CD of "Pirates of the
Caribbean" with no crack or no-CD-patch running!

Any suggestions what to do?
Any ideas what kind of "debugger" is running in the background?
Any help is welcome!

Thanks in advance,
Marcus
5 answers Last reply
More about debugger detected
  1. Archived from groups: microsoft.public.games.discussion (More info?)

    Hi Marcus,


    That error may occur if one or more of the following conditions are true:

    a.. There are programs (such as an antivirus program or debugging software)
    that run in the background and that interfere with the game startup process.
    b.. Your sound card or sound card drivers are outdated.
    c.. The Creative Audigy sound card is installed in your computer. This sound
    card may conflict with the game startup process.

    RESOLUTION
    To resolve this issue, use the methods presented in this article:
    http://support.microsoft.com/?kbid=812759

    --
    Cheers, Windows XP MVP Shell / User
    Jimmy S. http://mvp.support.microsoft.com

    Game FAQs: http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
    Visit my Zone.com / Gaming Helpsite: http://nibblesnbits.tk or Call / Contact
    MS Support at: http://support.microsoft.com/default.aspx?scid=sz;en-us;top
    My advice is donated "AS IS" without warranty; nor do I confer any rights.
    _________________________________________________________


    "Marcus H." <*@privat.net> wrote in message news:419e384a$0$145$9b622d9e@news.freenet.de...
    | Hi there,
    |
    | after installing SP2 on my Windows XP I got an error message from the game
    | "Pirates of the Caribbean" telling me "A debugger was detected. Close it
    | down and restart the program". I simply cannot find out what's causing this
    | error. Unfortunately Ubi couldn't help me and advised me to re-install my PC
    | :-(
    |
    | I didn't change any settings. But I did install SP2 and that seems to be the
    | reason for the error message. YES, I did disable the script debugging in IE
    | this is not the resolution! And YES I own a original CD of "Pirates of the
    | Caribbean" with no crack or no-CD-patch running!
    |
    | Any suggestions what to do?
    | Any ideas what kind of "debugger" is running in the background?
    | Any help is welcome!
    |
    | Thanks in advance,
    | Marcus
    |
    |
  2. Archived from groups: microsoft.public.games.discussion (More info?)

    Hi Jimmy,

    thanks for your reply!
    I followed the instructions in KB article 812759 and found out some
    interesting things about Win XP :-)

    Unfortunately the methods described didn't help. However I'm now absolutely
    sure that the problem has to do with SP2.

    Method 1 didn't apply to me although I have an AMD cpu...
    Method 2 was very interesting (I didn't know about msconfig) but that did
    not resolve the problem either.
    Method 3 is a nice idea - but I have the latest drivers for my audio device!
    Method 4 & 5 didn't apply to me as I'm not using Creative hardware at all...

    Hmmm, I just don't want to remove SP2 from my system but I'd really like to
    play "Pirates of the Caribbean". So what kind of debugging mechanisms could
    there be in SP2?

    Any ideas?

    Have a good time,
    Marcus
  3. Archived from groups: microsoft.public.games.discussion (More info?)

    Hi Marcus,

    There was another situation like this one several months ago.
    A Microsoft tech posted the following solution at that time:

    This can occur if you have the /DEBUG switch in your boot.ini file. Follow
    these steps to remove the /DEBUG switch:

    1) Make sure Windows is set to Show All Files. To view protected operating
    system files:
    Double-click My Computer.
    On the Tools menu, click Folder Options.
    Click the View tab.
    Click the "Show hidden files and folders" circle under "Hidden files and
    folders".
    Click to clear the "Hide extensions for known file types" check box.
    Click to clear the "Hide protected operating system files" check box.
    Click Yes when you are prompted to confirm your choice.
    Click OK.

    2) Find boot.ini on C:\
    3) Right-click on the file-icon and choose Properties - uncheck the
    Read-Only check box if it is checked, then click OK.
    4) Double-click the boot.ini file, you should see text that looks like this:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP
    Professional" /fastdetect /DEBUG

    5) Remove the "/DEBUG" listing and any other "/" listings after ""Microsoft
    Windows XP Professional" /fastdetect" *** WARNING - If you have a multi-boot
    option, you may show more than one line under "[Operating systems]". Only
    remove text on the line pertaining to the operating system you are booting
    to. ***
    6) Save the boot.ini file and close all Windows to desktop.
    7) Reboot system.

    Hope this helps.
    --
    Thanks,
    Nick Kritselis [MS]
    ==========================================


    --
    Cheers, Windows XP MVP Shell / User
    Jimmy S. http://mvp.support.microsoft.com

    Game FAQs: http://support.microsoft.com/default.aspx?scid=FH;[LN];gms
    Visit my MSN Zone.com and Gaming Help Site: http://mvps.org/nibblesnbits
    MS Assisted Support: http://support.microsoft.com/select/?target=assistance
    My advice is donated "AS IS" without warranty; nor do I confer any rights.
    _________________________________________________________

    "Marcus H." <nospam@privat.net> wrote in message news:419f72d7$0$181$9b622d9e@news.freenet.de...
    | Hi Jimmy,
    |
    | thanks for your reply!
    | I followed the instructions in KB article 812759 and found out some
    | interesting things about Win XP :-)
    |
    | Unfortunately the methods described didn't help. However I'm now absolutely
    | sure that the problem has to do with SP2.
    |
    | Method 1 didn't apply to me although I have an AMD cpu...
    | Method 2 was very interesting (I didn't know about msconfig) but that did
    | not resolve the problem either.
    | Method 3 is a nice idea - but I have the latest drivers for my audio device!
    | Method 4 & 5 didn't apply to me as I'm not using Creative hardware at all...
    |
    | Hmmm, I just don't want to remove SP2 from my system but I'd really like to
    | play "Pirates of the Caribbean". So what kind of debugging mechanisms could
    | there be in SP2?
    |
    | Any ideas?
    |
    | Have a good time,
    | Marcus
  4. Archived from groups: microsoft.public.games.discussion (More info?)

    Hi Jimmy,

    I took a look at the boot.ini file and there was no /DEBUG switch in it.
    However there was the /NoExecute=OptIn switch which I removed. That didn't
    solve the problem and so I searched the internet for a resolution.
    I came across some homepage which offered a "no-CD-patch" and downloaded
    it - I'm absolutely no fan of patches like this but the game runs without
    problems!

    Now I have a very good idea what's going wrong: The problem has something to
    do with the SafeDisc copy protection and some kind of security functionality
    of SP2. I'm not sure if it's a service that prevents SafeDisc from running.
    I experimented a little by disabling several services but didn't succeed. I
    have to admit that I fear that most of my games won't run with SP2 as they
    are all SafeDisc protected!

    If this is the case I'll have to remove SP2 which I wouldn't like very much
    but finding no way to resolve the issue leaves me no other option.

    Thank you very much for your assistance I appreciated it a lot.

    Best wishes,
    Marcus
  5. Archived from groups: microsoft.public.games.discussion (More info?)

    Do you have Nero installed? I (vaguely) remember someone having a
    similar problem that was solved by uninstalling it.

    Eyal

    Marcus H. wrote:
    > Hi there,
    >
    > after installing SP2 on my Windows XP I got an error message from the game
    > "Pirates of the Caribbean" telling me "A debugger was detected. Close it
    > down and restart the program". I simply cannot find out what's causing this
    > error. Unfortunately Ubi couldn't help me and advised me to re-install my PC
    > :-(
    >
    > I didn't change any settings. But I did install SP2 and that seems to be the
    > reason for the error message. YES, I did disable the script debugging in IE
    > this is not the resolution! And YES I own a original CD of "Pirates of the
    > Caribbean" with no crack or no-CD-patch running!
    >
    > Any suggestions what to do?
    > Any ideas what kind of "debugger" is running in the background?
    > Any help is welcome!
    >
    > Thanks in advance,
    > Marcus
    >
    >
Ask a new question

Read More

Debugger Error Message Windows XP Video Games