Sign in with
Sign up | Sign in
Your question

XP drive letter horror

Last response: in Windows XP
Share
September 13, 2002 7:05:36 PM

My XP PC has two drives, each split into 2 parts -- drive 1 has C (Windows XP), and E, drive 2 has D and F -- well atleast I did have this until I did an XP repair-install.

Now what was C is now given letter "D", and what was D is now lettered "C" - so all my shortcuts don't now work, as they point to C (which is now D)! Windows XP boots OK from D, and all data and progs. are there, on D.

So how do I get D retitled C, and C retitled D - ie back to as before the install.

dan

More about : drive letter horror

September 13, 2002 7:41:44 PM

Try right clicking on on "my Computer", and then click manage. When the management console comes up, click under storage, "Disk Management". In there it will list all of you phsyical disk, and their coresponding logical drives. Right click the drive you want to change, and then select "change drive letter". When you do this, you might have to reassign the drive letters, because if the drive letter is already taken that you want to change it is already taken, you obviously can't choose it. It might take a little juggling around of the letters, but it should work. Good luck. Note: This COULD mess up your system. Especially when changing the letter of the boot drive. I would suggest doing a system restore point to go back to. I don't even know if that will help if you messed up the boot order, and BACKUP or data, always. Do at you own risk.
September 13, 2002 9:24:34 PM

A good idea -- but the one drive that XP does not allow the letter to be changed is the boot drive, which of course is the drive I need set back to "C" from where it is now.

dan
Related resources
September 13, 2002 9:39:52 PM

I have never tried to change to boot drive before, good to know. The only other thing that I can think of is trying third party software, like partition magic. It might do it, or give you the same response XP did. I don't know, again, never really tried to change the drive letter of the boot drive.
September 13, 2002 11:48:18 PM

Schyster!!

Sounds like, to me, is that your d: got marked "active". So, naturally it's the c: (system drive) now.

The answer is, most likey, to mark that d: back to active, and reboot.

P@ll4dium f0r L1f3!
September 14, 2002 12:26:57 AM

Possibly - but -- all my progs and data were, before this happened, on drive C. C has been renamed D, because all my progs are now on D, and I have not transferred them there. Nope -- what was originally called C is now D, and what was called D is now C. It is something to do with drive letter allocation after a repair-install of XP.

dan
September 14, 2002 4:34:16 AM

That is nothing. Twice now my burner and DVD-ROM drives have just disappeared from my system for no apparent reason....


sz
September 14, 2002 9:22:09 AM

In the end nothing would swop the C & D drive letters - so I restored the system from Drive Image backups, then repeated the repair-install of XP,(which was what caused the trouble), and lo ! drive C is now back to being C, and D really is D -- weird ?

dan
September 14, 2002 1:05:52 PM

I know this won't help you, BUT I thought I'd share this. Oldbear might enjoy this since we couldn't figure this out before:

When I would format a drive and setup partitions in XP it would set my C: to F:. This drove me crazy and certain programs wouldn't work unless my main drive was C:

So I tried to change the drive letters within XP. It would not change the main drive letter. I was stuck.

I reformated, reinstalled, redid everything....same problem



Anyways, I let it sit since I was going to be getting a new drive anyways.

The new drive shows up, I format the drive, go to start the install, but spot the F: drive letter being used again and stop. I go back, delete all the partitions and watch very carefully what XP was up to. It kept, no matter what I tried to do, trying to make the main partition F:

I redid the partitions 3 times. On the 4th time it made the main partition E:. On the 5th time it made it C:, but my other partitions were E: and F: so I deleted them all again and amazingly it did it right the 6th time.

Just to see if I was dillusional I deleted all the partitions again and on the 7th time it made a C:, D:, and E: partition the way I wanted it.

Now I know that XP partitions like crap and you have to watch it very carefully. The only other solution I would recommend for you would be to use Partition Magic and see if that would work, but there's not much more I can offer you except my sympathy. At least you got it working in the end.

<font color=red>I'd like to dedicate this post to all my friends, family, and fans. Without them this post would never have been possible. Thank you!</font color=red>
September 14, 2002 2:22:53 PM

You people have some seriously hammered dog sh!t issues with XP.

Fubar at it's greatest intensity.

I've never had any crap like this. Not on any dual boot machine that I've ever setup.

The one time I had issues like this is when I tried out the Nt auto-bootloader. I had winme/win2k running. It made that fat32 partition for winme the system "C:" drive. I couldn't run chkdsk on it without having to reboot the machine. And, to chkdsk the "D:" NTFS partition, I had to reboot. That's two partitions that cannot be checked while the system is running.

My quota is one. I can handle a reboot for one drive. But if there's more than one drive that I have to reboot for, regardless of the fact that I can do both of them on the same reboot, that's out of the question.

I f*cking nixxed that real quick.

But now, I'd get the same problem if I didn't do things like I do.

I use System Commander to bootload my winme/winxp gaming desktop. I load the xp disk, and run through the installer until the point where I have to choose a partition to install too. I delete every single partition there. Then, so I don't have to convert an fat16 to fat32 from fdisk, I make an fat32 partition and let win2k copy over it's 100meg of filez and reboot.

I popout the win2k boot cd, and load the winme cd. It reformats the fat32 partition and loads. Then I install system commander.

This is where the critical point is. I reboot with system commander, and make an NTFS partition just after the fat32 one. I don't bother formatting it, but I do set it "ACTIVE". Even though XP knows it's the second partiion on the drive, it will now recognize and label it as the C:.

Then I install XP. I usually use XP to partition out the rest of the freespace, as you get a few extra options like that.

This really soundz like, somewhere along the line, you got an active partition screwed up. If I were having this problem, I'd delete every single partition on every single drive in the system. Then use XP to create a single parition on your system drive and install it.

You're pretty much guaranteed it's going to be C:.

P@ll4dium f0r L1f3!
September 14, 2002 3:19:03 PM

All that ends well and doesn't kill me is well.

<font color=red>I'd like to dedicate this post to all my friends, family, and fans. Without them this post would never have been possible. Thank you!</font color=red>
!