Sign in with
Sign up | Sign in
Your question

SM Bus controller trouble

Tags:
  • Drivers
  • Controller
  • USB
  • Windows 7
Last response: in Windows 7
Share
November 12, 2012 4:40:51 PM

Hey all,
I have this really frustrating problem that all started with me trying to install the Motioninjoy drivers for PS3 controllers on my PC. at first it worked well but then I had to uninstall them and then things went **** up.

What happened was that most devices were not recognized via USB anymore, specifically the USB bluetooth dongle I bought to connect my PS3 controller wirelessly with. The dongle used to work just fine yesterday (before the uninstallation).

I then went into device manager to figure out the problem and found that the USB controller and the SM Bus controller were listed under "other devices" and were flagged with an exclamation mark so I downloaded the drivers for the USB controller for my mobo (an ASUS p8p67 LE) which caused the system to recognize it.

Yet my SM Bus controller was still flagged and the dongles were still not being recognized so I searched around for the SM's drivers and figured out they were included in the chipset drivers so I downloaded those and tried to set them up but they just freeze up in the middle of the installation (while installing port 9's drivers I believe dunno how to figure out which one that is) and drags on forever, also the installer disables my network connection for some reason and I can only restore it by restarting my PC.

I am at my wit's end here people since I've been doing this pretty much all day.
PS: I use windows 7 64 bits and a Microsoft wireless keyboard and mouse with their own separate USB dongle which works fine BTW for a reason I cannot fathom. The dongle is plugged in during the chipset installation if that makes any difference.

More about : bus controller trouble

a b $ Windows 7
November 13, 2012 3:01:59 PM

what is your computer type and full model
m
0
l
a b \ Driver
a b $ Windows 7
November 13, 2012 3:56:02 PM

You're on the right track. The SM Bus controller driver is part of the chipset drivers. If the ASUS supplied drivers are giving you problems then try getting them from Intel.
m
0
l
Related resources
November 20, 2012 10:23:19 PM

Sorry for the late reply profkefah but my internet was out, I put my PC together a year ago. It's a desktop obviously. Here are my specs:
Mobo: Asus P8p67
Processor: Intel I5 2500K
RAM: 8GB Gskill ripjaws
Anything else that you'd like me to specify please tell me and thanks.
bubblehead I will try that out ASAP.
m
0
l
!