Language bar unavailable or erratic

Archived from groups: microsoft.public.windowsxp.general (More info?)

I've lost usage of the language bar and, when I can make it appear, it
behaves erratically.

For example, the bar doesn't currently appear in the list of toolbars
displayed when I right-click on the taskbar and choose Toolbars. If I go to
Control Panel > Regional and Language Options > Languages tab > Details... I
do see both languages currently installed: "English (United States) - US"
and "French (Canada) - United States-International" -- but the Language Bar
button at the bottom is greyed out.

Other times, I have gotten the Language Bar to reappear in the taskbar, but
with added options that I can't turn off, even if I right-click and uncheck
"Show additional Language Bar icons".

I just want to get my old single "EN" / "FR" icon. Help!
10 answers Last reply
More about language unavailable erratic
  1. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Try this registry file from Kelly's Korner website: http://www.kellys-korner-xp.com/regs_edits/langbarrestore.reg.

    --
    Greetings,
    Daniel Martín


    "Charles Blaquière" <blaq@blaqzone.com> wrote in message news:%23n6rL$mrFHA.904@tk2msftngp13.phx.gbl...
    > I've lost usage of the language bar and, when I can make it appear, it
    > behaves erratically.
    >
    > For example, the bar doesn't currently appear in the list of toolbars
    > displayed when I right-click on the taskbar and choose Toolbars. If I go to
    > Control Panel > Regional and Language Options > Languages tab > Details... I
    > do see both languages currently installed: "English (United States) - US"
    > and "French (Canada) - United States-International" -- but the Language Bar
    > button at the bottom is greyed out.
    >
    > Other times, I have gotten the Language Bar to reappear in the taskbar, but
    > with added options that I can't turn off, even if I right-click and uncheck
    > "Show additional Language Bar icons".
    >
    > I just want to get my old single "EN" / "FR" icon. Help!
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Daniel Martín wrote:
    > Try this registry file from Kelly's Korner website:
    > http://www.kellys-korner-xp.com/regs_edits/langbarrestore.reg.

    I already tried that; it adds "Language Bar" to the taskbar'S Toolbars
    context menu and makes the language bar appear, but the bar is blank.
    Unlocking the taskbar (to allow dotted resize handles to appear) shows the
    area used by the language bar, but it's blank and unresponsive when I click
    or right-click on it.
  3. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Update:

    there's also something wrong with my keyboard settings: Caps Lock and Num
    Lock are stuck on. This is not a hardware problem, since when I switch to
    another user, both keys work normally. Is this a clue?
  4. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Try this:

    1. Open Start, Control Panel.
    2. Select Date, Time, Language, and Regional Options.
    3. Click on Regional and Language Options.
    4. Choose the Languages tab.
    5. Click on Details.
    6. Select the Advanced tab.
    7. Verify if the 'Turn off advanced text services' checkbox is selected. If it is, uncheck it, click Apply and OK.

    --
    Greetings,
    Daniel Martín


    "Charles Blaquière" <blaq@blaqzone.com> wrote in message news:OC9reynrFHA.1684@TK2MSFTNGP14.phx.gbl...
    > Daniel Martín wrote:
    >> Try this registry file from Kelly's Korner website:
    >> http://www.kellys-korner-xp.com/regs_edits/langbarrestore.reg.
    >
    > I already tried that; it adds "Language Bar" to the taskbar'S Toolbars
    > context menu and makes the language bar appear, but the bar is blank.
    > Unlocking the taskbar (to allow dotted resize handles to appear) shows the
    > area used by the language bar, but it's blank and unresponsive when I click
    > or right-click on it.
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.general (More info?)

    This happened to me about 3 weeks ago. Somehow a program install decided to
    change this entry. Following this correction, I notice that the MSI
    installs were occurring in a different language also. Turned out that other
    language settings were changed (last tab). So check to see that all your
    language settings are correct.


    "Daniel Martín" <mardani29@yahoo.es> wrote in message
    news:ueBrcSorFHA.3604@tk2msftngp13.phx.gbl...
    Try this:

    1. Open Start, Control Panel.
    2. Select Date, Time, Language, and Regional Options.
    3. Click on Regional and Language Options.
    4. Choose the Languages tab.
    5. Click on Details.
    6. Select the Advanced tab.
    7. Verify if the 'Turn off advanced text services' checkbox is selected. If
    it is, uncheck it, click Apply and OK.

    --
    Greetings,
    Daniel Martín


    "Charles Blaquière" <blaq@blaqzone.com> wrote in message
    news:OC9reynrFHA.1684@TK2MSFTNGP14.phx.gbl...
    > Daniel Martín wrote:
    >> Try this registry file from Kelly's Korner website:
    >> http://www.kellys-korner-xp.com/regs_edits/langbarrestore.reg.
    >
    > I already tried that; it adds "Language Bar" to the taskbar'S Toolbars
    > context menu and makes the language bar appear, but the bar is blank.
    > Unlocking the taskbar (to allow dotted resize handles to appear) shows the
    > area used by the language bar, but it's blank and unresponsive when I
    > click
    > or right-click on it.
    >
    >
  6. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Have you checked the settings I mentioned in my former message?

    --
    Greetings,
    Daniel Martín


    "Charles Blaquière" <blaq@blaqzone.com> wrote in message news:%23idSUvqrFHA.2588@tk2msftngp13.phx.gbl...
    > Update:
    >
    > there's also something wrong with my keyboard settings: Caps Lock and Num
    > Lock are stuck on. This is not a hardware problem, since when I switch to
    > another user, both keys work normally. Is this a clue?
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Daniel Martín wrote:
    > Have you checked the settings I mentioned in my former message?

    Yes, and they do seem to have *some* effect: they make a Language Bar appear
    on the taskbar, but it's blank. (I can see its reserved space by unlocking
    the taskbar.) Right-clicking on the taskbar shows "Language Bar" in the list
    of toolbars I can activate or deactivate, but the toolbar itself is blank
    and unresponsive when clicked, double-clicked, and right-clicked.

    I have just discovered that, whenever I reboot, the "Turn off advanced text
    services" checkbox is checked again! This identifies a specific problem to
    be solved, for sure. Any guesses? (My user is an administrator, BTW)

    However, even when I turn off the checkbox, my Language Bar doesn't show as
    anything but a blank area.


    To summarize my current problems:

    - Caps Lock and Num lock are always on, but in my user account only.

    - Logging off and on always checks "Turn off advanced text services".

    - Even when visible, the Language Bar is blank and unresponsive.

    - I cannot switch input languages in any way.


    Not only is it tiring to keep typing with the Shift key depressed (my thumb
    hurts! B^) as I try to maintain some semblance of dignity and refuse to JUST
    GIVE UP AND TYPE IN UPPERCASE FOR A COUPLE OF DAYS, but I have bilingual
    work that needs to be done this week -- being unable to switch languages is
    more than a hassle.

    Thanks for your continued help. I'll keep looking on my own as well.
  8. Archived from groups: microsoft.public.windowsxp.general (More info?)

    Update:

    Now, my Caps Lock is off! All that's changed is... I went into the Logitech
    iTouch config utility to check on the setting for one of the Internet
    navigation key (by pressing Ctrl+the key). That turned Caps Lock off. Doing
    it again locks the caps back on. Totally reproducible.

    It also happens that my husband spilled some water on the keyboard this
    week. B^(

    All this leads me to conclude that the keyboard hasn't recovered from its
    liquid encounter, regardless how careful my husband was to give it a
    thorough drying out.


    So, until I get a new keyboard at the store, why don't we consider this
    issue closed for now? There's no sense in trying to solve a possible Windows
    problem while the keyboard acts wonky. Sorry for the false alert; since
    other users didn't have this problem, I thought hardware causes could be
    eliminated... but they probably don't change their iTouch configuration
    either.

    If I still experience problems with a new keyboard, I'll continue the
    thread. Merci à Daniel et Yves pour l'assistance rapide.
  9. I had the same problem and resolved it by first hiding my quick launch toolbar, then clicking and dragging the language bar up and to the left until it popped into a new postion where the quick launch icons had been. The I could see the icons in the language bar there on the left. It's like they were hidden due to some left-justification or something like that within the toolbar. Now I was able to drag the toolbar around some more without losing its icons, back to the right side.

    I think your issue with the caps lock might have to do with the options in the language bar. This is accessible either through the toolbar (options>settings) or through "Regional and Language Options" in the Control Panel). Click on the Languages tab, then settings. Click on the English keyboard. Then in the Preferences section click on "Key Settings..." There you'll see an option for how you want to turn off the caps lock within the keyboard you just selected. (The reason they offer this is that some language keyboards might be set up to use the caps lock key as an additional "shift" function in order to achieve more characters.) So if you fiddle with that setting on the top maybe it will fix the issue.

    Also there you see a little hint in case your language bar doesn't work and you want to toggle to another language - for me it shows the key sequence to be Left Alt + Shift.

    I hope this helps.
    -Rebecca

    Quote:
    Archived from groups: microsoft.public.windowsxp.general (More info?)

    I've lost usage of the language bar and, when I can make it appear, it
    behaves erratically.

    For example, the bar doesn't currently appear in the list of toolbars
    displayed when I right-click on the taskbar and choose Toolbars. If I go to
    Control Panel > Regional and Language Options > Languages tab > Details... I
    do see both languages currently installed: "English (United States) - US"
    and "French (Canada) - United States-International" -- but the Language Bar
    button at the bottom is greyed out.

    Other times, I have gotten the Language Bar to reappear in the taskbar, but
    with added options that I can't turn off, even if I right-click and uncheck
    "Show additional Language Bar icons".

    I just want to get my old single "EN" / "FR" icon. Help!



    Quote:
    Archived from groups: microsoft.public.windowsxp.general (More info?)

    I've lost usage of the language bar and, when I can make it appear, it
    behaves erratically.

    For example, the bar doesn't currently appear in the list of toolbars
    displayed when I right-click on the taskbar and choose Toolbars. If I go to
    Control Panel > Regional and Language Options > Languages tab > Details... I
    do see both languages currently installed: "English (United States) - US"
    and "French (Canada) - United States-International" -- but the Language Bar
    button at the bottom is greyed out.

    Other times, I have gotten the Language Bar to reappear in the taskbar, but
    with added options that I can't turn off, even if I right-click and uncheck
    "Show additional Language Bar icons".

    I just want to get my old single "EN" / "FR" icon. Help!
  10. Quote:

    I hope this helps.
    -Rebecca


    Did you just happen to notice this post is from over 5 years ago?
    Great effort, but me thinks the original poster might not even own that computer any more.
Ask a new question

Read More

Windows XP