Sign in with
Sign up | Sign in
Your question
Solved

Pioneer VSX-521-k and ASUS M4A89GTD PRO/USB3

Last response: in Home Audio
Share
October 20, 2011 11:35:06 PM

Hey Guys and Gals,

I just bought a new receiver to replace a older Denon receiver when the optical audio jacks gave out. I really loved it, but when it went out it went out. Long story short, I bought a Pioneer VSX-521-k. My cousin has always like Pioneer receivers and I have heard good opinions on the subject.

I plugged everything in and ran their version of the auto-setup for surround sound/speaker spacing etc.

I have my hdmi going out of my onboard hdmi video output. I have it going to 1 of the hdmi inputs on the receiver. For some reason the HDMI doesn't output from the comp to the tv or through the receiver. It used to, but I installed an Asus Ares vid card. And for some reason or another, it stopped working. Lighting strike close to the house recently and think it went haywire shortly there after. I pulled the card and ever since the audio hasn't passed over the HDMI cable.

I can pass the video thought the receiver to the tv just fine. Looks just like it would if it were direct, the sound still doesn't work but I think that is a windows/computer side issue. The mobo has an optical output that I ran to an input on the receiver. I have it set for the optical 1 slot to work with the hdmi input. But no sound comes out of it that way either. I am ordering a brand new optical cable to see if the cable is broken or if it is another issue.

Another thing that I noticed that probably somewhere plays a part is I play diablo 2. When I run the HDMI cable direct to the back of my TV, it plays fine. When I try to pass it through the receiver....it won't start. It tells me there is a critical error wiht the direct draw. I am guessing that the receiver isn't able to pass that through for some reason. If I unplug it and plug it back in to the TV direct....it works fine. So I know there is some issue there. I just don't know how much is related.

I could go on with every little thing that I think might be important, but I will end my novel here and seek more guided questions from the community.

Thanks guys and gals!

-Brook
October 21, 2011 7:01:05 AM

lets try this first: follow the directions here @http://www.tinyeye.com/avsetup/soundsetup_xp.html follow it step by step until you get to the part that shows the audio tab and in the Default device drop down look for your devices i.e. "HDMI" or "Digital Output" ect. select the one you want to output and see if you don't get audio. just be carefull and keep the volume down each time you try one, if you don't know which one to choose. the procedure should be about the same for any given version of Windows you use.

as far as the game not working, I do not have much experience with it, but I have read many post that say there are probs trying to get games to work with HDMI and AVR receivers, try the component inputs and see if the game works at all.

hope this helps, erl
m
0
l
October 24, 2011 11:54:42 AM

Dude,

Thanks so much for helping. I thought I would let you know where I am at right now. I didn't try what you said yet...getting ready to try that. I just worked a ton of hours so I had to wait to do anything till MY weekend.

I now have the video passthrough. I have sound coming through the HDMI. I have confirmed that the receiver knows that there is signal from the optical port (whether or not it knows how to handle it or not). The game now works fine. It does have some switch time lag...but it is totally playable. I havn't figured out how to get the hdmi in to the receiver and play though the speakers...accepting the sound at the receiver but now passing it on to the tv. right now it will only pass it on to the tv.

I know that this pioneer isn't the ulta high end model. But damn. I have never had this much difficulty with any sort of tech. I mean I built my own screaming monster computer from total scratch.

Anyways...Thanks again man. I appreciate it. I am going to go through the page you sent me to. I will let you know how that turns out.

-Brook
(matits)
m
0
l
Related resources
November 8, 2011 1:23:16 AM

It is some problem with the computer or the receiver with the optical. It would cut in and out of sync with Dobly. I abandoned that search and found that it was way easier to just use the HDMI cable. It doesn't have as many options for manipulation like the optical, but it works just the same, and works. That would be the key thing.

Since just using the HDMI it stays locked in Dolby Digital all the time, even if the media isn't. It doesn't play the back speakers it just plays the stereo speakers. Then when 5.1 media is played, they come to life.


Thanks bud!
m
0
l

Best solution

December 1, 2011 10:09:35 AM

matits said:
It is some problem with the computer or the receiver with the optical. It would cut in and out of sync with Dobly. I abandoned that search and found that it was way easier to just use the HDMI cable. It doesn't have as many options for manipulation like the optical, but it works just the same, and works. That would be the key thing.

Since just using the HDMI it stays locked in Dolby Digital all the time, even if the media isn't. It doesn't play the back speakers it just plays the stereo speakers. Then when 5.1 media is played, they come to life.


Thanks bud!

i have experienced the same issue. a technician suggested that i use an hdmi 1.4 cable so the vsx 521k receiver can recognize the audio format of the movie i am playing (since the receiver is already fit for the latest version of the hdmi cable). alternatively, i used an optical cable and selected the "auto surround" function of said receiver and it automatically recognizes and selects the audio format being transmitted by the source unit (hd multi media player). however, only an hdmi 1.4 cable can recognize the dts master audio format, which is more superior. as such, you may try using said cable. hope this helps. good luck. let me know of you progress. thanks.- guitarman
Share
December 1, 2011 3:30:01 PM

Best answer selected by matits.
m
0
l
!