Sign in with
Sign up | Sign in
Your question

Razer Deathadder (Left Handed) 3500 DPI Driver Issue

Last response: in Computer Peripherals
Share
November 5, 2010 10:07:40 PM

Hello everyone,

I hope someone here might be able to help me out with an issue I am having with my Razer mouse. I would talk directly with Razer, but they seem to be reluctant to email back about the issue. Just for a little background information. I have been having issues where my Windows 7 power options wouldn't turn my displays off regardless of what I did. I took control of Windows and so on and so forth with no resolution. I went ahead and went into msconfig, and disabled all my startup programs to see if something in there was causing the issue. Upon disabling everything and restarting my power options worked correctly. I added back startup programs one by one until I found the issue. The issue happened to be the razerhid Application which is what allows my drivers/customizer to work. I tried then disabling everything and enabling just the razerhid Application and sure enough the displays did not work. This verified my findings. My question now, has anyone encountered such and issue, have a solution or anything that might be helpful. I can continue to just turn my monitors off when I am done with them, but hate to have them left on for hours when I forget about them.

Thanks

Chris
February 19, 2011 3:40:44 PM

Hi there,

Yup, having the same problem with my windows 7 system and my Deathadder lefthanded 3500 mouse. As well as interfering with my power options, it also stopped my screensaver from working.

I did the same research as you to find the culprit (the startup program - razerhid application). Once I disabled it with msconfig, screen operated normally (power and screensaver).

I contaced razer via phone, and their suggestion was to back my driver from v3.01 to v3.00. That SEEMED to work on re-installation and reboot (both power and screen saver) but after going into the razer application and customizing some settings, it was back to causing the same problems.

I've disabled the razerhid application again and just changed my mouse options in control panel until i get a proper resolution.


Anyone else?
m
0
l
!