Sign in with
Sign up | Sign in
Your question

Moving Windows from AHCI to RAID

Last response: in Windows 7
Share
November 18, 2012 12:53:18 AM

Hi Guys,

I have an Asus Rampage IV Extreme Motherboard and have Windows 7 Installed on a 96gb kingston ssd.

I now bought 2x 256gb Samsung 830s and want to run them in raid.

If I set my RAID in bios, I cannot boot into my kingston ssd, it blue screens.

If I set it to AHCI I cannot run my ssds in Raid.


I can do a fresh install on the ssds but how do I move my programs and data over?

Any help would be appreciated.

BTW.. I have Norton Ghost 15 which was provided with the Sammy 830s... just letting you guys know if that would help

Ash
a b $ Windows 7
November 18, 2012 12:59:06 AM

this should work.

Just boot with AHCI mode, make the chance then reboot in raid. After it boots fine, clone away.

http://www.gregledet.net/?p=569

I have done this in reverse to go from raid to ahci and it worked fine.
m
0
l
November 18, 2012 1:13:35 AM

@nukemaster thanks for the quick reply but Ive been at it for hours now, have tried this, doesnt work for me... I did not clone but right now I set my bios to AHCI and am on my Win7 from the old SSD... I went into the registry made the changes and rebooted, now selected RAID in bios and tried booting with the kingston again but bsod again.. been up all night with this (... after waiting a month for my ssds to be delivered due to being caught up in an ebay scam :(  )
m
0
l
Related resources
a b $ Windows 7
November 18, 2012 1:46:50 AM

You DID install the raid drivers FIRST right?
m
0
l
a b $ Windows 7
November 18, 2012 2:23:04 AM

On Win8, I had to edit some slightly different values. I think it was iastor and not iastorV. But again, I was going in reverse leaving raid for AHCI.
m
0
l
November 18, 2012 2:24:52 AM

@unksol yes I did install the drivers then reboot to bios change to raid and still experience blue screen on boot.

@nukemaster any other ideas brother?
m
0
l
a b $ Windows 7
November 18, 2012 2:29:50 AM

check to see if msahci is set to 3 as well, just in case you are using MS drivers and NOT Intel.
m
0
l
November 18, 2012 2:34:26 AM

All set to 0 bro
m
0
l
a b $ Windows 7
November 18, 2012 2:40:39 AM

Don't you want 3 to disable and 0 to enable?

My current setting that is AHCI is
msahci 0
iastor 0
iastorV 0

I will go check a raid machine to see what it is set as

MS has a fix, not sure if it works, never tried it. I would guess it would work.
http://support.microsoft.com/kb/922976

EDIT.
The raid system is the same. Maybe because I also have AHCI(ESATA) ports on the same system.
So maybe try from here
http://communities.intel.com/thread/28709
iaStor = 3 <-disable
iastorV Start = 0 <-enable
msahci Start = 3 <-disable

I may still have my old drive from when it was set to RAID. so maybe i can get it switch to ACHI(get it booting) then switch back to raid and see the keys that need messing with, but that would be in the morning.
m
0
l
!