Sign in with
Sign up | Sign in
Your question

Faulty keyboard behaviour

Last response: in Windows XP
Share
September 6, 2005 2:21:38 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

In a CMD prompt when I press the | character I get Alt 224 rather than Alt
124, this is causing huge issues as they look similar but are totally
different characters.

How can I fix this?
September 6, 2005 2:36:12 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Sorry 221 and 124 not 224
Anonymous
September 6, 2005 5:06:08 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Sounds like you have the wrong keyboard driver available in DOS mode - it
would by default assume a US keyboard, and yours is a UK keyboard
Check your settings in Regional Settings and make sure that they're correct.


--
Noel Paton (MS-MVP 2002-2005, Windows)

Nil Carborundum Illegitemi
http://www.btinternet.com/~winnoel/millsrpch.htm

http://tinyurl.com/6oztj

Please read http://dts-l.org/goodpost.htm on how to post messages to NG's

"Martin" <martin@jotika.co.uk> wrote in message
news:e1vkwZssFHA.304@TK2MSFTNGP11.phx.gbl...
> Sorry 221 and 124 not 224
>
>
September 8, 2005 8:52:33 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Noel Paton <NoelDPspamless@aol.com> wrote on Tue, 6 Sep 2005:

>Sounds like you have the wrong keyboard driver available in DOS mode - it
>would by default assume a US keyboard, and yours is a UK keyboard
>Check your settings in Regional Settings and make sure that they're correct.

It isn't that, Noel. It's a Windows thing I never heard of until today.

I found I have the same problem as Martin, and not just in a Command
window either -- the same is true in Notepad, Word and every other
Windows program. My keyboard is set to United Kingdom and in every other
way behaves as a correctly brought-up UK keyboard should, i.e. GB pound
sign, #, @, quotes and apostrophe all in their correct places as per
what's printed on the keycaps.

Martin, have you tried the broken bar key (Shift-backslash, to the left
of Z)? What I'm finding is that on my keyboard the vertical line or pipe
(Alt-124 |) and the broken bar (Alt-221 ¦) are transposed, despite what
it says on the keytop. I have a Microsoft keyboard and I'm betting you
do, too.

I found this at Wikipedia which may explain the mystery:
http://en.wikipedia.org/wiki/Keyboard_layout#UK

<quote> --------------------------------------------
The key to the immediate left of numeral 1 (backtick, `) gives (logical
NOT, ¬) when shifted (instead of ~) and with AltGr either

* vertical bar | (OS/2's UK166 keyboard layout, Linux UK keyboard
layout, and as usually printed on the keytop on keyboards sold in the
UK),
or
* broken vertical bar ¦ (Microsoft Windows' UK keyboard layout);

The key to the immediate left of Z gives, when shifted, either

* broken vertical bar ¦ (OS/2's UK166 keyboard layout and as usually
printed on the keytop on keyboards sold in the UK),
or
* vertical bar | (Microsoft Windows' UK keyboard layout and Linux UK
keyboard layout).
</quote> -------------------------------------------

So it would seem we've got standard UK keycap layout, but what prints is
Microsoft Windows UK layout, whatever that may be :-) You can see it by
going to Windows Keyboard Layouts at Microsoft:
http://www.microsoft.com/globaldev/reference/keyboards....
and choosing UK keyboard. Press the Alt Gr or Shift key to see the keys
in question. It's quite hard to see the difference at this small size,
but if you hover your mouse over them an info-tip will pop up confirming
that the characters are swapped from where we would expect them to be.

Martin, hope it's some comfort to know your keyboard isn't faulty, and
that you can still access the character you need.

--
Nightowl
!