Cant pick DMA with XP?

Hello all,

After reading a tweak guild for XP, I went to make sure my HD was using DMA only to find out the advanced option with the DMA settings was not there. Anyone have an idea why? Im using XP pro NTFS with a P2 2gig, 40 gig harddrive on a intel D850GB MB. Is the DMA setting with the OS or the harddrive?

Thanks all
3 answers Last reply
More about cant pick
  1. Have you installed the 850 chipset drivers for the mainboard?

    If you haven't, then you should, for best performance ... starting with the Intel Chipset Software Installation Utility, and then the Intel Application Accelerator.

    If you <i>have</i> installed the Application Accelerator, then the DMA/UDMA options in the Device Manager for the IDE controller channels will not be available. Instead, to check the status of your devices, the Application Accelerator will be listed on your Start Menu, and you can open the viewer from this area.

    Note: FYI ... after installing an operating system with an Intel mainboard, it's a standard rule-of-thumb that the very first drivers that should be updated are for the chipset. And the drivers should always be obtained from Intel, <i>not</i> Windows Update.

    <A HREF="" target="_new">Intel Chipset - Driver Matrix</A>


    <font color=red>First Rig:</font color=red> <A HREF="" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
    <font color=red>Second Rig:</font color=red> <A HREF="" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>

    <A HREF="" target="_new"><b><font color=purple></font color=purple></b></A> - <i><font color=orange>A better place to be</font color=orange></i>. :wink:
  2. Thanks a lot Toejam !!!

    I will try this asap.

  3. XP has done this on a couple of occasions for me. I could tell it would happen due to my CD burner not burning correctly and performance errors with it. I found that getting the latest IDE software from your manufacturer (in my case VIA) will work. Sometimes though this is not the case, and this has worked each time; go into device settings and delete everything in the IDE/ATAPI controllers folder: Primary, Secondary, etc.

    Reboot once they're all deleted. Upon startup XP will reconfigure everything and prompt for a reboot. Once you're finally up and running, check the IDE channels again. Your primary should be in DMA 5, or whatever and the CD drive in DMA mode 1, etc and not PIO :)

Ask a new question

Read More

DMA Hard Drives Windows XP