Sign in with
Sign up | Sign in
Your question
Closed

System will not boot to Windows 7 Professional

Last response: in Windows 7
Share
November 20, 2012 3:51:27 AM

Hi All,

My Desktop restarted on its own while I was browsing online and won’t boot to Windows 7 Pro. This is what shows up:
File: \Windows\system32\winload.exe
Status: 0xc0000428
Info: Windows cannot verify the digital signature for this file.


" alt="" class="imgLz frmImg " />



BELOW ARE ACTIONS I HAVE TAKEN SO FAR:

1.
I boot my windows 7 prof. upgrade cd to repair and the system recovery options has:
OS: Window 7
Partition size: 114369 MB
Location: (D) Local Disk
Why is my Operating system located on D:? Shouldn’t be on my primary C drive?

" alt="" class="imgLz frmImg " />



2.
I attempted system repair and problem signature07 missingOSLoader showed up.

" alt="" class="imgLz frmImg " />




3.

On DOS prompt:
Action: Bootrec /fixMBR
Result: The operation completed successfully
Action: bootrec /fixBoot
Result: The operation completed successfully
Action: bootrec /rebuildBCD
Result: Successfully scanned windows installations. Total identified windows installations: 0
The operation completes successfully.
" alt="" class="imgLz frmImg " />

Since the BCD store exists and lists a Windows installation, you'll first have to "remove" it manually and then try to rebuild it again

bcdedit /export c:\bcdbackup

At this point, you need to adjust several file attributes for the BCD store so you can manipulate it.

attrib c:\boot\bcd -h -r –s

To rename the BCD store, execute the ren command as shown:

ren c:\boot\bcd bcd.old

rebuilding the BCD
bootrec /rebuildbcd

result:
Scanning all disks for Windows installations.

Please wait, since this may take a while...

Successfully scanned Windows installations.
Total identified Windows installations: 1
[1] D:\Windows
Add installation to boot list? Yes<Y>/No<N>/All<A>:

Yes,

Result: restart did not fix the problem



4.
Memory check ok



5.

Ran System File Checker
sfc /scannow /offbootdir=d:\ /offwindir=d:\windows
Windows resource protection did not find any integrity violation

Other Information:

I cannot F8 to advance boot option when loading from the Agility SSD, it only works when booting from Window 7 upgrade CD I have, but that doesn’t help since it boots to the Install & windows repair screen.

" alt="" class="imgLz frmImg " />


I built this Computer June of 2011 and had no problem. In July of 2012 I migrated my current Primary Drive to a new OCZ Agility 3 AGT3-25SAT3-120G and since then there has been about half a dozen times when it will not boot up to my OS. It displays:

“Version 2.02.1205, Copyright ( c ) 2010 American Megatrends, Inc.”

" alt="" class="imgLz frmImg " />

After a manually shutdown and startup it boots fine. Does this have anything to do with the issue now?

WHAT I AM ASKING:

How to fix this issue:
File: \Windows\system32\winload.exe
Status: 0xc0000428
Info: Windows cannot verify the digital signature for this file.


And

missingOSLoader


Any help would be much appreciated. Thanks in advance.

Best solution

November 20, 2012 9:05:29 PM

Hi, I want to share the solution that worked for me step by step so anyone can try it and see if it works for you. In many other forums people find their solution and post “I got it! It Works!” And never provide the steps so others may benefit from it, so here is my contribution for this issue.

Here is the solution that worked for me after trying many others. Please follow all the steps from top to bottom. (note: these instructions are not created by me, but steps that I have taken that worked for me)
1. Startup Repair (you may have to run it several times).

2. If the above doesn't cure the problem, go back to the Repair Option and this time choose Command Prompt, then type these 4 commands (in all instances the capitals are for clarity only):
BOOTREC /FIXMBR and press Enter
BOOTREC /FIXBOOT and press Enter.
BOOTREC /SCANOS and press Enter.
BOOTREC /REBUILDBCD and press Enter.

3. If it’s not successful or you receive ‘No operating system found’ or ‘Element not found’ messages, go back to the Command Prompt and make the partition active by typing these commands:
DISKPART and press Enter.
LIST DISK and press Enter.
SELECT DISK N and press Enter (N represents the disk you want).
LIST PARTITION and press Enter.
SELECT PARTITION N and press Enter (N represents the partition you want).
ACTIVE and press Enter.
EXIT and press Enter.
Startup repair reboot
For me the following boot problem occurred after the startup repair and if something like this or similar goes back to startup repair again.
File: \boot\bcd
Status: 0xc000000f
Info: An error occurred while attempting to read the boot configuration data.
After another Startup repair and reboot all is back to NORMAL!!
Share
November 20, 2012 9:07:05 PM

I got my own BEST ANSWER !! Too bad I can't select my own answer as best.
Score
0
Related resources
a c 416 $ Windows 7
November 20, 2012 9:09:48 PM

Best answer selected by SR-71 Blackbird.
Score
0
a c 416 $ Windows 7
November 20, 2012 9:10:23 PM

This topic has been closed by SR-71 Blackbird
Score
0
!