Sign in with
Sign up | Sign in
Your question
Closed

Logged into admin account = still can't delete anything.

Last response: in Windows 7
Share
April 10, 2010 6:22:49 PM

I kind of have a thread up on this subject already but not to this extent. I just logged into the hidden admin account and all i am trying to do is delete a folder. When i try to it says you need permission from [my OTHER account]. If i am logged into that administrator account (not the hidden one) I STILL can't delete the file. My question is how can i fix this, and what is the point of this super-powerful administrator account that is suppose to have power to do anything if it can't even delete a file/folder? I have checked the permissions, and this hidden admin account is suppose to have full rights, permissions, whatever.

This particular folder that i want to delete is on another hd, other than the root drive. running win 7 64.

I have never had a problem like this.
a b 8 Security
a c 209 $ Windows 7
April 10, 2010 6:37:05 PM

If you're trying to delete a personal folder, chances are that it's security settings are denying you access. Windows creates personal folders which don't allow administrative access by default (this is a good, security-conscious thing).

If this is the case, you need to right-click on the folder, go into the security settings for it, and do two things:

1) Take ownership of the folder and it's contents
2) Change the access settings for the folder and it's contents to allow "full control" by Administrators

Once you've done this you should be able to delete the folder.
Score
0
April 10, 2010 6:50:41 PM


All of the group or user names under the security tab on the file in question have the 'Allow' checkmark on each user group. this would include authenticated users, system, Iceman (my main account withthe path Iceman-pc/iceman) Administrators (witht the path iceman-pc\administrators) and users (iceman-pc\users). So under this true admin account i am allowed to change the Iceman and administrators permissions. they are both a full 'allow' checkmarks. Under the advanced tab, then owner, the current owner is administrator @ Iceman-pc\administrator. So i do believe i am the owner.THe only thing i don't quite understand is the inherited from part in the permissions tab. For the group administrators full control is granted, not inherited, and this applies to the folder, subfolders, etc.

So once again i should be able to do whatever i would like with these permissions. My other account (iceman) has just the same amount of permission as this other admin accout. i still can't move/ delete anything. I hate windows.
Score
0
Related resources
a b 8 Security
a c 209 $ Windows 7
April 10, 2010 7:08:51 PM

What folder is it that you're trying to delete?
Score
0
April 10, 2010 7:20:14 PM

it is just an installation directory for a game. I tried uninstalling it, it said removal complete, but i can still run the game....so i wanted to remove the files themselves.. but turns out i can't do that either. If i don't find a solution on here, i will be reformatting that hd tonight. I will have my revenge.
Score
0
a b 8 Security
a c 209 $ Windows 7
April 10, 2010 7:41:41 PM

Are you trying to delete them from the command line? UAC in Windows removes admin privileges from programs unless they specifically request them, so if you want to do something requiring admin privileges in a command line window then you have to open the window using "Run As Administrator".
Score
0
April 10, 2010 8:10:59 PM

I have turned UAC off, run cmd as admin and still get access denied when trying to delete.
Score
0
a b 8 Security
a c 209 $ Windows 7
April 10, 2010 8:51:50 PM

I wonder if the folder is a reparse point rather than a real folder...

...other than that, I'm out of ideas...
Score
0
a b $ Windows 7
April 12, 2010 5:21:52 PM

Have you tried rebooting into safe mode and see if you can do it that way?
Score
0
April 14, 2010 5:28:43 PM

Yup. I'll just chalk this one up to the computer. You win.

...for now.
Score
0
April 14, 2010 10:05:21 PM

I figured it out!! I was having the same problem but finally figured out a solution.

Right click on the folder > Properties > Security > Advanced

On the Permissions tab, click Change Permissions. The following window will list all permission entries. Check BOTH boxes below, one says, "Include inheritable permissions from this object's parent" and the other says, "Replace all child object permissions with inheritable permissions from this object." Click APPLY. A security message will come up about permissions, click YES. Then, uncheck the box (only the top box should be checked after you click apply) and you will be prompted with a security message. Click REMOVE.

Now, with all folders I've done this with except one, all permissions were removed except "Users". This is exactly what you want. The exception was one folder deleted ALL permissions which would not allow anyone to edit the file which you obviously don't want. For this file, I manually removed all permissions via the remove button except "users" and this worked as well.

Hope you get as much joy out of beating the system as I did!
Score
0
April 15, 2010 1:54:27 AM

Sorry dude, this didn't work for me. It removed all but 3 permissions...which gave me hope..but still even those .txt files are set in stone, forever laughing with at my misery as i struggle to delete the 2 kb files.

Thanks for the help though, i hope it helps someone else.
Score
0

Best solution

a b 8 Security
a c 209 $ Windows 7
April 15, 2010 3:37:12 AM

The files may be open by some program. Try booting in safe mode to see if you can delete them that way.
Share
a b $ Windows 7
April 15, 2010 12:27:12 PM

sminlal said:
The files may be open by some program. Try booting in safe mode to see if you can delete them that way.


Let's see if he listens. I had suggested he do this and he had a response to someone that something didn't work, but I couldn't tell if he was responding to my suggestion and saying it didn't work.

This is what has always done it for me when I found I couldn't delete a file.
Score
0
April 15, 2010 2:51:57 PM

sminalal- while trying to delete, it doesn't say the file is in use by some other program, it states you need permission from user/Iceman. <--the account i am always logged into.

isamuelson- sorry, my reply was to to you, I did try safe mode, twice.
Score
0
a b $ Windows 7
April 15, 2010 3:59:02 PM

iceman845 said:
sminalal- while trying to delete, it doesn't say the file is in use by some other program, it states you need permission from user/Iceman. <--the account i am always logged into.

isamuelson- sorry, my reply was to to you, I did try safe mode, twice.


No problem. That makes me REALLY scratch my head then.

Score
0
a b 8 Security
a c 209 $ Windows 7
April 15, 2010 4:47:21 PM

Can you post a screenshot of the message you're getting?
Score
0
April 16, 2010 3:30:24 AM

iceman845 said:
Sorry dude, this didn't work for me. It removed all but 3 permissions...which gave me hope..but still even those .txt files are set in stone, forever laughing with at my misery as i struggle to delete the 2 kb files.

Thanks for the help though, i hope it helps someone else.



You may have to remove the other permissions by manually pressing the remove button. Remove all except users
Score
0
April 27, 2010 1:47:57 AM

I just got back to my computer (been gone for quite some time) and I tried once again to start in safe mode w/o networking to try and delete the permissions. I deleted them and hit accept..went back in and added administrators and users/iceman w/ full permissions and this time...no clue why...but it accepted it. I restarted in normal mode and sure enough, that folder was now gone. So thank you everyone who pitched in to this and sorry for my absence... thanks again!

ps. would it be that i didn't use my computer in about a week??? lol maybe w/o networking did the trick? i used just regular safe mode before...
Score
0
April 27, 2010 1:48:46 AM

Best answer selected by iceman845.
Score
0
February 24, 2013 11:56:32 PM

Well, I worked on this for about 1.5 hours myself...trying to delete Internet Explorer (I use Chrome instead). I tried everything, but I finally found a relatively simple way to 'delete' a file. It's kind of a workaround, but it works. xD

1) Get yourself an external storage device (like a USB, for example) and plug it into your computer if you haven't already.

2) Select the file that you wish to delete (if you have a lot of files, try to put them all into one large file if you can...it makes it easier).

3) Right-Click the file, select 'Cut'. On Windows 8, after doing this you will see a greyed-out version of the file that you cut. Don't worry about that, that's supposed to be there.

4) Try to 'Paste' the file into your portable storage device. The computer should realize you're doing this, and will make it impossible for you to do it. HOWEVER, when you 'Paste' the file into the USB, the greyed-out version (after you 'Cut' it) will dissapear.

5) Congrats! You tricked the system and deleted the file. Just remember not to re-paste it elsewhere in your computer. :p 

Anyways, hope this helped. - Amalgam Animus
Score
0
!