Re-enabling a ps/2 keyboard

Hi everyone,

I recently bought a cheap USB wireless keyboard and now quite regret it (spotty performance, short range) But I figure no big deal, I'll go back to my wired PS/2 keyboard. But now I can't get the PS/2 keyboard to work.

From what I've read online, the default is that whenever a USB keyboard is detected, your computer will disable your PS/2 keyboard port, and that seems the case here. The PS/2 keyboard light does flash momentarily during boot or restart so it's getting power, but does not work at all. I've also got a second PS/2 keyboard that's exhibiting the same results so it's not a hardware problem with the keyboard.

I've also read that in order to re-enable the PS/2 input I need to change a setting during BIOS setup. MY USB keyboard works well enough for me to go into the settings to make changes (and to type this), but once in the BIOS I've scoured the settings for anything that says Keyboard or PS/2 or AT - specifically for anything that was disabled, and either it's not there or I'll feel incredibly embarrassed.

I'm running Windows 7 and here's my motherboard:
Board: ECS H55H-CM 1.0
Bus Clock: 133 megahertz
BIOS: American Megatrends Inc. 080015 05/19/2010

I've tried:
Uninstalling the keyboard USB drivers and restarting.
Uninstalling the keyboard USB drivers and rebooting (on/off).
Going into BIOS, choosing "apply default settings", hitting enter, and unplugging the USB keyboard before Windows starts.
Rebooting/restarting with and without either of USB and/or PS/2 keyboard plugged in.

So, any suggestions? In my motherboard's BIOS settings, is there something else that the PS/2 keyboard setting could be called? If nobody has any better ideas, next if it might help, I could go into the BIOS and write down all the options it gives me and type them out here to you you all (as ridiculous as that sounds).

Thanks a million,
Dustin
2 answers Last reply
More about enabling keyboard
  1. mine acts the same way. i keep a spare usb attached to it at all times (as a backup) and just happened to notice this behavior.

    if you have both a usb and ps2 keyboard plugged in... both should work at the same time. a temporary fix if you want to use the one keyboard while you try to find a solution.

    i'm unsure of the bios settings to fix your issue...but perhaps a ps2->usb adapter would solve your issue through hardware not software? my guess is that it is recognizing the port to be registered to the keyboard and not the keyboard itself. meaning that any usb keyboard in the slot would work (and maybe your ps2 keyboard with adapter)
  2. OK some time has elapsed since this was posted, but I just had the same problem and found SSDX's partial solution (have bothe USB and PS/2 keyboards connected at the same time). That worked for me but I was then able to revert to just using a PS/2 keyboard alone.
    Here is how I did it (really simple really). With both keyboards connected and both working, I disconnected the USB keyboard and found the PS/2 KB still worked. I then did a restart with just the PS/2 KB connected and hey presto! it worked and continues just as it was before I upgraded. No software of BIOS changes needed.

    I did look in the BIOS and found no mention of PS/2 anywhere, but while I was using the USB keyboard the Advanced USB option showed USB keyboard enabled with no option to change it, After my fix I had another look at the same place in the BIOS and there was no mention of a USB keyboard at all.

    HTH someone.
Ask a new question

Read More

PS/2 USB Keyboards Peripherals