How i enable parallel port

Win7 proffessional service pk 1. Parallell port does not work. i have set the port address as per the device manager, the port is enabled in the bios, on some systems this works on others with the same os it does not is there any address or settings in the registry i should be setting or changing.
7 answers Last reply
More about enable parallel port
  1. What error message / symptom? Any "!" next to it in device manager? All the same hardware? What hardware? What printers? We need more details!
  2. i am using this port to drive something other than a printer. Device manager finds the port and an address is shown, however when i connect my breakout box which just monitors the outputs, the status differs from machine to machine consequently when running the same software one machine works and another does not. Does anyone think this may be a driver problem?
    the output from the port is what is. Can this be changed or set in any wayother than changeing the address?
  3. What mode is the port set for (ECP, EPP, PS/2, etc..), and is it the same an all machines?

    Are all machines running the same OS?

    Are you attempting to access the port hardware directly? (not allowed except by driver level code)
  4. the mode is differant across the 2 machines one says ecp system works fine and the other says Lpt only does not work. both machines running win7 service pk1
  5. forgot to add that both systems have the port built onto the motherboard and is not on a pci slot
  6. also both systems using the same driver inpout 32.dll.
  7. keith_75 said:
    the mode is differant across the 2 machines one says ecp system works fine and the other says Lpt only does not work. both machines running win7 service pk1


    There's your problem. Change the mode to ECP on the one that doesn't work. If it's a builtj-in port then you change the mode in BIOS.
Ask a new question

Read More

Device Manager Parallel Port Windows 7