Sign in with
Sign up | Sign in
Your question
Solved

Problem with Logitech z506

Last response: in Home Audio
Share
March 6, 2012 12:28:03 AM

I realize these aren't truly high-end speakers, but this was the closest category I could think of. I bought, about 3 months ago, a Logitech z506 5.1 system for my computer. They worked fine initially but in the last few days, I have noticed that the sound on the two front speakers has stopped outputting; though, the front speaker with the volume knob will still control the volume. The sub-woofer also hits very quietly, even turned all the way up. I played around with my sound card's settings to see if i could get the front speakers to output- I have a Creative Titanium Pro sound card. I had the sound card's profile set on game, and when I changed it to entertainment, I got sound to the front two speakers, but the sound stopped from the rear two and the center. Then, by pressing the inputs into the sub-woofer really hard and holding them there, I got that to start hitting nicely again. Ultimately, I'm not sure whether this is a speaker problem or a sound card problem. Any thoughts? I can provide other system information if its needed. Thanks! :D 

More about : problem logitech z506

Best solution

March 6, 2012 8:29:43 PM
Share

The solder connections in the sub are broken, or the plug for the audio, into the sub is broken.
March 9, 2012 4:44:43 PM

Ahhh, I suspected as much. Thank you very much!
March 9, 2012 4:44:51 PM

Best answer selected by koolkat574.
!