Sign in with
Sign up | Sign in
Your question

Blu ray player skipping in my computer

Last response: in Laptops & Notebooks
Share
May 23, 2010 7:46:04 PM

this is my second dell first xps 1540, dell replaced it with a studio 1640 xps,windows 7 with t9600 2.8 ghz processor, 8 gb memory, and ATI Mobility Radeon hd 3670 graphics card my blu ray disc skips every 10 to 20 seconds, hd dvd's play just fine, running Power dvd software 8.3 version from dell pack, the mother board has been replaced twice along with the player, to no sucess, dell now wants to re-format my hard drive just a pain, does anyone know what may be causing this issue I tried to contact cyberlink for help they won't take calls only internet communications and they don't return messages, i had read that there is a version 9 power dvd that might help but can get information or maybe these drives won't work on a computer?
a b D Laptop
May 25, 2010 5:42:46 AM

Have you tried updating the firmware/drivers from Dell's support site for the drive? That could potentially get it going normally again. If that is a no go, I'd recommend upgrading or trying different software to play your blu-rays on. Do you know if this is a common issue for laptops with the same blu-ray drive in it?
m
0
l
June 1, 2010 1:47:59 AM

238394,2,374193 said:
Have you tried updating the firmware/drivers from Dell's support site for the drive? That could potentially get it going normally again. If that is a no go, I'd recommend upgrading or trying different software to play your blu-rays on. Do you know if this is a common issue for laptops with the same blu-ray drive in it?[/quotems

did all the firmware and drivers as well as re installing power dvd 8.3 software dell is sending a 136 watt power adapter, if that doesn't work looks like reformatting, I would bet that won't help the issue, then dell will send me another computer probably a alienware computer. If cyberlink would ever return a email or answer there phone they should be able to tell me if 9.0 version would solve the issue, dell refuse's to send 9.0 because they are not authorized.
m
0
l
!