Solved

All System tray icons missing

I know this has been discussed many times but all my icons are gone in my system tray.
I'm using windows 7 SP1
I've tried registry fixes, restarting explorer, turning off PNP services, a system restore, etc etc. without success.
The thing is that the icons reappear very briefly while I'm logging off ... and if for any reason the logging off is delayed while windows is trying to close programs and then I cancel the logging off, the icons manage to stay. But they disappear again in the next log-on.

Any suggestions ? I'm trying to avoid a re-install ...
Thanks
5 answers Last reply Best Answer
More about system tray icons missing
  1. Really? 3 weeks since I posted and not a single answer? Someone must have a solution for this ... please
  2. Best answer
    palosanto said:
    Really? 3 weeks since I posted and not a single answer? Someone must have a solution for this ... please


    Have you used a program such as AutoRuns to go through the items starting up when Windows does in order to try to isolate the program causing them to disappear. I would recommend that. Here is a few helpful links that you can use:

    Autoruns - Created by Sysinternals originally (Microsoft now) to help users control their startup items.
    Pacs Portal - Really ingenius site that you can type the name of a process in, it will let you know if it's needed or potentially malicious
  3. Hi,

    I use ccleaner startup feature to turn on/off or remove entries.
    However, I tried Autoruns which shows hundreds of entries and I was able to see a few entries marked yellow as 'file not found'. I remove them and it actually fixed the problem. Unfortunately I cannot say for sure that this was the culprit because I was playing with a few entries in the registry prior to that ...
    However, it is fixed now after months of frustration ...
    THANKS A LOT
  4. Best answer selected by palosanto.
  5. palosanto said:
    Hi,

    I use ccleaner startup feature to turn on/off or remove entries.
    However, I tried Autoruns which shows hundreds of entries and I was able to see a few entries marked yellow as 'file not found'. I remove them and it actually fixed the problem. Unfortunately I cannot say for sure that this was the culprit because I was playing with a few entries in the registry prior to that ...
    However, it is fixed now after months of frustration ...
    THANKS A LOT


    No problem. Glad to help!
Ask a new question

Read More

Windows 7 Icons System Restore