'USB Device not recognised'

Hey guys,

Just bought a Corsair Vengeance 1500 7.1 headset.

Plugged them via a USB port thinking theyd just plug'n'play, but instead I got an error bubble pop up saying 'USB Device not recognised'.

Upon clicking this bubble I was told my hardware may have malfunctioned. Ive searched the internet looking for fixes and have so far tried these:


1 - Download the headset drivers manually from Corsair (failed, cant install the drivers as it asks me to plug the headset in, but when I do, it doesnt recognise them as plugged in)

2 - Run the Windows Hardware and Device troubleshooter. (failed, couldnt find any problems with hardware or devices, or their drivers)

3 - Unplugged the PC from the power, leave for 15 mins, try again. (failed, tried again and still not recognised)


Anyone else got any suggestions?


Cheers,
Gallarian
1 answer Last reply
More about device recognised
  1. Turns out its a faulty set of headphones.

    My brothers Identical brand new set work perfectly, but mine dont.
Ask a new question

Read More

Gaming Headsets USB Devices Audio