Sign in with
Sign up | Sign in
Your question

Windows 7 Aero not working on HD7850 Powercolor card

Last response: in Windows 7
Share
November 30, 2012 1:34:23 PM

Hi,
I have just setup a new computer and windows 7 Aero is not working.
I have installed the latest Catalyst drivers 12.10 on the card.

Windows Aero says that my card is not compatible and i need to install another card.

The motherboard is a Gigabyte z77 DH3 and it has an i5 3750 CPU.

I didnĀ“t install the drivers for the onboard GPU. Could be that the problem?

Thanks
November 30, 2012 1:39:26 PM

Have you tried the 12.11 Beta 8 drivers?
November 30, 2012 1:39:51 PM

Make sure you have the monitor plugged into the 7850, not the motherboard/onboard video ports.

While you are at it, you might as well install the Intel HD drivers for the CPU, just so that when you don't use the discrete or switch between the two (either physically or with Virtu), you'll still have accelerated graphics.
Related resources
December 10, 2012 11:21:51 PM


Well, I did nothing, just update some windows stuff and now it is working.

I am not sure what the problem was but is fixed so i am happy. :) 

One question related, is there any way to make the system switch between both Graphic Cards? Not sure why i would like to do that... but it will be good to know.

Thanks

December 11, 2012 1:00:32 PM

darkpollo said:
Well, I did nothing, just update some windows stuff and now it is working.

I am not sure what the problem was but is fixed so i am happy. :) 

One question related, is there any way to make the system switch between both Graphic Cards? Not sure why i would like to do that... but it will be good to know.

Thanks


Check to see if your motherboard supports Virtu GPU switching. You have to set a BIOS setting (most likely) then install a Windows Virtu software.

If your board is GA-Z77-D3H, you can download the Virtu MVP software here:

http://ca.gigabyte.com/products/product-page.aspx?pid=4140#utility
!