Sign in with
Sign up | Sign in
Your question

OutlookExpress-CompactingMessages

Last response: in Windows XP
Share
Anonymous
September 18, 2005 3:25:03 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

How can I turn off the automatic compacting of messages and folders in OE6.
After using OE, it seems to come on and start compacting. It sure ties up the
computer and memory. Slows everything down and I occasionally have to reboot
- the run the compacting through on its own, takes an inordinate amount of
time.

Any help will be greatly appreciated. Thanks.
Anonymous
September 18, 2005 6:34:32 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Automatic compacting of messages takes place every 100 times you close down
Outlook Express. That's inordinate? How often do you open and close the
program? You may consider adjusting your habits a bit. Most people I work
with open the program in the morning and close the program when they turn
off the computer at the end of the work day.

Anyway, there is no way to change this that I am aware of. BTW: Compacting
"speeds up" Outlook Express. If you want to speed it up even more, clean out
you folders of all the sent, deleted, received messages etc. That will get
you the largest gain in speed of opening and closing the program.

--
Regards,

Richard Urban
Microsoft MVP Windows Shell/User

Quote from: George Ankner
"If you knew as much as you thought you know,
You would realize that you don't know what you thought you knew!"

"Norm75" <Norm75@discussions.microsoft.com> wrote in message
news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
> How can I turn off the automatic compacting of messages and folders in
> OE6.
> After using OE, it seems to come on and start compacting. It sure ties up
> the
> computer and memory. Slows everything down and I occasionally have to
> reboot
> - the run the compacting through on its own, takes an inordinate amount of
> time.
>
> Any help will be greatly appreciated. Thanks.
Anonymous
September 18, 2005 6:34:33 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I must confess, Richard, that I do open and close it quite often. I will
start leaving it open all day. However, at one stage, pop up asked me whether
I wanted to compact or not "Yes" or "No". From then on, it was automatic.
I'll have to watch more closely, but it seems to come on more frequently than
once per 100 openings. Thanks for your advice.
Norm.

"Richard Urban [MVP]" wrote:

> Automatic compacting of messages takes place every 100 times you close down
> Outlook Express. That's inordinate? How often do you open and close the
> program? You may consider adjusting your habits a bit. Most people I work
> with open the program in the morning and close the program when they turn
> off the computer at the end of the work day.
>
> Anyway, there is no way to change this that I am aware of. BTW: Compacting
> "speeds up" Outlook Express. If you want to speed it up even more, clean out
> you folders of all the sent, deleted, received messages etc. That will get
> you the largest gain in speed of opening and closing the program.
>
> --
> Regards,
>
> Richard Urban
> Microsoft MVP Windows Shell/User
>
> Quote from: George Ankner
> "If you knew as much as you thought you know,
> You would realize that you don't know what you thought you knew!"
>
> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
> > How can I turn off the automatic compacting of messages and folders in
> > OE6.
> > After using OE, it seems to come on and start compacting. It sure ties up
> > the
> > computer and memory. Slows everything down and I occasionally have to
> > reboot
> > - the run the compacting through on its own, takes an inordinate amount of
> > time.
> >
> > Any help will be greatly appreciated. Thanks.
>
>
>
Anonymous
September 18, 2005 7:20:24 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

No problem. And it does take about 10 seconds to compact when there are many
messages saved in many folders.

--
Regards,

Richard Urban
Microsoft MVP Windows Shell/User

Quote from: George Ankner
"If you knew as much as you thought you know,
You would realize that you don't know what you thought you knew!"

"Norm75" <Norm75@discussions.microsoft.com> wrote in message
news:351C0CA7-3A37-449F-A847-66E36C609E8F@microsoft.com...
>I must confess, Richard, that I do open and close it quite often. I will
> start leaving it open all day. However, at one stage, pop up asked me
> whether
> I wanted to compact or not "Yes" or "No". From then on, it was automatic.
> I'll have to watch more closely, but it seems to come on more frequently
> than
> once per 100 openings. Thanks for your advice.
> Norm.
>
> "Richard Urban [MVP]" wrote:
>
>> Automatic compacting of messages takes place every 100 times you close
>> down
>> Outlook Express. That's inordinate? How often do you open and close the
>> program? You may consider adjusting your habits a bit. Most people I work
>> with open the program in the morning and close the program when they turn
>> off the computer at the end of the work day.
>>
>> Anyway, there is no way to change this that I am aware of. BTW:
>> Compacting
>> "speeds up" Outlook Express. If you want to speed it up even more, clean
>> out
>> you folders of all the sent, deleted, received messages etc. That will
>> get
>> you the largest gain in speed of opening and closing the program.
>>
>> --
>> Regards,
>>
>> Richard Urban
>> Microsoft MVP Windows Shell/User
>>
>> Quote from: George Ankner
>> "If you knew as much as you thought you know,
>> You would realize that you don't know what you thought you knew!"
>>
>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>> > How can I turn off the automatic compacting of messages and folders in
>> > OE6.
>> > After using OE, it seems to come on and start compacting. It sure ties
>> > up
>> > the
>> > computer and memory. Slows everything down and I occasionally have to
>> > reboot
>> > - the run the compacting through on its own, takes an inordinate amount
>> > of
>> > time.
>> >
>> > Any help will be greatly appreciated. Thanks.
>>
>>
>>
September 18, 2005 11:34:53 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Tools > Options> Maintenance

Cleaning up messages section

Jon


"Norm75" <Norm75@discussions.microsoft.com> wrote in message
news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
> How can I turn off the automatic compacting of messages and folders in
> OE6.
> After using OE, it seems to come on and start compacting. It sure ties up
> the
> computer and memory. Slows everything down and I occasionally have to
> reboot
> - the run the compacting through on its own, takes an inordinate amount of
> time.
>
> Any help will be greatly appreciated. Thanks.
Anonymous
September 18, 2005 11:34:54 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Best look again, as the option for automatic compacting was removed. I
believe with SP2.

--
Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP
http://mvp.support.microsoft.com/
Associate Expert - WindowsXP Expert Zone
www.microsoft.com/windowsxp/expertzone
Windows help - www.rickrogers.org

"Jon" <Email_Address@SomewhereOrOther.com> wrote in message
news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
> Tools > Options> Maintenance
>
> Cleaning up messages section
>
> Jon
>
>
> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>> How can I turn off the automatic compacting of messages and folders in
>> OE6.
>> After using OE, it seems to come on and start compacting. It sure ties up
>> the
>> computer and memory. Slows everything down and I occasionally have to
>> reboot
>> - the run the compacting through on its own, takes an inordinate amount
>> of
>> time.
>>
>> Any help will be greatly appreciated. Thanks.
>
>
September 19, 2005 12:33:03 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

You may be right, but just had a quick look in the registry, and it does
look like there are some settings relating to background compaction

eg
"Background Compaction" (DWORD 1=on, 0 = off)
at
HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
Express\5.0

and
"Compact Do not Ask Again" (DWORD 1 or 0)

HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
Express\5.0\Dont Show Dialogs

The alphanumeric combination following the "Identities" will differ on your
machine

So setting the first of those to 0 and the second of those also to 0 would
change things.

Jon



"Rick "Nutcase" Rogers" <rick@mvps.org> wrote in message
news:o aoSgbIvFHA.2540@TK2MSFTNGP09.phx.gbl...
> Best look again, as the option for automatic compacting was removed. I
> believe with SP2.
>
> --
> Best of Luck,
>
> Rick Rogers, aka "Nutcase" - Microsoft MVP
> http://mvp.support.microsoft.com/
> Associate Expert - WindowsXP Expert Zone
> www.microsoft.com/windowsxp/expertzone
> Windows help - www.rickrogers.org
>
> "Jon" <Email_Address@SomewhereOrOther.com> wrote in message
> news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
>> Tools > Options> Maintenance
>>
>> Cleaning up messages section
>>
>> Jon
>>
>>
>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>> How can I turn off the automatic compacting of messages and folders in
>>> OE6.
>>> After using OE, it seems to come on and start compacting. It sure ties
>>> up the
>>> computer and memory. Slows everything down and I occasionally have to
>>> reboot
>>> - the run the compacting through on its own, takes an inordinate amount
>>> of
>>> time.
>>>
>>> Any help will be greatly appreciated. Thanks.
>>
>>
>
>
Anonymous
September 19, 2005 12:33:04 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Do *not* mess with those Registry keys/values.
--
~PA Bear

Jon wrote:
> You may be right, but just had a quick look in the registry, and it does
> look like there are some settings relating to background compaction
>
> eg
> "Background Compaction" (DWORD 1=on, 0 = off)
> at
> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
> Express\5.0
>
> and
> "Compact Do not Ask Again" (DWORD 1 or 0)
>
> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
> Express\5.0\Dont Show Dialogs
>
> The alphanumeric combination following the "Identities" will differ on
> your
> machine
>
> So setting the first of those to 0 and the second of those also to 0 would
> change things.
>
> Jon
>
>
>
> "Rick "Nutcase" Rogers" <rick@mvps.org> wrote in message
> news:o aoSgbIvFHA.2540@TK2MSFTNGP09.phx.gbl...
>> Best look again, as the option for automatic compacting was removed. I
>> believe with SP2.
>>
>> --
>> Best of Luck,
>>
>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>> http://mvp.support.microsoft.com/
>> Associate Expert - WindowsXP Expert Zone
>> www.microsoft.com/windowsxp/expertzone
>> Windows help - www.rickrogers.org
>>
>> "Jon" <Email_Address@SomewhereOrOther.com> wrote in message
>> news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
>>> Tools > Options> Maintenance
>>>
>>> Cleaning up messages section
>>>
>>> Jon
>>>
>>>
>>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>>> How can I turn off the automatic compacting of messages and folders in
>>>> OE6.
>>>> After using OE, it seems to come on and start compacting. It sure ties
>>>> up the
>>>> computer and memory. Slows everything down and I occasionally have to
>>>> reboot
>>>> - the run the compacting through on its own, takes an inordinate amount
>>>> of
>>>> time.
>>>>
>>>> Any help will be greatly appreciated. Thanks.
Anonymous
September 19, 2005 12:51:08 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Richard

I am not certain about what is to follow. If you run File, Folder, Compact All at a time that suits you it resets to 100 so you do not get the system kicking in at an inconvenient moment.

--


Hope this helps.

Gerry
~~~~~~~~~~~~~~~~~~~~~~~~
FCA

Using invalid email address

Stourport, Worcs, England
Enquire, plan and execute.
~~~~~~~~~~~~~~~~~~~~~~~~
Please tell the newsgroup how any
suggested solution worked for you.

http://dts-l.org/goodpost.htm

~~~~~~~~~~~~~~~~~~~~~~~~


"Richard Urban [MVP]" <richardurbanREMOVETHIS@hotmail.com> wrote in message news:uix0FYIvFHA.1328@TK2MSFTNGP10.phx.gbl...
> No problem. And it does take about 10 seconds to compact when there are many
> messages saved in many folders.
>
> --
> Regards,
>
> Richard Urban
> Microsoft MVP Windows Shell/User
>
> Quote from: George Ankner
> "If you knew as much as you thought you know,
> You would realize that you don't know what you thought you knew!"
>
> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
> news:351C0CA7-3A37-449F-A847-66E36C609E8F@microsoft.com...
>>I must confess, Richard, that I do open and close it quite often. I will
>> start leaving it open all day. However, at one stage, pop up asked me
>> whether
>> I wanted to compact or not "Yes" or "No". From then on, it was automatic.
>> I'll have to watch more closely, but it seems to come on more frequently
>> than
>> once per 100 openings. Thanks for your advice.
>> Norm.
>>
>> "Richard Urban [MVP]" wrote:
>>
>>> Automatic compacting of messages takes place every 100 times you close
>>> down
>>> Outlook Express. That's inordinate? How often do you open and close the
>>> program? You may consider adjusting your habits a bit. Most people I work
>>> with open the program in the morning and close the program when they turn
>>> off the computer at the end of the work day.
>>>
>>> Anyway, there is no way to change this that I am aware of. BTW:
>>> Compacting
>>> "speeds up" Outlook Express. If you want to speed it up even more, clean
>>> out
>>> you folders of all the sent, deleted, received messages etc. That will
>>> get
>>> you the largest gain in speed of opening and closing the program.
>>>
>>> --
>>> Regards,
>>>
>>> Richard Urban
>>> Microsoft MVP Windows Shell/User
>>>
>>> Quote from: George Ankner
>>> "If you knew as much as you thought you know,
>>> You would realize that you don't know what you thought you knew!"
>>>
>>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>> > How can I turn off the automatic compacting of messages and folders in
>>> > OE6.
>>> > After using OE, it seems to come on and start compacting. It sure ties
>>> > up
>>> > the
>>> > computer and memory. Slows everything down and I occasionally have to
>>> > reboot
>>> > - the run the compacting through on its own, takes an inordinate amount
>>> > of
>>> > time.
>>> >
>>> > Any help will be greatly appreciated. Thanks.
>>>
>>>
>>>
>
>
Anonymous
September 19, 2005 12:51:09 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Manual compacting does not reset the Compact Count.

Automatic Compacting in WinXP SP2 cannot be disabled.

- If you choose "Don't ask me again" when presented with the Automatic
Compacting prompt, it /will/ run automatically without the prompt the next
time.

- Do *not* attempt to close OE via Task Manager or shutdown while
Automatic Compacting is taking place or you risk loss of your (entire)
message store.

MS MVP Steve Cochran's OE Tool has a 'compact all folders' button: When
used, it resets the Compact Count.
http://www.oehelp.com/OETool/Default.aspx

OE - Reset Compact Check Count to 0 (Line 367, Left)
http://www.kellys-korner-xp.com/xp_tweaks.htm
--
OE6-specific newsgroup:
news://msnews.microsoft.com/microsoft.public.windows.inetexplorer.ie6_outlookexpress
OE General newsgroup:
news://msnews.microsoft.com/microsoft.public.outlookexpress.general

~Robear Dyer (PA Bear)
MS MVP-Windows (IE/OE) & Security, AH-VSOP

Gerry Cornell wrote:
> I am not certain about what is to follow. If you run File, Folder, Compact
> All at a time that suits you it resets to 100 so you do not get the system
> kicking in at an inconvenient moment.
Anonymous
September 19, 2005 12:53:34 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Jon

Was there but not in latest version of Outlook Express.

--


Regards.

Gerry

~~~~~~~~~~~~~~~~~~~~~~~~
FCA

Stourport, Worcs, England
Enquire, plan and execute.
~~~~~~~~~~~~~~~~~~~~~~~~


"Jon" <Email_Address@SomewhereOrOther.com> wrote in message news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
> Tools > Options> Maintenance
>
> Cleaning up messages section
>
> Jon
>
>
> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>> How can I turn off the automatic compacting of messages and folders in
>> OE6.
>> After using OE, it seems to come on and start compacting. It sure ties up
>> the
>> computer and memory. Slows everything down and I occasionally have to
>> reboot
>> - the run the compacting through on its own, takes an inordinate amount of
>> time.
>>
>> Any help will be greatly appreciated. Thanks.
>
>
September 19, 2005 1:52:15 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Yes, looks like you are correct. Also, it looks like the previous registry
changes, I posted to Rick, don't affect the "compact after 100 uses of
Outlook Express" rule, either.

However, there's another key

"Compact Check Count"

at

HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
Express\5.0

(alphanumeric combination after "Identities" will again vary)

that seems to be the counter that counts up to the significant 100th time,
that triggers the compacting

So a periodic resetting of that key to say 1, either manually or
programmatically, would be another way of delaying / stopping the
compacting, in addition to the method Richard posted.


Jon



"Gerry Cornell" <gcjc@tenretnitb.com> wrote in message
news:o EpZpqIvFHA.252@TK2MSFTNGP09.phx.gbl...
Jon

Was there but not in latest version of Outlook Express.

--


Regards.

Gerry

~~~~~~~~~~~~~~~~~~~~~~~~
FCA

Stourport, Worcs, England
Enquire, plan and execute.
~~~~~~~~~~~~~~~~~~~~~~~~


"Jon" <Email_Address@SomewhereOrOther.com> wrote in message
news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
> Tools > Options> Maintenance
>
> Cleaning up messages section
>
> Jon
>
>
> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>> How can I turn off the automatic compacting of messages and folders in
>> OE6.
>> After using OE, it seems to come on and start compacting. It sure ties up
>> the
>> computer and memory. Slows everything down and I occasionally have to
>> reboot
>> - the run the compacting through on its own, takes an inordinate amount
>> of
>> time.
>>
>> Any help will be greatly appreciated. Thanks.
>
>
September 19, 2005 1:57:59 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

oops .. that should have read "the method that you yourself posted"

Jon


"Jon" <Email_Address@SomewhereOrOther.com> wrote in message
news:%23BY8ZLJvFHA.3932@TK2MSFTNGP15.phx.gbl...
> Yes, looks like you are correct. Also, it looks like the previous registry
> changes, I posted to Rick, don't affect the "compact after 100 uses of
> Outlook Express" rule, either.
>
> However, there's another key
>
> "Compact Check Count"
>
> at
>
> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
> Express\5.0
>
> (alphanumeric combination after "Identities" will again vary)
>
> that seems to be the counter that counts up to the significant 100th time,
> that triggers the compacting
>
> So a periodic resetting of that key to say 1, either manually or
> programmatically, would be another way of delaying / stopping the
> compacting, in addition to the method Richard posted.
>
>
> Jon
>
>
>
> "Gerry Cornell" <gcjc@tenretnitb.com> wrote in message
> news:o EpZpqIvFHA.252@TK2MSFTNGP09.phx.gbl...
> Jon
>
> Was there but not in latest version of Outlook Express.
>
> --
>
>
> Regards.
>
> Gerry
>
> ~~~~~~~~~~~~~~~~~~~~~~~~
> FCA
>
> Stourport, Worcs, England
> Enquire, plan and execute.
> ~~~~~~~~~~~~~~~~~~~~~~~~
>
>
> "Jon" <Email_Address@SomewhereOrOther.com> wrote in message
> news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
>> Tools > Options> Maintenance
>>
>> Cleaning up messages section
>>
>> Jon
>>
>>
>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>> How can I turn off the automatic compacting of messages and folders in
>>> OE6.
>>> After using OE, it seems to come on and start compacting. It sure ties
>>> up
>>> the
>>> computer and memory. Slows everything down and I occasionally have to
>>> reboot
>>> - the run the compacting through on its own, takes an inordinate amount
>>> of
>>> time.
>>>
>>> Any help will be greatly appreciated. Thanks.
>>
>>
>
>
September 19, 2005 2:16:55 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I'll do what I like with my registry, thanks

Jon


"PA Bear" <PABearMVP@gmail.com> wrote in message
news:u13cnPJvFHA.3792@TK2MSFTNGP10.phx.gbl...
> Do *not* mess with those Registry keys/values.
> --
> ~PA Bear
>
> Jon wrote:
>> You may be right, but just had a quick look in the registry, and it does
>> look like there are some settings relating to background compaction
>>
>> eg
>> "Background Compaction" (DWORD 1=on, 0 = off)
>> at
>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>> Express\5.0
>>
>> and
>> "Compact Do not Ask Again" (DWORD 1 or 0)
>>
>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>> Express\5.0\Dont Show Dialogs
>>
>> The alphanumeric combination following the "Identities" will differ on
>> your
>> machine
>>
>> So setting the first of those to 0 and the second of those also to 0
>> would
>> change things.
>>
>> Jon
>>
>>
>>
>> "Rick "Nutcase" Rogers" <rick@mvps.org> wrote in message
>> news:o aoSgbIvFHA.2540@TK2MSFTNGP09.phx.gbl...
>>> Best look again, as the option for automatic compacting was removed. I
>>> believe with SP2.
>>>
>>> --
>>> Best of Luck,
>>>
>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>>> http://mvp.support.microsoft.com/
>>> Associate Expert - WindowsXP Expert Zone
>>> www.microsoft.com/windowsxp/expertzone
>>> Windows help - www.rickrogers.org
>>>
>>> "Jon" <Email_Address@SomewhereOrOther.com> wrote in message
>>> news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
>>>> Tools > Options> Maintenance
>>>>
>>>> Cleaning up messages section
>>>>
>>>> Jon
>>>>
>>>>
>>>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>>>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>>>> How can I turn off the automatic compacting of messages and folders in
>>>>> OE6.
>>>>> After using OE, it seems to come on and start compacting. It sure ties
>>>>> up the
>>>>> computer and memory. Slows everything down and I occasionally have to
>>>>> reboot
>>>>> - the run the compacting through on its own, takes an inordinate
>>>>> amount
>>>>> of
>>>>> time.
>>>>>
>>>>> Any help will be greatly appreciated. Thanks.
>
Anonymous
September 19, 2005 4:47:42 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

OK, go for it. When you loose your message store, see
http://www.microsoft.com/windows/IE/community/columns/f...
and http://www.oehelp.com/OETips.aspx#4. (I'd bookmark those two pages
IIWY.)
--
~PA Bear

Jon wrote:
> I'll do what I like with my registry, thanks
>
> Jon
>
>
> "PA Bear" <PABearMVP@gmail.com> wrote in message
> news:u13cnPJvFHA.3792@TK2MSFTNGP10.phx.gbl...
>> Do *not* mess with those Registry keys/values.
>> --
>> ~PA Bear
>>
>> Jon wrote:
>>> You may be right, but just had a quick look in the registry, and it does
>>> look like there are some settings relating to background compaction
>>>
>>> eg
>>> "Background Compaction" (DWORD 1=on, 0 = off)
>>> at
>>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>>> Express\5.0
>>>
>>> and
>>> "Compact Do not Ask Again" (DWORD 1 or 0)
>>>
>>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>>> Express\5.0\Dont Show Dialogs
>>>
>>> The alphanumeric combination following the "Identities" will differ on
>>> your
>>> machine
>>>
>>> So setting the first of those to 0 and the second of those also to 0
>>> would
>>> change things.
>>>
>>> Jon
>>>
>>>
>>>
>>> "Rick "Nutcase" Rogers" <rick@mvps.org> wrote in message
>>> news:o aoSgbIvFHA.2540@TK2MSFTNGP09.phx.gbl...
>>>> Best look again, as the option for automatic compacting was removed. I
>>>> believe with SP2.
>>>>
>>>> --
>>>> Best of Luck,
>>>>
>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>>>> http://mvp.support.microsoft.com/
>>>> Associate Expert - WindowsXP Expert Zone
>>>> www.microsoft.com/windowsxp/expertzone
>>>> Windows help - www.rickrogers.org
>>>>
>>>> "Jon" <Email_Address@SomewhereOrOther.com> wrote in message
>>>> news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
>>>>> Tools > Options> Maintenance
>>>>>
>>>>> Cleaning up messages section
>>>>>
>>>>> Jon
>>>>>
>>>>>
>>>>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>>>>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>>>>> How can I turn off the automatic compacting of messages and folders
>>>>>> in
>>>>>> OE6.
>>>>>> After using OE, it seems to come on and start compacting. It sure
>>>>>> ties
>>>>>> up the
>>>>>> computer and memory. Slows everything down and I occasionally have to
>>>>>> reboot
>>>>>> - the run the compacting through on its own, takes an inordinate
>>>>>> amount
>>>>>> of
>>>>>> time.
>>>>>>
>>>>>> Any help will be greatly appreciated. Thanks.
Anonymous
September 19, 2005 5:30:02 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I received a message to compact emails. After compacting I cannot view the
old emails in Inbox.

Please help on how I can view the old emails. Thanks.

"Norm75" wrote:

> How can I turn off the automatic compacting of messages and folders in OE6.
> After using OE, it seems to come on and start compacting. It sure ties up the
> computer and memory. Slows everything down and I occasionally have to reboot
> - the run the compacting through on its own, takes an inordinate amount of
> time.
>
> Any help will be greatly appreciated. Thanks.
September 19, 2005 12:28:11 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

The first of those registry keys is ignored in SP2, and the second merely
turns a prompt on and off, so changing those 2 particular keys, to the
values I suggested, would not affect the message store at all.


If you'd read, and properly understood, the web pages you posted, then you
would also have read the following sections.

http://www.microsoft.com/windows/IE/community/columns/f...

http://www.oehelp.com/OETips.aspx#2

Both of which show that it is the compacting process itself, or rather its
untimely interruption, which is a major cause of message store corruption.
So disabling it completely, via the registry, (eg using the method I
outlined in another post in this conversation), is hardly likely to be a
cause of message store corruption.

So you can keep your technophobic, "don't touch the sacred registry"
approach to things.


Jon


"PA Bear" <PABearMVP@gmail.com> wrote in message
news:e$vgTVNvFHA.2132@TK2MSFTNGP15.phx.gbl...
> OK, go for it. When you loose your message store, see
> http://www.microsoft.com/windows/IE/community/columns/f...
> and http://www.oehelp.com/OETips.aspx#4. (I'd bookmark those two pages
> IIWY.)
> --
> ~PA Bear
>
> Jon wrote:
>> I'll do what I like with my registry, thanks
>>
>> Jon
>>
>>
>> "PA Bear" <PABearMVP@gmail.com> wrote in message
>> news:u13cnPJvFHA.3792@TK2MSFTNGP10.phx.gbl...
>>> Do *not* mess with those Registry keys/values.
>>> --
>>> ~PA Bear
>>>
>>> Jon wrote:
>>>> You may be right, but just had a quick look in the registry, and it
>>>> does
>>>> look like there are some settings relating to background compaction
>>>>
>>>> eg
>>>> "Background Compaction" (DWORD 1=on, 0 = off)
>>>> at
>>>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>>>> Express\5.0
>>>>
>>>> and
>>>> "Compact Do not Ask Again" (DWORD 1 or 0)
>>>>
>>>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>>>> Express\5.0\Dont Show Dialogs
>>>>
>>>> The alphanumeric combination following the "Identities" will differ on
>>>> your
>>>> machine
>>>>
>>>> So setting the first of those to 0 and the second of those also to 0
>>>> would
>>>> change things.
>>>>
>>>> Jon
>>>>
>>>>
>>>>
>>>> "Rick "Nutcase" Rogers" <rick@mvps.org> wrote in message
>>>> news:o aoSgbIvFHA.2540@TK2MSFTNGP09.phx.gbl...
>>>>> Best look again, as the option for automatic compacting was removed. I
>>>>> believe with SP2.
>>>>>
>>>>> --
>>>>> Best of Luck,
>>>>>
>>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>>>>> http://mvp.support.microsoft.com/
>>>>> Associate Expert - WindowsXP Expert Zone
>>>>> www.microsoft.com/windowsxp/expertzone
>>>>> Windows help - www.rickrogers.org
>>>>>
>>>>> "Jon" <Email_Address@SomewhereOrOther.com> wrote in message
>>>>> news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
>>>>>> Tools > Options> Maintenance
>>>>>>
>>>>>> Cleaning up messages section
>>>>>>
>>>>>> Jon
>>>>>>
>>>>>>
>>>>>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>>>>>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>>>>>> How can I turn off the automatic compacting of messages and folders
>>>>>>> in
>>>>>>> OE6.
>>>>>>> After using OE, it seems to come on and start compacting. It sure
>>>>>>> ties
>>>>>>> up the
>>>>>>> computer and memory. Slows everything down and I occasionally have
>>>>>>> to
>>>>>>> reboot
>>>>>>> - the run the compacting through on its own, takes an inordinate
>>>>>>> amount
>>>>>>> of
>>>>>>> time.
>>>>>>>
>>>>>>> Any help will be greatly appreciated. Thanks.
>
Anonymous
September 19, 2005 12:28:12 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Compact Do not Ask Again is not in my Registry.
That key must be before SP 2.
Background Compaction is in two unused Identities, but not in the Identity
that I use.
Not compacting will eventually get the message store in trouble.
--
Ron Sommer


"Jon" <Email_Address@SomewhereOrOther.com> wrote in message
news:eO2mwuOvFHA.1132@TK2MSFTNGP10.phx.gbl...
> The first of those registry keys is ignored in SP2, and the second merely
> turns a prompt on and off, so changing those 2 particular keys, to the
> values I suggested, would not affect the message store at all.
>
>
> If you'd read, and properly understood, the web pages you posted, then you
> would also have read the following sections.
>
> http://www.microsoft.com/windows/IE/community/columns/f...
>
> http://www.oehelp.com/OETips.aspx#2
>
> Both of which show that it is the compacting process itself, or rather its
> untimely interruption, which is a major cause of message store corruption.
> So disabling it completely, via the registry, (eg using the method I
> outlined in another post in this conversation), is hardly likely to be a
> cause of message store corruption.
>
> So you can keep your technophobic, "don't touch the sacred registry"
> approach to things.
>
>
> Jon
>
>
> "PA Bear" <PABearMVP@gmail.com> wrote in message
> news:e$vgTVNvFHA.2132@TK2MSFTNGP15.phx.gbl...
>> OK, go for it. When you loose your message store, see
>> http://www.microsoft.com/windows/IE/community/columns/f...
>> and http://www.oehelp.com/OETips.aspx#4. (I'd bookmark those two pages
>> IIWY.)
>> --
>> ~PA Bear
>>
>> Jon wrote:
>>> I'll do what I like with my registry, thanks
>>>
>>> Jon
>>>
>>>
>>> "PA Bear" <PABearMVP@gmail.com> wrote in message
>>> news:u13cnPJvFHA.3792@TK2MSFTNGP10.phx.gbl...
>>>> Do *not* mess with those Registry keys/values.
>>>> --
>>>> ~PA Bear
>>>>
>>>> Jon wrote:
>>>>> You may be right, but just had a quick look in the registry, and it
>>>>> does
>>>>> look like there are some settings relating to background compaction
>>>>>
>>>>> eg
>>>>> "Background Compaction" (DWORD 1=on, 0 = off)
>>>>> at
>>>>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>>>>> Express\5.0
>>>>>
>>>>> and
>>>>> "Compact Do not Ask Again" (DWORD 1 or 0)
>>>>>
>>>>> HKEY_CURRENT_USER\Identities\{3750B9E7-DB22-485C-8640-3FE520544084}\Software\Microsoft\Outlook
>>>>> Express\5.0\Dont Show Dialogs
>>>>>
>>>>> The alphanumeric combination following the "Identities" will differ on
>>>>> your
>>>>> machine
>>>>>
>>>>> So setting the first of those to 0 and the second of those also to 0
>>>>> would
>>>>> change things.
>>>>>
>>>>> Jon
>>>>>
>>>>>
>>>>>
>>>>> "Rick "Nutcase" Rogers" <rick@mvps.org> wrote in message
>>>>> news:o aoSgbIvFHA.2540@TK2MSFTNGP09.phx.gbl...
>>>>>> Best look again, as the option for automatic compacting was removed.
>>>>>> I
>>>>>> believe with SP2.
>>>>>>
>>>>>> --
>>>>>> Best of Luck,
>>>>>>
>>>>>> Rick Rogers, aka "Nutcase" - Microsoft MVP
>>>>>> http://mvp.support.microsoft.com/
>>>>>> Associate Expert - WindowsXP Expert Zone
>>>>>> www.microsoft.com/windowsxp/expertzone
>>>>>> Windows help - www.rickrogers.org
>>>>>>
>>>>>> "Jon" <Email_Address@SomewhereOrOther.com> wrote in message
>>>>>> news:uTaQp%23HvFHA.3896@TK2MSFTNGP15.phx.gbl...
>>>>>>> Tools > Options> Maintenance
>>>>>>>
>>>>>>> Cleaning up messages section
>>>>>>>
>>>>>>> Jon
>>>>>>>
>>>>>>>
>>>>>>> "Norm75" <Norm75@discussions.microsoft.com> wrote in message
>>>>>>> news:F41CF632-C2D0-4DC6-AE90-6F8D4A78F717@microsoft.com...
>>>>>>>> How can I turn off the automatic compacting of messages and folders
>>>>>>>> in
>>>>>>>> OE6.
>>>>>>>> After using OE, it seems to come on and start compacting. It sure
>>>>>>>> ties
>>>>>>>> up the
>>>>>>>> computer and memory. Slows everything down and I occasionally have
>>>>>>>> to
>>>>>>>> reboot
>>>>>>>> - the run the compacting through on its own, takes an inordinate
>>>>>>>> amount
>>>>>>>> of
>>>>>>>> time.
>>>>>>>>
>>>>>>>> Any help will be greatly appreciated. Thanks.
>>
>
>
Anonymous
September 19, 2005 5:14:34 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Sorry Bear there seems to be some conflict between your assertion and my
experience.


Regards.

Gerry

~~~~~~~~~~~~~~~~~~~~~~~~
FCA

Stourport, Worcs, England
Enquire, plan and execute.
~~~~~~~~~~~~~~~~~~~~~~~~

"PA Bear" <PABearMVP@gmail.com> wrote in message news:%234APzNJvFHA.252@TK2MSFTNGP09.phx.gbl...
> Manual compacting does not reset the Compact Count.
>
> Automatic Compacting in WinXP SP2 cannot be disabled.
>
> - If you choose "Don't ask me again" when presented with the Automatic
> Compacting prompt, it /will/ run automatically without the prompt the next
> time.
>
> - Do *not* attempt to close OE via Task Manager or shutdown while
> Automatic Compacting is taking place or you risk loss of your (entire)
> message store.
>
> MS MVP Steve Cochran's OE Tool has a 'compact all folders' button: When
> used, it resets the Compact Count.
> http://www.oehelp.com/OETool/Default.aspx
>
> OE - Reset Compact Check Count to 0 (Line 367, Left)
> http://www.kellys-korner-xp.com/xp_tweaks.htm
> --
> OE6-specific newsgroup:
> news://msnews.microsoft.com/microsoft.public.windows.inetexplorer.ie6_outlookexpress
> OE General newsgroup:
> news://msnews.microsoft.com/microsoft.public.outlookexpress.general
>
> ~Robear Dyer (PA Bear)
> MS MVP-Windows (IE/OE) & Security, AH-VSOP
>
> Gerry Cornell wrote:
>> I am not certain about what is to follow. If you run File, Folder, Compact
>> All at a time that suits you it resets to 100 so you do not get the system
>> kicking in at an inconvenient moment.
>
Anonymous
September 19, 2005 5:19:22 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

You may be able to recover your "lost" messages using an inexpensive
third party programme. Details of DBXtract in link cost $5 may help with
lost messages if the corrupted inbox is still on your computer.

http://www.tomsterdam.com/insideoe/problems/bugs.htm#ma...


However, check first that the corrupted inbox is there. Using Windows XP
you need to enable show hidden files. Start, Control Panel,
Folder Options, View, Advanced Settings. Next enter Windows Explorer.
Using Tools, Find, Files and Folders search your C drive with
"inbo*.dbx" without quotes as the search criteria and see if you can
find more than one folder. Note the date / time stamp on the files and
the older folder will contain your missing messages. The original inbox
will appear as inbox. dbx. The next as inbox (01) dbx, then inbox (02)
dbx etc. The file extension can also appear as .dbt i.e. a temporary
folder.


~~~~~~


Hope this helps.

Gerry
~~~~~~~~~~~~~~~~~~~~~~~~
FCA

Stourport, Worcs, England
Enquire, plan and execute.
~~~~~~~~~~~~~~~~~~~~~~~~
Please tell the newsgroup how any
suggested solution worked for you.

http://dts-l.org/goodpost.htm

~~~~~~~~~~~~~~~~~~~~~~~~

"Vikas" <Vikas@discussions.microsoft.com> wrote in message news:21B142E3-64FC-483D-B9E3-AEBEB7CD8ECF@microsoft.com...
>I received a message to compact emails. After compacting I cannot view the
> old emails in Inbox.
>
> Please help on how I can view the old emails. Thanks.
>
> "Norm75" wrote:
>
>> How can I turn off the automatic compacting of messages and folders in OE6.
>> After using OE, it seems to come on and start compacting. It sure ties up the
>> computer and memory. Slows everything down and I occasionally have to reboot
>> - the run the compacting through on its own, takes an inordinate amount of
>> time.
>>
>> Any help will be greatly appreciated. Thanks.
September 19, 2005 8:34:46 PM

Archived from groups: microsoft.public.windowsxp.general (More info?)

"Ron Sommer" <rsommer@nospam.ktis.net> wrote in message
news:o EkQj6QvFHA.2072@TK2MSFTNGP14.phx.gbl...
> Compact Do not Ask Again is not in my Registry.
> That key must be before SP 2.

Possibly because you've not yet opened and closed Outlook Express 100 times,
using that particular identity (?)
The key is created (in the "Dont Show Dialogs" subkey of the "5.0" key) when
you check the "Don't show this dialog again" checkbox, in response to the
compacting dialog box, after the 100th closure of Outlook Express.

You may be able to cause its creation, by changing the "Compact Check Count"
key to 99 (click on "Decimal" radio button first), and then opening and
closing Outlook Express one or two times. [or if you prefer, just open and
close Outlook Express the required number of times, without changing the
registry]



> Background Compaction is in two unused Identities, but not in the Identity
> that I use.

Yeah, that is odd

> Not compacting will eventually get the message store in trouble.

Yeah sure, the option to compact manually, at the time of your choosing,
remains

Jon
Anonymous
September 20, 2005 2:39:26 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

Are you compacting use the button on OE Tool bar?

Gerry Cornell wrote:
> Sorry Bear there seems to be some conflict between your assertion and my
> experience.
>
> "PA Bear" <PABearMVP@gmail.com> wrote in message
> news:%234APzNJvFHA.252@TK2MSFTNGP09.phx.gbl...
>> Manual compacting does not reset the Compact Count.
>>
>> Automatic Compacting in WinXP SP2 cannot be disabled.
>>
>> - If you choose "Don't ask me again" when presented with the Automatic
>> Compacting prompt, it /will/ run automatically without the prompt the
>> next
>> time.
>>
>> - Do *not* attempt to close OE via Task Manager or shutdown while
>> Automatic Compacting is taking place or you risk loss of your (entire)
>> message store.
>>
>> MS MVP Steve Cochran's OE Tool has a 'compact all folders' button: When
>> used, it resets the Compact Count.
>> http://www.oehelp.com/OETool/Default.aspx
>>
>> OE - Reset Compact Check Count to 0 (Line 367, Left)
>> http://www.kellys-korner-xp.com/xp_tweaks.htm
>> --
>> OE6-specific newsgroup:
>> news://msnews.microsoft.com/microsoft.public.windows.inetexplorer.ie6_outlookexpress
>> OE General newsgroup:
>> news://msnews.microsoft.com/microsoft.public.outlookexpress.general
>>
>> ~Robear Dyer (PA Bear)
>> MS MVP-Windows (IE/OE) & Security, AH-VSOP
>>
>> Gerry Cornell wrote:
>>> I am not certain about what is to follow. If you run File, Folder,
>>> Compact
>>> All at a time that suits you it resets to 100 so you do not get the
>>> system
>>> kicking in at an inconvenient moment.
Anonymous
September 20, 2005 2:43:15 AM

Archived from groups: microsoft.public.windowsxp.general (More info?)

I've read and am fully familiar with my colleague's article, Jon. Automatic
Compacting in WinXP SP2 and Win2K03 cannot be disabled. Messing with OE or
the Registry to try to disable it, or attempting to close OE via Task
Manager or shutting down while Automatic Compacting is occurring can lead to
corruption in the store and loss of messages.
--
OE6-specific newsgroup:
news://msnews.microsoft.com/microsoft.public.windows.inetexplorer.ie6_outlookexpress
OE General newsgroup:
news://msnews.microsoft.com/microsoft.public.outlookexpress.general

~Robear Dyer (PA Bear)
MS MVP-Windows (IE/OE, Security, Shell/User)

Inside Outlook Express
http://www.insideoe.com

Jon wrote:
<snip>
> If you'd read, and properly understood, the web pages you posted, then you
> would also have read the following sections.
>
> http://www.microsoft.com/windows/IE/community/columns/f...
>
> http://www.oehelp.com/OETips.aspx#2
>
> Both of which show that it is the compacting process itself, or rather its
> untimely interruption, which is a major cause of message store corruption.
> So disabling it completely, via the registry, (eg using the method I
> outlined in another post in this conversation), is hardly likely to be a
> cause of message store corruption.
!