Sign in with
Sign up | Sign in
Your question

Razer Megalodon headset not playing sound

Last response: in Home Audio
Share
September 14, 2012 11:30:39 PM

Hi there, I've had my megalodon headset for a while now, but have recently brought a new computer. The headset was working fine on my old system but isn't working on my new one. When I plugged the device in it was detected fine, and it says that the headset is my default playback device, yet no sound plays through google chrome or iTunes.

Interesting point: Attempting to play a song through iTunes results in the song staying at 0.00seconds, sound plays through the speakers when I unplug the headset. I have the headset plugged into a 3.0 front USB port. Thanks Paul
September 14, 2012 11:32:54 PM

Try plugging it in into a usb 2.0 port. Made a difference with some of my devices.
September 14, 2012 11:38:36 PM

Hi, thank you for the quick response, ok it IS working on a back panel 2.0 port, however it's kind of inconvenient having it plugged in there. Is there a way to get it working in the 3.0 ports? Thanks
Related resources
July 31, 2013 1:15:39 AM

its not an Acer PC by any chance? I had the same problem with an Acer M3970 (I have upgraded some components but CPU/MB/Ram is still original). headset is faulty in the rear ports. if i plug it into the front port of the PC case, It works fine. I suspect the front USB hub is a separate controller to what operates the rear ports.

I was having the same problems with iTunes playing no sound and remaining at 0:00 and Windows Media player had a massive attack of uselessness, I thought I'd managed to destroy my MP3 collection. Games wouldn't even recognise that there was an audio device attached to the computer (after i disabled on board audio in the troubleshooting process). Microphone on the headset still worked though because i could see a volume level appearing in the mixer.

I am waiting to hear more from Razer in regards to their thoughts.
January 12, 2014 6:40:51 PM

If you're still having troubles I found the Megalodon had terrible power drain. When I had a Xbox controller plugged in at the same time as the Headset the headset didn't work. I had to get an external powered USB hub to make both work.

USB3.0 might carry more power and therefore the Megalodon draws more?
!