Sign in with
Sign up | Sign in
Your question

Acer aspire 8940g how to recover bios

Last response: in Laptops & Notebooks
Share
June 19, 2010 7:21:45 PM

my Aspire 8940G blue-screened while updating the BIOS in Windows 7. Now it won't boot or display POST anymore.
I've tried to "reconstruct" a "crisis disk" by using the only crisis disk I've found on the Net -- at http://www.wimsbios.com/forum/topic10069.html -- and replacing the BIOS.WPH by the file found on the Acer download site for the 8940G (the only .WPH is in the Zip for an older BIOS release: ZY9_3110.WPH). I've renamed that file to BIOS.WPH.
Then tried to follow the procedure at the URL above as for the 5050, but it doesn't seem to work.
After switching on with FN+Esc pressed & the USB stick inserted, the Power light blinks, and so does the "CAPS" light, and the USB's access light is lit, but nothing seems to happen, after half an hour he's still doing that.
Of course, I'm not even sure this procedure works with an USB stick (on the older laptops it was only with an USB floppy drive).

Can anybody help ?
I've already had to replay this laptop after water damage (yeah, cost me about 80% of the new unit price) after barely a month, so I'm not too fond about sending it back to Acer...
a b D Laptop
June 21, 2010 7:49:09 PM

It can be tough to get a laptop (or any computer for that matter) going after a failed BIOS update. At this point, I would recommend just calling Acer and seeing if they have any ideas. If not, you may have to send it in, but it should be covered under the one year warranty, so it should be free.
!