Sign in with
Sign up | Sign in
Your question

Toshiba Satellite M300 ran out of power - now it won't even respond

Last response: in Laptops & Notebooks
Share
June 20, 2010 4:45:05 AM

I was using this laptop in class, and for once I was unable to get near a power plug. So I used it on battery, intending to let it run itself down until I had about 5 minutes of power left before shutting down completely. Well, at 10 minutes of power left, the machine suddenly began to shut down spontaneously. It went into (what appeared to be) suspend mode, and saved its data to the hard drive.

Problem is, it won't turn on again. Nothing. Nada. No power light (under the power button), no lights anywhere else (except for the battery indicator -- see below), and definitely no fans or booting sounds.

I have tried powering on without the battery, I have tried the “pull everything and press power button for 30 seconds” trick, and nothing seems to be working. The only response I get at all is if I try to power up with the battery in and the power connected. Then, and only then, will the battery indicator (the one which looks like a AAA-battery, on the leading edge down by the trackpad) flash quickly 4 times. If I press and hold, it will flash 4 times quickly, wait for about 2-3 seconds, and then flash slowly until I let go of the power button. Under all conditions it is an orange colour.

Leaving it for several hours with the battery out does nothing. Plugging the power in while the battery attached does NOTHING, no charging lights come on at all. There is nothing to indicate that power has been attached, unlike previously when I have ALWAYS had the battery light come on to show that power was attached and/or it was charging, even with the unit totally off. As well, I have NEVER had a charge issue with this unit. It has always been able to charge itself, and I have never had an issue with power when using the power cord.

FYI, I am using Linux Mint, probably Helena but maybe Isadora (not sure now that I can't boot up!). I have a Toshiba Satellite M300, with the exact model number being PSMDCC-03C00Q (yes, it is a Futureshop special!)

So I am curious: is this a sleep/suspend/hibernate issue? If so, how do I get around it?
June 25, 2010 5:11:01 AM

Well, the system wouldn't recover even after I took the hard drive out of it. I also let it sit for a week with the battery out of it. No dice.

So I took it back for a warranty repair. Because it had a 3-year on it, about halfway over.

Guess what? Turned out to be the power brick. Or, at least, the plug wasn't getting power anymore (a multimeter showed zero power, so nothing was getting to the laptop). The strange thing is, I have NEVER had a problem with that brick or that cord before. No jiggling necessary, nothing. And suddenly it goes tits-up.

Oh, well. At least I got a brand-new Kensington power brick out of it. With multiple adaptors, too. For free, thanks to the warranty (there is a reason why laptop warranties are actually worth the money you paid for them!!).
June 25, 2010 11:46:28 AM

good to hear, wifey had a laptop her sister giving her doing the same kind of thing. there was no warranty on i though and to get it looked at and fixed would cost more than the laptop is worth so she got a new toshiba satellite one.
July 2, 2010 12:13:10 AM

Well, in this case it was just the power brick, or the cord leading between it and the computer. The Kensington I got as a warranty replacement was only around $50 brand new, but still it would have been a pain were I to buy it out of warranty.
!