Sign in with
Sign up | Sign in
Your question

Weird Graphic Glitches after CPU Upgrade!

Tags:
Last response: in CPUs
Share
July 19, 2004 3:38:32 PM

Ok guys I need some help troubleshooting, at at my wits end. Here's the situation.

I was running a p3 celeron (66mhz fsb overclock to 83mhz) with 512 MB ram and a Geforce 2 MX and everything was fine.

I needed alittle more power for UT2004 and Battlefield Vietnam so I I got myself a P3 1Ghz (133 FSB). After I installed the processor anytime I use the 3D card the graphics get all weird, like you see missing triangle and stuff. It reminds me of what grpahic glitches you get when you overclock a video card too much.

Mind you all 2D seems absolutly fine and the PC seems stable.

This seems to only happen on anything using D3D. Opengl seems fine as far as I can tell, only tested quake 3.

Here is what I have done so far which doesn't help.

Reinstalled OS and all drivers numerous time
Underclocked Processor and RAM.
Tried a more powerful Power supply and even tried another p3 750 (133 MHZ FSB).

Tried a new video card as well.

The only think that fixed the D3D games is if I go back to the Celeron processor.


I have ran CPU error and memory error tests but nothing is reported.

Does anyone know if the Celerons run alot cooler (even severly overclocked) compare to the normal p3? Both are 1.7v.

My last option will be to underclock the graphics cards becasue my last train of though is that the p3 is running the inside of my case alittle hotter than the Celeron cuasing my graphics card to overheat slight cuasing corrupt graphics.

Any other ideas?
July 19, 2004 3:53:48 PM

Is your AGP bus running within spec now?

Maybe you need to set some jumpers to make the PCI bus run at 33Mhz and the AGP @ 66Mhz?

What motherboard etc do you actually have?

Have you tried different (earlier) versions of the graphics drivers, as well as the latest ones?

AFAIK The celerys don't run <i>that</i> much cooler than the PIIIs of the time - what's your System/CPU temperatures?

---
Epox 8RDA+ V1.1 w/ Custom NB HS
XP1700+ @200x10 (~2Ghz), 1.4 Vcore
2x256Mb Corsair PC3200LL 2-2-2-4
Sapphire 9800Pro @412/740
July 19, 2004 4:07:06 PM

I have no idea what the motherboard is without looking at the manual. It's some cheap board. Not made by any of the big boys like Abit, Epox etc...

The temp of the CPU runs about 29-35 celcius and the motherboard seems to run about the same.

No idea what the video card temp is as i dont have anytype of monitor on that, but it does get pretty warm to the touch. I can hold my finger on it for a minute or two before it's uncomfortable.

I really really like the AGP bus idea, since channging to a non Celeron would effect my FSB which would effect my AGP bus settings. Problem is I'm not sure if I have any type of AGP adjustmenst of this board. I'm at work now so I can't check.

I'll get the name of the board tonight and check the bios for AGP divider settings.

Is there any software that would tell me my AGP divider setting or my AGP bus speed assumming my bios doesn't give me any ideas?
Related resources
July 19, 2004 4:37:37 PM

Not sure what software would tell you that sort of thing.. :eek:  .. Sisoft Sandra maybe?

It's possible that you'd need to move a jumper on the motherboard rather than adjust BIOS settings.

---
Epox 8RDA+ V1.1 w/ Custom NB HS
XP1700+ @200x10 (~2Ghz), 1.4 Vcore
2x256Mb Corsair PC3200LL 2-2-2-4
Sapphire 9800Pro @412/740
July 19, 2004 5:44:09 PM

Yeah, i might need to move a jumper, I need to check the manual tonight. Thanks, the AGP divider seems like the logical next step.
July 20, 2004 12:30:22 PM

Well looked at the motherboard at is doesn't have AGP bus setting in the bios or on the motherboard. I'm screwed. I also can't find any inforamtion about the board or any new bios updates. Its a Supertek ST-693AVMA/E board.

Any new ideas?
July 20, 2004 3:34:52 PM

Does it have a jumper for 66/100/133FSB? It might actually control the AGP/PCI speeds. Make sure it's set to 133 if you have one.

None of the links I can find to Supertek's website actually work, so I can't see the manual myself to check anything.

You said you've tried underclocking - have you tried the PIII @ 66FSB? If that still gave the problem, then it can't be the AGP bus, as it would then be at the same speed as with the celery....

Only other thing I can suggest is to try lots of different video driver versions - try a few earlier detonators (not just the most recent ones)

---
Epox 8RDA+ V1.1 w/ Custom NB HS
XP1700+ @200x10 (~2Ghz), 1.4 Vcore
2x256Mb Corsair PC3200LL 2-2-2-4
Sapphire 9800Pro @412/740
July 21, 2004 1:49:45 PM

No jumpers on the board control the AGP/PCI bus speed.

And the lowest bus speed I can go on the board with a P3 chip is 124mhz.

If I put the Celeron in I can go to 66 ofcourse.

In any case I wanted to post back that I did get the graphics abnomalities fixed. I just set the board's AGP speed to 1X instead of the default 2X.

So to recap, IF I running a Celeron processer I could use 2X AGP without issues. Plug in a P3 I get graphics errors down to 124MHZ FSB setting using 2X AGP. I goto 1X and everything is fine.

So I guess I fixed the problem, not happy going to 1X AGP, but it's not a big deal since the video card has 64MB onboard memory.

Thanks for your help!
July 21, 2004 2:28:47 PM

How strange.

Well, glad you got it working, and I don't think a Gf2 MX will be <i>too</i> crippled by going to 1x AGP... Still better than running a PCI version! :smile:

---
Epox 8RDA+ V1.1 w/ Custom NB HS
XP1700+ @200x10 (~2Ghz), 1.4 Vcore
2x256Mb Corsair PC3200LL 2-2-2-4
Sapphire 9800Pro @412/740
July 21, 2004 5:30:09 PM

Actually I just threw in my Geforce 3 from another PC, so I should be good to go..Thanks
!