Sign in with
Sign up | Sign in
Your question

Memory 8GB installed bios sees 4GB

Last response: in Windows 7
Share
December 6, 2012 12:36:23 PM

New Motherboard ASUS M5A78L-M LX PLUS, bios version 1302 windows 7 Ultimate 64 bit, video ATI Radeon HD 5450. I have installed 8gb of memory and bios reports only 4gb, windows sees 8gb with 4gb usable. I have tried all the usual fixes, updated bios, swapped sticks ( reseated ) install 1 stick at a time to no avail. I can not seem to find any memory remapping switches in bios setup, but something is locking out 2nd 4gb. Any suggestions????
a b $ Windows 7
December 6, 2012 12:45:05 PM

Have you done memtest?

And tried every stick in every slot singly?
m
0
l
December 6, 2012 12:48:23 PM

darth pravus said:
Have you done memtest?

And tried every stick in every slot singly?



Yes did all of the above.
m
0
l
Related resources
December 6, 2012 12:50:24 PM

Make sure your first stick is in socket 1 and the second is in socket 2. They are not right next to each other. You can read the numbers in small print on the board or your motherboard manual will tell you which is which. Should be something like 1, 3, 2, 4. 1 being closest to cpu.
m
0
l
a b $ Windows 7
December 6, 2012 12:51:37 PM

He only has 2 DIMM slots
m
0
l
December 6, 2012 1:03:39 PM

I would look in the bios for an option for dual channel memory and play around with that.

You said both sticks work, but are you certain that both sockets work individually? Try each, 1 at a time.

With both sticks in, I would reseat the cmos battery to force a new hardware detection.

Did you check to see if your ram is on the supported hardware list?

m
0
l
December 6, 2012 1:07:17 PM

Windows sees 8gb with 4gb usable.

- Run MSCONFIG and restore it's defaults.
- Windows loads it's own BIOS when it starts, so you may be able to ignore your BIOS's detected memory count.
m
0
l
December 6, 2012 1:28:50 PM

I have verified that the dimms are correct and both slotys work fine. As I said originally Bios only sees 4gb windows sees 8gb using only 4gb. I reset msconfig to normal and it did not work. I believe the problem is somehow in the bios configuration. I find nothing that leaps out to me that it has to do with memory setup?
m
0
l
a b } Memory
a b $ Windows 7
December 6, 2012 1:44:17 PM

Scott_D_Bowen said:
Windows sees 8gb with 4gb usable.

- Run MSCONFIG and restore it's defaults.
- Windows loads it's own BIOS when it starts, so you may be able to ignore your BIOS's detected memory count.



What? No it doesn't.
m
0
l
a b $ Windows 7
December 6, 2012 1:44:28 PM

Are the sticks running at same speed/voltage?
m
0
l
a b $ Windows 7
December 6, 2012 1:57:29 PM

getochkn said:
Maybe it just doesn't like your brand or kind of memory. Some systems are picky, and your MB seems to list some "qualified vendor" lists for memory and different types needed.

http://www.asus.com/Motherboards/AMD_AM3Plus/M5A78LM_LX...

He said both sticks work individually... they don't work together most likely cause they're running at different volts (1,5v/1,65v) and/or speeds.
m
0
l
December 6, 2012 2:06:53 PM

MSconfig:
Boot tab:
Advanced options:
Uncheck maximum memory box
m
0
l
a b } Memory
a b $ Windows 7
December 6, 2012 2:08:42 PM

Soda-88 said:
He said both sticks work individually... they don't work together most likely cause they're running at different volts (1,5v/1,65v) and/or speeds.


Yes, it could be that but most RAM will switch speeds to the timing of the MB which is usually the lowest speed or default voltage, hell mine is a miss match of 4 different types of sticks, a 4GB, 2GB, 1GB, 1GB and I get all 8GB.

Or just be a picky motherboard/bad design. I remember back in the day, the fun of swapping RAM around and having sticks work fine in 1 system but not the other because 1 system didn't like double sided sticks, etc. They would work 1 at a time, but 2 together wouldn't because of the design of the chip. That's why I pointed that out, just could be a bad design or chipset implemenation.

But the OP didn't specify the brand of each chip and whether they are a matched set or anything, so it could be 2 different types.
m
0
l
December 6, 2012 2:13:05 PM

Or, as i said, his maximum memory box is checked in msconfig
m
0
l
a b $ Windows 7
December 6, 2012 2:29:06 PM

Take both of the sticks of memory out, verify that they are of the same voltage, speed rating, and have the same timings on the labels found on the memory sticks.
Next you want to check what memory slots the board requires you two fit the two memory sicks into.
If one stick is at a lower speed rating, then you will have to manually lower the memory speed in the bios to the lowest setting memory speed.
The bank interleaving option in the bios should be set to Auto not off. As it will cause an error in reading the memory sticks. Make sure the EEC option for the memory is turned off. Make sure the on board graphics chipset of the board is turned off and check the frame buffer size of the memory it is using in the bios, that option uses the system memory so if it is set to 4G then that is why your memory is missing. It is reserved for sole use of the graphics chipset solution of the board. So obviously knock it down or turn it off. If you read the manual it states if you put an ATI card in the Pci-e slot the frame buffer option kicks in meaning it reserves system memory as a frame buffer for the card.


m
0
l
a b } Memory
a b $ Windows 7
December 6, 2012 3:12:30 PM

Wanchopiskado said:
Or, as i said, his maximum memory box is checked in msconfig


How is a checkbox in msconfig going to affect the bios not seeing it? If the bios doesn't see it,the pc can't use it, simple.
m
0
l
December 6, 2012 3:16:35 PM

As the OP said :windows sees 8gb with 4gb usable
m
0
l
December 6, 2012 3:26:49 PM

I don't see in the bios any way to set EEC, frame buffer or disable onboard video. I have a matched set of 4gb memory dimms from kingstone and they show via asus site to be fully compatible.
m
0
l
a b $ Windows 7
December 6, 2012 3:30:05 PM

So if you take a fact windows sees 8Gb, it cannot be using 4gb to run just windows. Something else is reserving a block of memory for its sole use as I said, and if you read the manual it says if you put an Ati card in the system There is a frame buffer option enabled to reserve system memory for the card Doh !
m
0
l
December 6, 2012 3:43:44 PM

weaselman, please I don't want a fight, but I also don't like to be insulted. I have read the manual, now YOU tell me where to the frame buffer and I will try to do it. I find nothing in the bios that identifies with frame buffer. I know I am not stupid but I sure can't find it. Point the way instead of pointing fingers.
m
0
l
a b $ Windows 7
December 6, 2012 3:54:52 PM

It is advice. not and argument, and not an insult at all Its help.
It explains why the ram is missing.
m
0
l
a b $ Windows 7
December 6, 2012 4:01:25 PM

Start on page 2-14 of the manual:

All of this is under the 'Advanced' menu:

Chipset
Northbridge Configuration

DRAM Controller Configuration: Set as indicated

Bank Interleaving <auto>
Node Interleaving <disabled>
Channel Interleaving <auto>
Memory Hole Remapping <Enabled>
Power Down Enable <Enabled>

Internal Graphics: Set as indicated

Primary Video Controller <GFX0>
UMA Frame Buffer Size <32MB> (You have a dedicated video card. You don't need addional framebuffer)
Frame Buffer Location <Above 4G>


Those are the only settings I see that would have an effect.
m
0
l
a b $ Windows 7
December 6, 2012 4:13:45 PM

Thank ex_bubblehea I did try to explain the reason as to the missing memory. since it would use system memory If enabled. There is something about inserting an Ati card and it using system memory also in a lower section. Or memory adress.
m
0
l
a b } Memory
a b $ Windows 7
December 6, 2012 4:16:45 PM

I don't know if this helps but it kind of sounds like the motherboard DMI pool was not updated when the memory was first added and was never refreshed. To fix you have to trigger the BIOS to flush its pool and build another database. Often you can do this by making a hardware change, such as moving a hard drive cable to another port, disable some hardware and then re-enable it. Be sure to select plug and play OS in the bios if you have that setting. Some BIOSs will have options to rebuild the DMI pool, some have utilities you can run. bugs in BIOS versions also prevent proper hardware detection.

- you know that the BIOS plans to build a new DMI pool if you make a change and tell the system to reboot. if the BIOS has to build a new DMI pool, it should force a shutdown that acts like a cold boot rather than a warm boot.

-you could also have a physical problem with the interleave controller in your CPU or where it connect into the CPU socket.

- you could also reduce your memory speed and see if both RAM sticks are correctly detected. Each stick of RAM will cause a capacitance induced timing delay in the circuit. you can have both sticks individually run at 1600MHz in either slot but fail when both slots are in use. (generally, the timing is close, it works while the circuit is cool and fails during use later) low probability of this error in this case but check the lower speed just in case)

- first step would be to get your BIOS to work correctly without involving the OS.
- maybe have your BIOS do full tests rather than the default quick boot tests and see if that detects and updates your memory count in the BIOS

EDIT
- since you can run windows, try and download and run CPUID CPU-z program and
have a look a look of how it reads your memory bank configurations and see if they are as you expect or have set in your BIOS
m
0
l
December 6, 2012 7:29:28 PM

My settings are as follows:
Bank Interleaving <auto>
Node Interleaving <auto>
Channel Interleaving <auto>
Memory Hole Remapping <Enabled>
Power Down Enable <Disabled>

Internal Graphics: Set as indicated

Primary Video Controller <GFX0>
UMA Frame Buffer Size <auto>
Frame Buffer Location <Above 4G>

I have a jumper which clears/resets bios and I did that to force a rescan.

NO JOY

m
0
l
a b $ Windows 7
December 6, 2012 8:28:27 PM

Bugler101 said:
My settings are as follows:
Bank Interleaving <auto>
Node Interleaving <auto>
Channel Interleaving <auto>
Memory Hole Remapping <Enabled>
Power Down Enable <Disabled>

Internal Graphics: Set as indicated

Primary Video Controller <GFX0>
UMA Frame Buffer Size <auto>
Frame Buffer Location <Above 4G>

I have a jumper which clears/resets bios and I did that to force a rescan.

NO JOY



Reread what I posted above and set as I indicated.
m
0
l
December 6, 2012 9:57:28 PM

set as you posted. NO JOY..... Also I have 2 other settings which no one has told me to set. They are Dram Controller : DCT Unganged mode and is set to Always.
and under Internal Graphics: Surround View and set to Auto. Surround view has to do with the ATI graphics card in the PCie x16 slot, But I don't know what it does. the options are auto, disabled and enabled ???
m
0
l
December 9, 2012 10:39:46 AM

still don't see 8gb memory. I tyried playing with Surround View and got my self into a real mess. Had to remove bios batterys and reset bios to get the darn video working again. This is turning into a nightmare. I have done everything suggested with no success. Any suggestions of who I might contact to resolve this?
m
0
l
a b } Memory
a b $ Windows 7
December 9, 2012 6:25:02 PM

force a kernel dump and put your dump on a cloud share, we can look at it with a debugger and see what the BIOS reports to the OS. here is how to force a memory dump:
http://msdn.microsoft.com/en-us/library/windows/hardwar...(v=vs.85).aspx

- many motherboard makers will check to see if the memory is on the Qualified vendor list, if not they tend to give generic advice and punt.

-I suggest the memory dump because some BIOS settings might be ignored or incorrectly stored or read from the BIOS.
m
0
l
!