Sign in with
Sign up | Sign in
Your question

Change Dialog boxes to English

Last response: in Windows 7
Share
December 7, 2012 3:38:25 PM

I am an expat American living in France. I bought my laptop in the US, I have the Windows 7 Home Premium 64bit OS and it is in English. I have my location set to United States through the control panel and all of my system is set to display in English.

My problem is that when I visit english websites that open dialog boxes, the boxes opened are often in French. My current example is I'm trying to update my video card driver through Intel's website. They have a diagnostic tool that scanned my computer and suggested I download drivers and update 2 components. The website was in English and I assume there are files that are all in English. However, when I run the .exe files, the dialog box is all in French -- and I am not fluent.

I am assuming that something is checking my IP address or something. Is there a way to only have these programs display English? I'm not sure if it matters or not, but I am using Google Chrome.

Also, I don't know if I'm articulating the problem very much and I welcome suggestions/questions. All I know is it is frustrating.

More about : change dialog boxes english

a b $ Windows 7
December 7, 2012 4:31:46 PM

just change the language settings to your browser to open english page and some site allow you to download files in your own language
a c 256 $ Windows 7
December 7, 2012 5:48:47 PM

Two different things here. Sounds like your system is properly configured for English.

The other issue is the matter of being located in France and the IP address is causing this issue. Since you are in France, sites are using that location to provide a default language.

Go here for tips on how to configure Chrome:

http://support.google.com/chrome/bin/answer.py?hl=en&an...
Related resources
December 8, 2012 3:40:52 PM

I've checked out the Google Chrome settings and there doesn't seem to be anything to change -- everything is configured as it should be. I believe COLGeek is correct and it's my IP causiing the issue. However, since I don't have a VPN or anything to spoof my IP, I guess I'll just have to live with it.
December 9, 2012 8:04:22 AM

Quote:
in google chrome do you have a place contents that will let you chose the language of the web page you link to ,see this on google chrome in french for settings http://support.google.com/chrome/b [...] swer=95416f


Scout, you sent me the same link as COLGeek, just in French. I don't think there's anything in there to help me.


There are only 3 sections on this link:
Browser interface language -- I've got it set to English.

Webpage language preferences & Default fonts and encodings
This basically addresses problems arising when the language of the webpage is not displaying at all (ie you're seeing little squares instead of text). It allows you to "autodetect" the encoding of a page, which is not a problem for me, as I don't typically view pages in languages with special characters.
I have the encoding set to Unicode (UTF-8), but that shouldn't have to change.


a b $ Windows 7
December 10, 2012 12:27:14 AM

one thing i do when i want to see a page in another language since my system is in french ,i put the name in the search of the complete link and use the translator so i get the page in english ,i am using firefox for that.see this i mark intel driver in the search and google lead me to this page and if i click the download center i got the english page http://www.google.ca/#hl=fr&gs_nf=3&gs_rn=0&gs_ri=serp&... hope that could help you
!