Sign in with
Sign up | Sign in
Your question

BCD/Bootloader Screwed

Last response: in Windows 7
Share
December 8, 2012 2:29:46 PM

This all started with installing grub to the wrong partition (ahem, the windows partition instead of the device. whoops.)...reinstall grub onto the device, mint can boot just fine.

Try to boot into windows using grub, just sits there with the blinking underscore unable to find it. Boot in with recovery dvd, hit repair; it doesn't identify the installation.

go in with repair console, bootrec /scanos CAN find it.

run /fixmbr, it "works," /fixboot throws an error. reboot shows that it correctly ran over grub like a freight train, now the error is "missing operating system."

back into recovery console, bootrec /rebuildbcd throws an error about corrupted disk or it can't see it-- run chkdsk /F and it fixes some, but /rebuildbcd throws same error.

/scanos still finds windoze.
automatic repair didn't work (of course).
going into c:\ in console shows all my files still there, hanging out.

Any ideas?

More about : bcd bootloader screwed

December 8, 2012 9:14:32 PM

I started at step 5:
/rebuildbcd SAW the installation, so I did "yes" to add it to boot list, then it spat out this error:

"The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted."

I really don't think it's a problem with the device driver, because I can cd into C: and see everything...

And I just ran chkdsk /F on C and it found no problems.
m
0
l
Related resources
January 28, 2013 3:05:37 AM

I'm having a very similar problem, but I'm dual-booting Mac OSX Mountain Lion (hackintosh) and Windows 8. I need to boot into safe mode to solve an unrelated driver issue, but can't because my BCD file seems to be missing. No OS is listed in the boot tab of msconfig, and the repair console fails to reboot into safe mode as well.

I've tried the guide you linked, and I'm stuck at the same spot the OP is. I can boot into regular (non-safe mode) Windows fine, though.
m
0
l
January 28, 2013 4:30:39 PM

I never found a solution to this problem. I tried just about every repair tool imaginable. I ended up just pulling *** off from a live CD and nuking the installation from orbit.

Protip; never let grub install onto your Windows partition instead of the device. bad things happen!
m
0
l
March 1, 2013 4:40:28 AM

next time just run bcdboot C:\windows (assuming ur windows drive is C:\) that should fix any issues oh and of course run this in command prompt off the windows 8 installation disk :) 
m
0
l
!