Sign in with
Sign up | Sign in
Your question
Solved

AMD A10 with Windows 7

Last response: in Windows 7
Share
December 12, 2012 1:34:21 AM

Hello all, I'm a new member here but a long time AMD user. Last week, I purchased some components to build a HTPC. My CPU is the A10-5800k. The assembly went together well up until I started installing Windows 7 64 bit. The OS will install fine onto the ssd, but after it reboots it stays stuck at the "Setup is preparing your computer for it's first use" screen. I've tried all of the things from the Microsoft site, and nothing is working. I did read somewhere that it could be a problem with Windows 7 not having a current driver for the CPU/video card combo. I installed XBMCbuntu and it ran fine. Has anyone else experienced the same problems as I have? If so, what did you have to do to get it installed? Thanks in advance for any help that any of you guys may have!

More about : amd a10 windows

Best solution

December 12, 2012 1:45:08 AM

set your SATA ports to native IDE in the BIOS until you get up and running then load the SATA driver from your motherboard manufacturer once win 7 is completed...

Problem is when you started the setup, you didnt load the AHCI SATA driver.. You def want to make sure you load the AHCI driver in win7 when it's installed... reboot, then enable AHCI on the SATA ports in the BIOS, or restart your intall again and make sure you load the SATA drive when asked if you have any drivers required for install
Share
December 12, 2012 1:51:49 AM

Thanks Madbiker. I'll try that tomorrow.
m
0
l
Related resources
December 12, 2012 6:38:54 PM

That worked like a charm! Thank you, Madbiker!
m
0
l
December 12, 2012 6:39:05 PM

Best answer selected by joelstradamus.
m
0
l
!