Sign in with
Sign up | Sign in
Your question

seting up port fowarding

Last response: in Networking
Share
September 17, 2004 11:22:24 PM

Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.broadbandnet.hardware (More info?)

i recently purchased a microsoft router and connected it to my home
network, everything seems to be workin fine, however i would now like
to enable port-fowarding so that i can access my linux box outside of
my network via SSH. I know that the port for SSH is port 22. In the
"Application-Triggered Port Forwarding" section of the web-based
management tool, i have SSH as one of the fields with outbound and
inbound port set as 22. Also in the "Persistent Port Forwarding"
section i have a field for ssh setup with inbound port as 22, private
IP address set to: 192.168.2.2 (the computer that host the ssh
server(my linux box)) type TCP and private port set to 22 as well. Can
someone help me get this working...thanks in advance.

More about : seting port fowarding

September 18, 2004 12:29:29 AM

Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.broadbandnet.hardware (More info?)

Well because application port forwarding is only to be used when you
send data on one port & get a response on a different port you shouldn't
even be using it for that application.

Second off I don't see how this could possibly be on topic for the
"microsoft.public.windowsxp.work_remotely" newsgroup as this is a router
& Linux issue not a Windows XP issue of any sort.

So only use persistent port forwarding to the IP address of the linux
box that your are going to ssh into.

Also when you try to connect are you behind the router or connecting to
the Internet using something else?

What if the firmware version on your router?

Which Microsoft router are you using?

Avi wrote:

> i recently purchased a microsoft router and connected it to my home
> network, everything seems to be workin fine, however i would now like
> to enable port-fowarding so that i can access my linux box outside of
> my network via SSH. I know that the port for SSH is port 22. In the
> "Application-Triggered Port Forwarding" section of the web-based
> management tool, i have SSH as one of the fields with outbound and
> inbound port set as 22. Also in the "Persistent Port Forwarding"
> section i have a field for ssh setup with inbound port as 22, private
> IP address set to: 192.168.2.2 (the computer that host the ssh
> server(my linux box)) type TCP and private port set to 22 as well. Can
> someone help me get this working...thanks in advance.
September 18, 2004 4:40:44 AM

Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.broadbandnet.hardware (More info?)

sorry for posting into the wrong group. Here is my router's info.

Microsoft Wireless base station MN-500

Current Base Station Firmware Version
Version: V1.00.072
Date: 07-30-2002


joker <no-spam@netzero.com> wrote in message news:<u0UkOdSnEHA.3352@TK2MSFTNGP15.phx.gbl>...
> Well because application port forwarding is only to be used when you
> send data on one port & get a response on a different port you shouldn't
> even be using it for that application.
>
> Second off I don't see how this could possibly be on topic for the
> "microsoft.public.windowsxp.work_remotely" newsgroup as this is a router
> & Linux issue not a Windows XP issue of any sort.
>
> So only use persistent port forwarding to the IP address of the linux
> box that your are going to ssh into.
>
> Also when you try to connect are you behind the router or connecting to
> the Internet using something else?
>
> What if the firmware version on your router?
>
> Which Microsoft router are you using?
>
> Avi wrote:
>
> > i recently purchased a microsoft router and connected it to my home
> > network, everything seems to be workin fine, however i would now like
> > to enable port-fowarding so that i can access my linux box outside of
> > my network via SSH. I know that the port for SSH is port 22. In the
> > "Application-Triggered Port Forwarding" section of the web-based
> > management tool, i have SSH as one of the fields with outbound and
> > inbound port set as 22. Also in the "Persistent Port Forwarding"
> > section i have a field for ssh setup with inbound port as 22, private
> > IP address set to: 192.168.2.2 (the computer that host the ssh
> > server(my linux box)) type TCP and private port set to 22 as well. Can
> > someone help me get this working...thanks in advance.
Related resources
September 18, 2004 12:17:28 PM

Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.broadbandnet.hardware (More info?)

You should update your firmware then. The latest version 1.11.017 Haas
loop back support which versions prior to 1.09.* didn't have.

Avi wrote:
> sorry for posting into the wrong group. Here is my router's info.
>
> Microsoft Wireless base station MN-500
>
> Current Base Station Firmware Version
> Version: V1.00.072
> Date: 07-30-2002
>
>
> joker <no-spam@netzero.com> wrote in message news:<u0UkOdSnEHA.3352@TK2MSFTNGP15.phx.gbl>...
>
>>Well because application port forwarding is only to be used when you
>>send data on one port & get a response on a different port you shouldn't
>>even be using it for that application.
>>
>>Second off I don't see how this could possibly be on topic for the
>>"microsoft.public.windowsxp.work_remotely" newsgroup as this is a router
>>& Linux issue not a Windows XP issue of any sort.
>>
>>So only use persistent port forwarding to the IP address of the linux
>>box that your are going to ssh into.
>>
>>Also when you try to connect are you behind the router or connecting to
>>the Internet using something else?
>>
>>What if the firmware version on your router?
>>
>>Which Microsoft router are you using?
>>
>>Avi wrote:
>>
>>
>>>i recently purchased a microsoft router and connected it to my home
>>>network, everything seems to be workin fine, however i would now like
>>>to enable port-fowarding so that i can access my linux box outside of
>>>my network via SSH. I know that the port for SSH is port 22. In the
>>>"Application-Triggered Port Forwarding" section of the web-based
>>>management tool, i have SSH as one of the fields with outbound and
>>>inbound port set as 22. Also in the "Persistent Port Forwarding"
>>>section i have a field for ssh setup with inbound port as 22, private
>>>IP address set to: 192.168.2.2 (the computer that host the ssh
>>>server(my linux box)) type TCP and private port set to 22 as well. Can
>>>someone help me get this working...thanks in advance.
September 29, 2004 1:05:25 AM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

Joker

You told that data is sent in one port and received in a
different port

How do I set up port forwarding to run a ftp server to
work in passive mode ?

I´ve configured my ftp server software to work with
passive ports 5000-5049 and in my MN700 base setup I´ve
configured a persistant forward ports 5000-5049 to
private ports 5000-5049 and port 21 to private port 21 to
my internal IP address.

I can connect and client and server are talking, but I
can´t list ftp content or establish a file tranfer.

I´ve noticed that server answers the PASV command with
the correct port (5000), but client receives a different
answer (port 1024).

What am I doing wrong ?

Thanks

Jorge


>-----Original Message-----
>Well because application port forwarding is only to be
used when you
>send data on one port & get a response on a different
port you shouldn't
>even be using it for that application.
>
>Second off I don't see how this could possibly be on
topic for the
>"microsoft.public.windowsxp.work_remotely" newsgroup as
this is a router
>& Linux issue not a Windows XP issue of any sort.
>
>So only use persistent port forwarding to the IP address
of the linux
>box that your are going to ssh into.
>
>Also when you try to connect are you behind the router
or connecting to
>the Internet using something else?
>
>What if the firmware version on your router?
>
>Which Microsoft router are you using?
>
>Avi wrote:
>
>> i recently purchased a microsoft router and connected
it to my home
>> network, everything seems to be workin fine, however i
would now like
>> to enable port-fowarding so that i can access my linux
box outside of
>> my network via SSH. I know that the port for SSH is
port 22. In the
>> "Application-Triggered Port Forwarding" section of the
web-based
>> management tool, i have SSH as one of the fields with
outbound and
>> inbound port set as 22. Also in the "Persistent Port
Forwarding"
>> section i have a field for ssh setup with inbound port
as 22, private
>> IP address set to: 192.168.2.2 (the computer that host
the ssh
>> server(my linux box)) type TCP and private port set to
22 as well. Can
>> someone help me get this working...thanks in advance.
>
>.
>
!